Contents

1. Basic Skills .................................................. 1
   Mouse Skills .................................................. 2
     ♦ To Click .................................................. 2
     ♦ To Double-Click ........................................... 2
     ♦ To Drag .................................................. 2
   Basic Keyboard Skills ......................................... 3
   Overview of the Desktop ....................................... 4
   Working with Windows ......................................... 9
     Window Frame Controls ...................................... 9
       ♦ To Open an Application Window ........................ 11
       ♦ To Close an Application Window ........................ 12
       ♦ To Turn a Window into an Icon ........................ 12
       ♦ To Restore a Window from an Icon ...................... 13
       ♦ To Move a Window or Window Icon ....................... 13
       ♦ To Resize a Window ..................................... 14
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>To Bring a Window or Icon Forward</td>
<td>15</td>
</tr>
<tr>
<td>To Copy and Paste Text into Windows</td>
<td>15</td>
</tr>
<tr>
<td>Using Workspaces</td>
<td>16</td>
</tr>
<tr>
<td>To Display Another Workspace</td>
<td>16</td>
</tr>
<tr>
<td>To Place a Window in Other Workspaces</td>
<td>17</td>
</tr>
<tr>
<td>To Rename a Workspace</td>
<td>18</td>
</tr>
<tr>
<td>Using Controls in Application Windows</td>
<td>19</td>
</tr>
<tr>
<td>To Choose a Push Button</td>
<td>19</td>
</tr>
<tr>
<td>To Select a Check Box or Radio Button</td>
<td>20</td>
</tr>
<tr>
<td>To Scroll the Contents of a Window</td>
<td>21</td>
</tr>
<tr>
<td>To Select a List Item</td>
<td>22</td>
</tr>
<tr>
<td>To Enter Text into an Empty Field</td>
<td>23</td>
</tr>
<tr>
<td>To Edit Text in a Field</td>
<td>24</td>
</tr>
<tr>
<td>Using Menus</td>
<td>25</td>
</tr>
<tr>
<td>Window Menu</td>
<td>26</td>
</tr>
<tr>
<td>Workspace Menu</td>
<td>28</td>
</tr>
<tr>
<td>To Choose a Window Menu Item</td>
<td>29</td>
</tr>
<tr>
<td>To Choose a Workspace Menu Item</td>
<td>29</td>
</tr>
<tr>
<td>To Choose a Menu Item with the Mouse</td>
<td>30</td>
</tr>
<tr>
<td>To Choose a Menu Item with the Keyboard</td>
<td>30</td>
</tr>
<tr>
<td>Leaving the Desktop</td>
<td>31</td>
</tr>
<tr>
<td>To Log Out</td>
<td>31</td>
</tr>
<tr>
<td>To Lock Your Display</td>
<td>32</td>
</tr>
<tr>
<td>Getting Help</td>
<td>32</td>
</tr>
</tbody>
</table>
Help Menu ......................................................... 33
♦ To Display the Help Manager .............................. 33

2. Starting a Desktop Session ................................. 35
Starting and Ending a Desktop Session .................. 35
♦ To Log In to a Desktop Session ......................... 36
♦ To Log Out .................................................... 36
♦ To Use a Session in a Different Language. ............ 36
Starting a Failsafe Session .................................... 37
♦ To Log In to a Failsafe Session .......................... 37
♦ To Log Out of a Failsafe Session ....................... 37
Starting a Command-Line Session ....................... 37
♦ To Log In to and Out of a Command-Line Session .. 38
Using a Home Session .......................................... 38
♦ To Save a Home Session .................................. 38
♦ To Automatically Start the Home Session at Login . 39
♦ To Choose between the Current and Home Session for Each Session ......................... 39

3. Getting Help .................................................... 41
Requesting Help ................................................. 42
Press F1 — The Help Key ..................................... 42
Using an Application's Help Menu ....................... 42
On Item Application Help .................................... 43
Using Help Manager ........................................... 44
Using Help Windows .......................................... 45
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selecting Help Topics</td>
<td>46</td>
</tr>
<tr>
<td>Using the Topic Tree</td>
<td>46</td>
</tr>
<tr>
<td>Using Hyperlinks</td>
<td>47</td>
</tr>
<tr>
<td>What Hyperlinks Look Like</td>
<td>47</td>
</tr>
<tr>
<td>Links That Display a New Window</td>
<td>48</td>
</tr>
<tr>
<td>Moving between Help Topics</td>
<td>48</td>
</tr>
<tr>
<td>Help Pop-up Menu</td>
<td>49</td>
</tr>
<tr>
<td>Knowing Where You Are</td>
<td>49</td>
</tr>
<tr>
<td>Browsing between Different Help Volumes</td>
<td>50</td>
</tr>
<tr>
<td>Knowing Where You've Been</td>
<td>51</td>
</tr>
<tr>
<td>Searching for Specific Information</td>
<td>51</td>
</tr>
<tr>
<td>♦ To Search for Topics Using the Help Index</td>
<td>52</td>
</tr>
<tr>
<td>Pattern Searches</td>
<td>54</td>
</tr>
<tr>
<td>Browsing Help on Your System</td>
<td>54</td>
</tr>
<tr>
<td>♦ To Open Help Manager</td>
<td>55</td>
</tr>
<tr>
<td>♦ To Duplicate a Help Window</td>
<td>57</td>
</tr>
<tr>
<td>Displaying a Man Page</td>
<td>57</td>
</tr>
<tr>
<td>♦ To Display a Man Page</td>
<td>58</td>
</tr>
<tr>
<td>Printing Help Topics</td>
<td>58</td>
</tr>
<tr>
<td>♦ To Print a Help Topic</td>
<td>59</td>
</tr>
<tr>
<td>Printing Configuration</td>
<td>60</td>
</tr>
<tr>
<td>Modifying Help Window Colors</td>
<td>60</td>
</tr>
<tr>
<td>♦ To Change Help Window Colors for an Application</td>
<td>61</td>
</tr>
<tr>
<td>4. Using the Front Panel</td>
<td>63</td>
</tr>
</tbody>
</table>
Front Panel Elements .......................... 63
Main Panel .................................. 63
Subpanels .................................. 64
The Workspace Switch ......................... 65
Basic Front Panel Skills ....................... 65
  ♦ To Activate a Front Panel Control ...... 65
  ♦ To Open a Subpanel ................... 65
  ♦ To Close a Subpanel .................. 66
Front Panel Pop-Up Menus .................... 66
  Contents of the Pop-Up Menus .......... 67
Front Panel Help ............................ 70
  ♦ To Move the Front Panel or a Subpanel 70
  ♦ To Minimize the Front Panel ...... 71
A Tour of the Front Panel ...................... 71
  The Main Panel .......................... 72
  Personal Applications Subpanel ........ 74
  Personal Printers Subpanel .......... 75
  Help Subpanel .......................... 76
Customizing the Front Panel ................. 77
  ♦ To Put a Subpanel Control in the Main Panel ... 77
  ♦ To Add an Application or Other Icon to a Subpanel 78
    How Installed Icons Work .......... 78
Adding and Removing Subpanels .............. 78
  ♦ To Replace a Control in the Main Panel .... 79
5. Managing Files with File Manager

Introducing the File Manager Window and Desktop

Basic File System Concepts
Files
Folders
Objects
Paths

Basic File Management Skills
- To Select a Single File or Folder
- To Select Multiple Files and Folders
- To Drag and Drop a File or Folder
  Basic Drag-and-Drop Tasks
- To Display a Pop-up Menu
- To Rename a File or Folder
- To Get Help on a File or Folder

Opening a File or Folder

Manipulating Files and Folders
- To Create a New File or Folder
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>To Move a File or Folder</td>
<td>96</td>
</tr>
<tr>
<td>To Copy a File or Folder</td>
<td>97</td>
</tr>
<tr>
<td>To Create a Symbolic Link</td>
<td>98</td>
</tr>
<tr>
<td>Navigating to Folders and Subfolders</td>
<td>99</td>
</tr>
<tr>
<td>To Change to Another Folder</td>
<td>99</td>
</tr>
<tr>
<td>To Go to Your Home Folder</td>
<td>100</td>
</tr>
<tr>
<td>To Change to the Parent Folder</td>
<td>100</td>
</tr>
<tr>
<td>To Open a Terminal Window in the Current Folder</td>
<td>100</td>
</tr>
<tr>
<td>Executing an Action for a File or Folder</td>
<td>100</td>
</tr>
<tr>
<td>To Execute the Default Action</td>
<td>101</td>
</tr>
<tr>
<td>To Execute Other Actions</td>
<td>101</td>
</tr>
<tr>
<td>Deleting Objects to the Trash Can</td>
<td>102</td>
</tr>
<tr>
<td>To Open the Trash Can Window</td>
<td>102</td>
</tr>
<tr>
<td>To Put an Object in the Trash Can</td>
<td>102</td>
</tr>
<tr>
<td>To Put Back a File or Folder from the Trash Can</td>
<td>102</td>
</tr>
<tr>
<td>To Delete a File or Folder Permanently</td>
<td>103</td>
</tr>
<tr>
<td>File Ownership and Security</td>
<td>103</td>
</tr>
<tr>
<td>Who Has Access?</td>
<td>103</td>
</tr>
<tr>
<td>Types of Access Permissions</td>
<td>104</td>
</tr>
<tr>
<td>Default Permissions</td>
<td>105</td>
</tr>
<tr>
<td>To Change the Owner of a File or Folder</td>
<td>105</td>
</tr>
<tr>
<td>To Change the Permissions on a File or Folder</td>
<td>105</td>
</tr>
<tr>
<td>Using File Manager Objects on the Desktop</td>
<td>106</td>
</tr>
<tr>
<td>To Put a File or Folder on the Workspace Backdrop</td>
<td>107</td>
</tr>
</tbody>
</table>
♦ To Display the Pop-up Menu for a Workspace Object 107
♦ To Remove an Object from the Workspace ........ 108

Locating Files ................................................. 108
♦ To Find an Object by Name ......................... 109
♦ To Find a File by Contents ....................... 110

Customizing File Manager Views .................. 111
♦ To Configure the Headers ....................... 111
♦ To Configure How Icons are Placed .......... 112

Using the Tree View ...................... 112
♦ To Display the Tree View ................. 113
♦ To Display the Folder View .................. 114
♦ To Change How Objects Are Represented 115
♦ To Change the Order Icons Are Sorted .... 115
♦ To Re-Sort (Clean Up) Objects .............. 116
♦ To Save the Current Preferences as Your Default ... 116

Hiding Files and Folders ......................... 117
♦ To Show or Hide Files and Folders .......... 117
♦ To Specify Which Data Types Are Hidden .. 117

Icon Browsing ........................................ 118
♦ To Change the Icon Display Area Size .... 119

6. Running Applications from the Desktop .... 121

Running Applications Using Application Manager .... 121
♦ To Open Application Manager ................. 122

Application Manager Window .................. 122
Contents of Application Manager ................. 123
Built-In Application Groups ..................... 124
Application Manager Menus and Commands .... 124
♦ To Run an Application from Application Manager . 124
♦ To Get Help on an Application Icon ............ 126
♦ To Put an Application Icon in the Front Panel .. 126
♦ To Put an Application Icon on the Workspace Backdrop 127
♦ To Update Application Manager .................. 127
♦ To Create a Personal Application Group .......... 127
♦ To Add Applications to a Personal Application Group 128
Advanced Application Manager Concepts .......... 128
File Names in Application Manager ............... 128
Folder Location of Application Manager ......... 129
Creating Personal Actions and Data Types ...... 130
Registering Applications ......................... 132
Running Applications Using File Manager ....... 132
♦ To Run an Application from File Manager ....... 132
Running and Organizing Applications Using the Front Panel 133
♦ To Put an Application in the Personal Applications Subpanel ................................... 133
♦ To Run an Application from the Personal Applications Subpanel ................................... 134
♦ To Replace the Main Panel Personal Applications Control ......................................... 134
Mailer Main Window ........................................... 154

Viewing and Acting On Your Mail Messages ............ 155

♦ To Read a Mail Message. ............................... 155

Sorting Mail Messages ...................................... 156

♦ To Reply to a Message ................................. 156

♦ To Forward a Message ................................. 157

♦ To Save a Message as Text ....................... 157

♦ To Find a Mail Message within a Mailbox ....... 157

♦ To Delete a Mail Message ......................... 158

♦ To Undelete a Mail Message .................... 159

♦ To Destroy Deleted Messages When Closing the Mailbox 159

Sending Mail Messages ...................................... 159

Using Aliases ................................................. 160

♦ To Address, Compose, and Send a Mail Message .. 160

Editing Text in a Mail Message .......................... 162

Formatting Text in a Mail Message ..................... 163

♦ To Include a Template in a Mail Message ....... 165

♦ To Include Multiple Messages in a New Message .. 165

♦ To Include a Text File in a Mail Message ......... 165

♦ To Send an Automatic Message (Vacation Mail) . 166

♦ To Send Mail Messages in MIME or Sun Format .. 166

♦ To Find or Change Text in Your Message ......... 167

♦ To Check Spelling in Your Mail Message ........... 167
Creating and Using Mailboxes .......................... 168

♦ To Edit Text in Message View ...................... 168

♦ To Create a Mailbox ................................. 168

♦ To Open a Mailbox .................................... 169

♦ To Close a Mailbox ................................... 169

♦ To File a Message in Other Mailboxes ............ 169

♦ To Remove a Mailbox from Your File System ...... 170

♦ To Drag and Drop Messages to Other Mailboxes ... 170

♦ To Add Mailboxes to the Move and Copy To Menus . 170

♦ To Display Recently Visited Mailboxes in the Move Menu 171

Printing Mail Messages ................................. 171

♦ To Print a Message with Default Options .......... 171

♦ To Print a Message with Specific Options .......... 171

♦ To Print a Message Using Drag and Drop .......... 172

Working with Attachments .............................. 172

♦ To View an Attachment .............................. 172

♦ To Print an Attachment .............................. 173

♦ To Add an Attachment ............................... 173

♦ To Save an Attachment to Your File System ....... 174

♦ To Delete both an Attachment and the Mail Message 174

♦ To Attach a File from File Manager ................. 174

♦ To Attach a Calendar Appointment ................ 175

Customizing Mailer ................................. 175
Contents

♦ To Display Message Numbers in Your Mailbox........ 176
♦ To Change the Character Marker for Included Text in a
  Reply.......................................................... 176
♦ To Set How Often Mailer Checks for Messages........ 177
Creating Templates ........................................... 177
♦ To Add Custom Fields to Your Format Menu........... 178
Opening and Saving ........................................... 178
Mailer Keyboard and Menu Shortcuts .................... 180

9. Printing......................................................... 183
Your Default Printer .......................................... 183
♦ To Determine the Default Printer ........................ 184
♦ To Change the Default Printer ............................ 184
Printing Files..................................................... 184
  Submitting a File to a Printer ............................ 185
♦ To Print Using the Front Panel ........................... 185
♦ To Print Using File Manager ............................... 186
♦ To Print Using Print Manager ............................. 187
Setting Print Options Using the Print Dialog Box...... 187
  Print Command Options ................................... 189
Printer Applications .......................................... 189
Print Manager ................................................... 189
Printer Jobs Application .................................... 191
Displaying Print Job Information ........................... 192
♦ To Open a Printer Icon ..................................... 192
♦ To Close a Printer Icon
♦ To Find a Print Job
♦ To Cancel a Print Job

Print Job Properties

Printers and the Front Panel
♦ To Change the Front Panel Printer
♦ To Add a Printer to the Personal Printers Subpanel

Changing the Print Manager Display
♦ To Change How Printers and Print Jobs Are Displayed
♦ To Change the Update Frequency
♦ To Determine Which Jobs Are Displayed
♦ To Display the Print Manager Message Line
♦ To Display the Print Manager Problem Flag
♦ To Determine Which Printers Are Shown

Printer Properties
♦ To Show a Printer’s Properties
♦ To Change a Printer’s Icon
♦ To Change a Printer’s Icon Label

10. Using Text Editor

Opening and Closing Text Editor
♦ To Open Text Editor
♦ To Close Text Editor

Text Editor Window
Contents

♦ To Display the Status Line 203

Opening and Saving Documents 204
♦ To Create a New Document 204
♦ To Save a Document to a New File 204
♦ To Save a Document to the Original File 205

Opening an Existing Document 206

Entering Text 208
♦ To Enter New Text 208

Using Wrap To Fit 208

Entering Special Characters 209

Moving the Cursor in a Document 209
♦ To Go to a Specific Line 210
♦ To Scroll a Document 210

Selecting Text 210
♦ To Select Text with the Mouse 211
Secondary Selection 211
♦ To Select Text with the Keyboard 212

Editing Text 212

Editing Keys 212

Menu Shortcut Keys 213
UNIX Key Bindings 213
♦ To Set Overstrike Mode 214
♦ To Type Over Text 214
♦ To Delete Text 214
♦ To Clear Text ........................................... 215
♦ To Undo an Edit ...................................... 215
♦ To Copy Text ........................................... 215
♦ To Move Text (Cut and Paste) ..................... 216
♦ To Correct Misspelled Words ..................... 216
♦ To Include a File ..................................... 217
Using Drag and Drop ................................. 219
♦ To Move Text Using Drag and Drop ............. 219
♦ To Copy Text Using Drag and Drop .............. 219
♦ To Include a File Using Drag and Drop ......... 219
Searching a Document .............................. 220
♦ To Find Text .......................................... 220
♦ To Find and Change Text............................ 220
♦ To Find and Delete Text ............................. 221
Formatting and Printing Documents ............... 221
♦ To Format a Document .............................. 222
♦ To Print an Open Document ...................... 222
♦ To Print a Closed Document ..................... 223
Recovering a File ..................................... 224
♦ To Recover a File .................................... 224
Text Editor and Other Applications ............... 224
11. Using Calendar .................................... 225
♦ To Start Calendar .................................... 225
Calendar Main Window ............................... 226
Calendar Tool Bar ........................................ 227
Calendar Views ........................................ 228
Day View .................................................. 228
Week View ............................................... 229
Month View .............................................. 230
Year View ............................................... 231
Appointments ............................................ 231
♦ To Schedule a Basic Appointment .............. 231
♦ To Set Appointment Options ...................... 232
♦ To Change an Appointment ....................... 233
♦ To Delete an Appointment ......................... 233
♦ To Find an Appointment ............................ 234
♦ To View an Appointment List ..................... 234
To Do Items .............................................. 235
♦ To Insert a To Do Item .............................. 235
♦ To Change a To Do Item ............................ 236
♦ To Delete a To Do Item ............................. 236
♦ To View a To Do List ............................... 236
Marking To Do Items Completed .................. 237
Printing Calendars, Appointment, or To Do Lists .... 238
♦ To Print Current Day, Week, Month, or Year Views . 238
♦ To Print Your Appointment or To Do List .......... 238
♦ To Change the Print Options for a Single Print Job . 239
Browsing Calendars on a Network .................. 239
♦ To Obtain the Names of Other Calendars ........ 240
♦ To Add or Delete Calendars in the Browse List .... 240
♦ To Determine Whether You Have Access to Other
  Calendars .................................................. 241
Scheduling Appointments on Other Calendars ....... 241
♦ To Schedule a Group Appointment .............. 241
♦ To Mail Reminders to a Group Using Calendar .... 242
♦ To Create an Appointment Message Using a Mail
  Program ................................................... 243
♦ To Drag an Appointment from Another Application to
  Calendar ................................................. 244
♦ To Drag an Appointment from Calendar to Another
  Application ............................................... 245
Customizing Calendar .................................. 246
♦ To Change Appointment Editor Defaults ......... 246
Changing the Display Settings ....................... 247
♦ To Change Access and Permissions ............... 248
♦ To Change the Printer Settings for Future Print Jobs 252
♦ To Change the Date Format ......................... 253
♦ To Change the Default Time Zone ................. 253
Accessing Calendar through a Command-Line Interface . 254
dtcm_editor .............................................. 254
dtcm_lookup ............................................. 255
dtcm_insert ............................................. 255
dtcm_delete ............................................ 256
dtcm ........................................................ 256
12. Using Terminal ........................................... 257

Default Desktop Terminal Emulator ......................... 258
Starting a Terminal Window ................................. 258
♦ To Close a Terminal Window .............................. 261
Using a Terminal Window ................................... 261
♦ To Start Applications in a Terminal Window .......... 261
♦ To Enter a Command ..................................... 262
♦ To Copy and Paste Text ................................. 262
♦ To Resize the Window Contents ......................... 263

Running dtterm on Another System ......................... 263
Using the -display Option .................................. 263
Using rlogin ................................................. 264
Using remsh ................................................. 264

Customizing dtterm ........................................ 265
Displaying the Menu Bar ................................... 265
Displaying the Scroll Bar ................................... 266
dtterm Global Options ..................................... 266
Cursor Control .............................................. 267
Bell Control ............................................... 270
dtterm Terminal Options ................................... 271
Keyboard Control .......................................... 272
Screen Control ........................................... 275

Terminal Control Characters ................................. 277
♦ To Set Terminal Control Characters ................. 277
13. Using Icon Editor ........................................... 279
   ♦ To Start Icon Editor ........................................ 281

Basic Drawing Tasks ........................................ 282
   ♦ To Open an Existing Icon ............................... 282
   ♦ To Start a New Icon ..................................... 282
   ♦ To Clear an Icon ........................................... 283
   ♦ To Draw an Image ......................................... 283

Drawing Tools ................................................ 283
   ♦ To Undo a Drawing Operation ......................... 285

Saving Icon Files ............................................. 285
   Icon Size Conventions .................................... 286
   ♦ To Save the Icon ........................................... 286
   ♦ To Save the Icon with a New Name .................. 287

Color Usage .................................................... 287

Advanced Drawing Tasks .................................... 288
   ♦ To Select an Area of the Icon .......................... 288
   ♦ To Cut a Region of the Icon ............................ 288
   ♦ To Copy a Region of the Icon ........................... 288
   ♦ To Move a Region of the Icon ........................... 289
   ♦ To Rotate Part of the Icon .............................. 289
   ♦ To Flip (Mirror) Part of the Icon ..................... 289

Resizing Icons ............................................... 290

Hotspots ....................................................... 290
Screen Captures .............................................. 291
Modifying the View of an Icon ......................... 292

A. Keyboard Shortcuts for the Desktop .............. 293
  ♦ To Open an Application Window ................. 296
  ♦ To Close an Application Window ............... 296
  ♦ To Select a Window or Icon ................. 297
  ♦ To Turn a Window into an Icon (Minimize) .... 297
  ♦ To Restore a Window from an Icon ............ 297
  ♦ To Move a Window or Window Icon .......... 298
  ♦ To Resize a Window ................................. 298
  ♦ To Scroll a Window's Contents ............... 298
  ♦ To Select a List Item ............................... 299
  ♦ To Display a Pull-down Menu ................. 299
  ♦ To Use a Pop-up Menu ......................... 299
  ♦ To Use the Window Menu ....................... 300
  ♦ To Switch to Another Workspace .............. 300
  ♦ To Rename a Workspace ......................... 300
  ♦ To Move among Windows ....................... 301
  ♦ To Display a Window in Other Workspaces .... 301
  ♦ To Choose a Front Panel Control .............. 301
  ♦ To Choose a Subpanel Control ................. 302
  ♦ To Move the Front Panel ....................... 302
  ♦ To Get Help in Any Window .................... 302
  ♦ To Choose a Help Topic Hyperlink ............. 303
B. Running Localized Sessions .......................... 305
   ♦ To Create or Edit a Language-Specific File ........ 306
   ♦ To Specify Fonts from the Command Line .......... 308
   ♦ To Specify Fonts within a Resource File .......... 309
Glossary .................................................. 313
Index ...................................................... 337
Preface

The Common Desktop Environment: User’s Guide describes the basic features of the Common Desktop Environment (CDE). It describes how to use the desktop and desktop applications.

How This Book Is Organized

This book contains the following chapters:

Chapter 1, “Basic Skills,” describes the basic skills you need to work with the Common Desktop Environment, keyboard navigation, and some common interface aspects of the desktop.

Chapter 2, “Starting a Desktop Session,” describes how to log in to and out of the desktop, and how to set the session that will appear at login.

Chapter 3, “Getting Help,” explains how to get help about an application and how to navigate within the help viewer.

Chapter 4, “Using the Front Panel,” describes the Front Panel, a special desktop window that contains a set of controls for doing common tasks. It explains the Front Panel controls and how to customize the Front Panel.

Chapter 5, “Managing Files with File Manager,” explains how to work with files and folders in the graphical user interface File Manager. It describes basic skills, navigation, manipulating and locating files and folders, and the Trash Can.
Chapter 6, “Running Applications from the Desktop,” explains how to run applications from the desktop using Application Manager, File Manager, the Front Panel, and terminal emulator windows.

Chapter 7, “Customizing the Desktop Environment,” explains how to use Style Manager to customize the look and behavior of your desktop. It also describes how to set personal environment variables.

Chapter 8, “Using Mailer,” describes how to send and receive electronic mail messages through Mailer, and how to add and retrieve attachments.

Chapter 9, “Printing,” explains how to print through the desktop, and how to change the default printer.

Chapter 10, “Using Text Editor,” describes the desktop Text Editor, which you can use to create and edit short documents such as memos, mail messages, or resource files.

Chapter 11, “Using Calendar,” explains how to use Calendar to set appointments for yourself or a group, and how to create To Do lists.

Chapter 12, “Using Terminal,” explains how to display and customize terminal emulator windows on the desktop.

Chapter 13, “Using Icon Editor,” explains how to create files for use as desktop icons or backdrops.


Appendix B, “Running Localized Sessions,” explains how to change the language for your desktop session, and how to change fonts for different languages.

Related Books

Once you’ve read this book, you may want to read more detailed information on the desktop in CDE Advanced User’s and System Administrator’s Guide.
## What Typographic Changes and Symbols Mean

The following table describes the type changes and symbols used in this book.

**Table P-1  Typographic Conventions**

<table>
<thead>
<tr>
<th>Typeface or Symbol</th>
<th>Meaning</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>AaBbCc123</td>
<td>The names of commands, files, and directories; on-screen</td>
<td>Edit your .login file. Use <code>ls -a</code> to list all files. system% You have mail.</td>
</tr>
<tr>
<td></td>
<td>computer output</td>
<td></td>
</tr>
<tr>
<td>AaBbCc123</td>
<td>Command-line placeholder: replace with a real name or value</td>
<td>To delete a file, type <code>rm filename</code>.</td>
</tr>
<tr>
<td>AaBbCc123</td>
<td>Book titles, new words or terms, or words to be emphasized</td>
<td>Read Chapter 6 in User’s Guide. These are called class options. You must be root to do this.</td>
</tr>
</tbody>
</table>
This chapter provides an introduction to the Common Desktop Environment.

For information about logging in to the desktop, refer to Chapter 2, “Starting a Desktop Session.”

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mouse Skills</td>
<td>2</td>
</tr>
<tr>
<td>Basic Keyboard Skills</td>
<td>3</td>
</tr>
<tr>
<td>Overview of the Desktop</td>
<td>4</td>
</tr>
<tr>
<td>Working with Windows</td>
<td>9</td>
</tr>
<tr>
<td>Using Workspaces</td>
<td>16</td>
</tr>
<tr>
<td>Using Controls in Application Windows</td>
<td>19</td>
</tr>
<tr>
<td>Using Menus</td>
<td>25</td>
</tr>
<tr>
<td>Leaving the Desktop</td>
<td>31</td>
</tr>
<tr>
<td>Getting Help</td>
<td>32</td>
</tr>
</tbody>
</table>
Mouse Skills

♦ To Click

◊ Press and release mouse button 1 without moving the mouse.

By default, mouse button 1 is the left button.

Tasks that you perform by clicking include:

• Selecting a window or icon, making it active or selected
• Choosing a button in a dialog box or a control in the Front Panel
• Choosing a hyperlink within a help window

♦ To Double-Click

◊ Press and release mouse button 1 twice in rapid succession, without moving the mouse.

Here are some tasks you perform by double-clicking:

• Starting the default action for a File Manager or workspace icon
• Restoring a window icon (displaying the whole window again)
• Closing a window to remove it from the workspace—double-click the Window menu button in the upper left corner of the window frame

♦ To Drag

To move a window or drop an icon, use the press-drag-release motion.

◊ Point to the window’s title bar or anywhere on the icon, press and hold mouse button 1, drag the mouse, then release the button.

Tasks you perform by dragging and dropping include:

• Moving windows and icons on your screen
• Moving or copying files and folders within File Manager
• Dragging a slider within a scroll bar to scroll the contents of a window
• Printing a file by dropping its icon on the Printer control in the Front Panel
Basic Keyboard Skills

You can perform desktop tasks using your keyboard instead of your mouse. When you use your keyboard for desktop navigation, note the following:

- The Alt key is the same as the Extend char key on some keyboards
- Return is the same as Enter on some keyboards
- Pressing Esc halts most interactive operations
- In Style Manager, the Window Behavior setting must be Click In Window To Make Active (this is the default value)

For more information on the Window Behavior setting, refer to Chapter 7, “Customizing the Desktop Environment.”

Keyboard focus uses the highlight to show you which element of a window, menu, or control will respond to your input. To activate a selected menu item or control (such as a button), press the Spacebar.

Here’s a summary of several common keyboard operations:

- To move the highlight to the next window: Press Alt+Tab.
- To move the keyboard highlight within a window: Press Tab and the arrow keys (up, down, left, and right).
- To close a window and remove it from the workspace: Press Alt+F4.
- To minimize a window (turn it into an icon): Press Alt+Spacebar, then N to choose Minimize from the Window menu.
- To move a window: Press Alt+Spacebar, then M to choose Move from the Window menu. Press the arrow keys to move the window up, down, left, or right, then press Return.

   Hold down Control while you press an arrow key to move the window faster.

For more information about using your keyboard for desktop navigation, refer to Appendix A, “Keyboard Shortcuts for the Desktop.”
Overview of the Desktop

To help you organize and manage your work, the desktop provides windows, workspaces, controls, menus, and the Front Panel.

- Windows contain software applications and are framed with controls so you can move them, size them, or place them in additional workspaces.
- Workspaces are the screen areas where you place the windows needed for your work, arrange them, and put them away when you’re done.
- Controls enable you to manipulate objects, select choices, or type information.
- Menus provide access to commands you use to manage windows and operate applications.
- The Front Panel is a collection of frequently used controls, available in every workspace.

Some of the windows, icons and objects you’ll encounter as you use the desktop are:

- Window icons
- The Front Panel
- Style Manager
- File Manager
- Application Manager
- Workspace objects

Window Icons

When you minimize a window, it becomes an icon on the workspace. Shown here are the window icons for File Manager and Style Manager.

To minimize a window, click the minimize button near the upper right corner of the window frame.
To restore the window, double-click mouse button 1 on the icon. You can also restore the window by clicking its icon to display the Window menu and then clicking on the menu’s Restore item. See “To Restore a Window from an Icon” on page 13 for more information.

**Front Panel**

The Front Panel is a special window at the bottom of the display. It provides controls, indicators, and subpanels you use in your everyday work. The Front Panel also provides the workspace switch for selecting a workspace.

Many controls in the Front Panel, such as the File Manager control, start applications when you click them. Some controls, like the Printer control, are also drop zones. You can drag a file icon from File Manager and drop it on the Printer control to be printed.

The clock is an example of an indicator.

Arrow buttons over Front Panel controls identify subpanels—click an arrow button to open a subpanel.

Figure 1-1 Front Panel controls

For more information, see Chapter 4, “Using the Front Panel.”
Style Manager

Use Style Manager to easily customize many elements of the desktop including:

• Colors
• Workspace backdrops
• Font size
• Keyboard, mouse, and window behavior

To start Style Manager, click its Front Panel control.

For more information about Style Manager, see Chapter 7, “Customizing the Desktop Environment.”
File Manager displays the files, folders, and applications on your system as icons. Working with File Manager icons saves you from having to learn complex commands.

To open a File Manager view of your home folder, click the File Manager control in the Front Panel.

For more information, see Chapter 5, "Managing Files with File Manager."
Application Manager

Application Manager provides access to applications you use in your everyday work through action icons. You use action icons to start applications. Application Manager stores action icons in special folders called application groups.

You can place the action icons you use frequently on the workspace backdrop.

To open Application Manager, click its Front Panel control.

For more information, see Chapter 6, “Running Applications from the Desktop.”

Workspace Objects

You can place the files, folders, and actions you use frequently on the workspace backdrop as icons.

To place an object on the workspace, drag its icon from a File Manager or Application Manager window and drop it directly on the workspace backdrop.

A workspace object is a reference to the actual object, not a copy. The actual object remains unchanged within File Manager or Application Manager.
Working with Windows

This section describes how to open, close, and manipulate windows in a workspace.

Window Frame Controls

A window's frame provides controls with which you can:

• Focus attention on a window, making it active for input from your mouse or keyboard. When you select a window and it becomes active, its frame changes color.
• Move a window.
• Minimize a window into an icon.
• Size a window.
• Close a window, removing it from the desktop.
• Display a window in other workspaces.

Refer to Chapter 7, “Customizing the Desktop Environment,” for information about settings that make windows active.
Click the Window menu button to display the Window menu.

To close a window and remove it from the desktop, double-click the Window menu button or display the Window menu and click on Close.

Click the minimize button to turn the window into a window icon. To restore a window from its icon, double-click the icon.

Click the maximize button to display the window in its largest allowable size. Return the window to its former size by clicking the maximize button again.

The title bar shows the name of the application that owns the window. Select a window by clicking its title bar. You can move a window by dragging its title bar.

Drag a window's resize corner or border to resize the window.

For information on keyboard navigation and windows, see “Opening and Closing Windows” in Appendix A, “Keyboard Shortcuts for the Desktop.”
♦ To Open an Application Window

**Mouse**

◊ Click the application’s control in the Front Panel.

Or:

• From within Application Manager, double-click the application’s icon.
• From within File Manager, choose an action for a selected icon from the Selected menu.

You can also select an icon in a File Manager or Application Manager window by clicking it and then choose an action for the selected icon from the Selected menu.

**Keyboard**

From the Front Panel:

1. Press Alt+Tab to move the keyboard focus to the Front Panel.

2. Press the arrow keys to move the highlight within the Front Panel and select a control.

3. Press Spacebar or Return to choose the control and open the application’s window.

From Application Manager:

1. Open the Application Manager window by choosing its Front Panel control as described above.

2. Press the arrow keys to move the highlight to an application group icon within the Application Manager window.

3. Press Return twice to open the application group.

4. Press the arrow keys to move the highlight to an application or action icon, then press Return twice to start the application.
♦ To Close an Application Window

Closing an application window removes it from all workspaces. Closing an application is the same as quitting an application on other systems.

Caution - Before closing an application window, save your work. In most applications you can do this by choosing Save from the File menu.

Mouse
• Choose Close from the application’s File menu.
• Or, double-click the Window menu button (in the upper right corner of the application’s window). See Figure 1-2 on page 10.

Keyboard
1. Press Alt+Tab to move the highlight to the window you want to close.

♦ To Turn a Window into an Icon

To save screen space, you can minimize windows into window icons. This keeps the windows easily available and programs running in them continue to run.

Mouse
◊ Click the window's minimize button.

Keyboard
1. Press Alt+Spacebar to display the Window menu.
2. Choose Minimize:
   • Press Down Arrow until you select Minimize, then press Return.
   • Or, press N, the menu's mnemonic for Minimize.
To Restore a Window from an Icon

**Mouse**
◊ Double-click the icon.

**Keyboard**
1. With keyboard focus on the icon, press Alt+Spacebar to display the Window menu.
2. Press Down Arrow to select Restore, then press Return.

To Move a Window or Window Icon

**Mouse**
1. Point to the window's title bar or icon.
2. Drag the window or icon to its new location.

**Keyboard**
1. Press Alt+Spacebar to display the Window menu.
2. Press M, the menu's mnemonic for Move.
3. Press the arrow keys to relocate the window or icon.
   Hold down Control while you press an arrow key to speed up the movement of the window or icon.
4. When you’ve moved the window or icon to where you want it, press Return.

To cancel the move operation, press Esc.
♦ To Resize a Window

**Mouse**
1. Place the pointer on a window's border or corner. The pointer changes to a resize arrow.
2. Drag the border or corner. An outline appears to show you the window's new size.
3. Release the mouse button when the outline shows the window's desired size.

**Keyboard**
1. Press Alt+Spacebar to display the Window menu.
2. Press S, the menu's mnemonic for Size.
3. Press the arrow keys to stretch or shrink the window. Hold down Control while you press an arrow key to size the window faster.
4. When the outline shows the size you want, press Return.
To cancel the resize operation, press Esc.
To Bring a Window or Icon Forward

Mouse
• To bring a window or icon to the foreground of the workspace, click a visible part of the window's frame or anywhere on the icon.
• To bring a concealed window or icon to the foreground, choose Shuffle Up from the Workspace menu.

Keyboard
• To bring the bottom window or icon in a workspace forward, press Alt+Up Arrow.
• To place the top window in the background, press Alt+Down Arrow.
• To cycle through and select the windows and icons in a workspace, press Alt+Tab or Alt+Esc.
• To cycle through and select the windows and icons in reverse order, press Shift+Alt+Tab or Shift+Alt+Esc.

To Copy and Paste Text into Windows

Copying and pasting eliminates the need to retype text.

You can copy from and paste text into:
• Text fields
• Terminal emulator windows
• Text Editor windows
• Mailer Compose windows

You can also copy text from a Mailer message view and a Help Viewer window and paste it into Text Editor, terminal emulator, and Mailer Compose windows.

Selecting the Text To Be Copied
1. Move the pointer to the start of the text to be pasted.

2. Drag to the end of the text to be pasted, then release the mouse button, leaving the text highlighted.
Pasting Text
1. Place the text insertion cursor in the target location.
2. Click mouse button 2 to paste the text.
   To deselect text, click in an empty area of the window that has the text selected, or press Esc.
For related information, refer to:
• Chapter 3, “Getting Help”
• Chapter 10, “Using Text Editor”
• Chapter 12, “Using Terminal”

Using Workspaces

Workspaces are like separate screens of windows. To help organize your desktop, you can place specific applications in a particular workspace and name that workspace accordingly. For example, a workspace you’ve named Reports could contain the tools you use to prepare reports, such as a spreadsheet, desktop publisher, and graphics applications. You might set up other workspaces according to your projects.

This section describes how to display workspaces, place windows in specific workspaces, and rename workspaces.

For information about using your keyboard for desktop navigation, refer to Appendix A, “Keyboard Shortcuts for the Desktop.”

♦ To Display Another Workspace

Mouse
♦ Click the workspace’s button in the workspace switch of the Front Panel.
Keyboard
1. Press Alt+Tab until the keyboard focus, as shown by the highlight, is on the Front Panel.
2. Press the arrow keys to move the highlight to the button for the workspace you want to display.
3. Press Return.

♦ To Place a Window in Other Workspaces

Mouse
1. Click the Window menu button.
   The Window menu appears.
2. Choose Occupy Workspace from the Window menu.
3. In the Workspaces list of the Occupy Workspace dialog box, select the workspaces in which you want the window to appear.
   • To select more than one contiguous workspace name in the list, hold down Shift while you click.
   • To select discontiguous workspace names in the list, hold down Control while you click.
   • Click on a selected workspace to deselect it.
   • To place the window in every workspace, click the All Workspaces button.
4. Click OK.

Keyboard
1. To display the Window menu, press Alt+Spacebar.
2. Press the Down Arrow key to select Occupy Workspace, then press Return.
   The Occupy Workspace dialog box appears.
3. Press Tab until the keyboard focus, as shown by the highlight, is in the Workspaces list.
4. Select the workspaces in which you want the window to appear:
   • Press Down Arrow or Up Arrow to move through the list.
   • To select more than one workspace, press Shift+Down Arrow or
     Shift+Up Arrow.

5. Press Return.

♦ To Rename a Workspace

Mouse
1. Click the Front Panel button for the workspace whose name you want to change.
   That workspace is displayed.
2. Click the workspace's Front Panel button again.
   The button becomes a text field.
3. Edit the workspace's name in the text field.
4. Once you've renamed the workspace, press Return.

Keyboard
1. Press Alt+Tab until the keyboard focus, as shown by the highlight, is on the Front Panel.
2. Press the arrow keys to move the highlight to the button for the workspace you want to rename.
3. Press Shift+F10 to display the workspace button's pop-up menu.
4. Press the Down Arrow key to select the Rename item, then press Return.
   The button becomes a text field.
5. Edit the workspace's name in the text field.
6. Once you've renamed the workspace, press Return.
Using Controls in Application Windows

Windows and dialog boxes contain controls that help you work with applications. You use controls to manipulate objects, select choices, or type information.

This section describes various types of controls you’ll come across while using the desktop. Here’s a list of the most common controls:

- **Buttons** initiate commands, start actions, or specify options and settings. Types of buttons include push buttons and radio buttons.
- **Check boxes** specify options and settings.
- **Text fields** provide areas where you can type information.
- **Lists** display a scrollable list of choices from which you can select.
- **Sliders** provide incremental selection from a range of values.
- **Scroll bars** enable you to scroll through a window’s contents.

♦ **To Choose a Push Button**

Choosing a push button immediately performs the associated command or action. For example, choosing an OK button applies any changes made to a dialog box then closes it.

As a shortcut, many dialog boxes automatically give focus to the OK button so that you can quickly specify settings and then press Return to choose OK.

Mouse

◊ Click the button.
**Keyboard**
1. Press Tab and the arrow keys until the button has the keyboard focus, as shown by the highlight.
2. Press Return.

♦ ✧ To Select a Check Box or Radio Button

You select a check box to specify an option or setting. You can select more than one check box in a group.

You also use a radio button to specify an option or setting, but only one radio button in a group can be selected at a time.

![Diagram of check boxes and radio buttons]

**Mouse**

◊ Click the check box or radio button you want to select.

**Keyboard**
1. Press Tab and the arrow keys until the check box or radio button has the keyboard focus, as shown by the highlight.
2. Press the Spacebar.
To Scroll the Contents of a Window

Windows often contain more information than you can see at one time. Use a window’s scroll bar to bring the window’s contents into view.

Mouse

1. Click to move up one line
2. Click to move up one screen
3. Drag the slider to move to a region of the window
4. Click to move down one screen
5. Click to move down one line

Keyboard

1. Press Tab to move to the window area you want to scroll.
2. Press the arrow keys, or Prev and Next, or Page Up and Page Down.
   Hold down Control while you press an arrow key to scroll faster.

To use a slider:

1. Press Tab or an arrow key to move the highlight to the slider.
2. Press Up Arrow or Down Arrow to move the slider.
   Hold down Control while you press an arrow key to move the slider faster.
To Select a List Item

A selected list item becomes highlighted. The highlighted item is acted upon when you click a button, such as OK.

Mouse
1. Click the list item.
   - In a multiple-selection list, hold down Shift while you click the items.
   - To deselect an item, click it again.
2. Click a button, such as OK.
   - In some lists, double-clicking an item selects the item and chooses the default command.

Keyboard
1. Press Tab to move to the list.
2. Select the list item:
   - In a single-selection list, use the arrow keys to reach your choice.
   - In a multiple-selection list, use the arrow keys to reach your first selection, then press Shift+Up Arrow or Shift+Down Arrow.
   - To deselect an item, press the Spacebar.
3. Press Tab to move to a button, such as OK or Apply, then press Return.
To Enter Text into an Empty Field

A text field accepts information you type.

**Mouse**
1. Click the field to display the text insertion cursor.
2. Type the text.

In many dialog boxes, pressing Return completes the text entry and activates the default button, such as OK or Apply.

**Keyboard**
1. Press Tab, Shift+Tab, or the arrow keys until you reach the text field.
   A blinking cursor indicates that the text field has the keyboard focus.
2. Type the text, then press Control+Tab to move keyboard focus out of the text field.
To Edit Text in a Field

**Mouse**
1. Select the text in the field to edit:
   - Characters: Drag from the first character to the last character
   - Word: Double-click the word
   - Line: Triple-click the line
   - Multiline: Quadruple-click the field
   To deselect text, click an empty area in the window.
2. Type the replacement text.

**Keyboard**
1. Press Tab, Shift+Tab, or the arrow keys until you reach the field.
2. Use the editing keys to edit the field’s contents, then type the replacement text.

<table>
<thead>
<tr>
<th>Editing key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow key</td>
<td>Move the text insertion cursor</td>
</tr>
<tr>
<td>Backspace</td>
<td>Delete the character to the left of the cursor</td>
</tr>
<tr>
<td>Delete or Delete char</td>
<td>Delete the character to the right of the cursor</td>
</tr>
<tr>
<td>Control+Delete or</td>
<td>Delete the character to the right of the cursor</td>
</tr>
<tr>
<td>Control+Delete char</td>
<td>Delete from the cursor to the end of the line</td>
</tr>
</tbody>
</table>
3. Press Control+Tab to move keyboard focus out of the text field.
Using Menus

Menus provide access to commands you use to manage windows and operate software applications.

Choosing a menu item performs an associated action on the currently selected object. For example, when you select a window and choose Minimize from its Window menu, the window becomes an icon.

Menu items that appear dimmed are available only under certain conditions. For example, the Window menu’s Restore item is available only when the window is an icon.

Menus you’ll use on the desktop include:

- Menus that you “pull down” from an application’s menu bar by clicking the menu’s name or typing Alt and its mnemonic. A mnemonic is an underlined character in a menu or item name.

An application’s File menu is shown here.

The sequence of keys listed to the right of some items is called a shortcut key. Typing mnemonics and shortcut keys gives you quick keyboard access to menu items.
• Menus that “pop up” when you click mouse button 3 (or press Shift+F10) in an application window or on a workspace object.

<table>
<thead>
<tr>
<th>Workspace Object</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove From Workspace</td>
</tr>
<tr>
<td>Open Parent Folder</td>
</tr>
<tr>
<td>Rename</td>
</tr>
<tr>
<td>Open</td>
</tr>
<tr>
<td>Print</td>
</tr>
</tbody>
</table>

**Window Menu**

Use Window menu items to control windows and window icons.

This menu is displayed when you:

• Click the Window menu button in the upper left corner of a window
• Click on a window icon
• Press Alt+Spacebar with the keyboard focus on a window or window icon
<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restore</td>
<td>Turns an icon back into a window</td>
<td>Alt+F5</td>
</tr>
<tr>
<td>Move</td>
<td>Changes the window’s location</td>
<td>Alt+F7</td>
</tr>
<tr>
<td>Size</td>
<td>Changes the size of the window (inactive for icons)</td>
<td>Alt+F8</td>
</tr>
<tr>
<td>Minimize</td>
<td>Turns the window into an icon</td>
<td>Alt+F9</td>
</tr>
<tr>
<td>Maximize</td>
<td>Enlarges the window to its greatest allowable size</td>
<td>Alt+F10</td>
</tr>
<tr>
<td>Lower</td>
<td>Moves the window to the background</td>
<td>Alt+F3</td>
</tr>
<tr>
<td>Occupy Workspace</td>
<td>Use to select the workspaces in which you want the window to appear</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Occupy All Workspaces</td>
<td>Displays the window in all workspaces</td>
<td></td>
</tr>
<tr>
<td>Close</td>
<td>Closes the window, removing it from the workspace</td>
<td></td>
</tr>
</tbody>
</table>
Workspace Menu

The Workspace menu is a pop-up menu that contains items for managing the workspace.

To display the Workspace menu, click mouse button 3 on the workspace backdrop.

<table>
<thead>
<tr>
<th>Workspace Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shuffle Up</td>
</tr>
<tr>
<td>Shuffle Down</td>
</tr>
<tr>
<td>Refresh</td>
</tr>
<tr>
<td>Minimize/Restore Front Panel</td>
</tr>
<tr>
<td>Restart Workspace Manager...</td>
</tr>
<tr>
<td>Log out...</td>
</tr>
</tbody>
</table>

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Shuffle Up</td>
<td>Brings the bottom window (in a stack of windows) forward</td>
</tr>
<tr>
<td>Shuffle Down</td>
<td>Puts the top window (in a stack of windows) in the background</td>
</tr>
<tr>
<td>Refresh</td>
<td>Repaints the display</td>
</tr>
<tr>
<td>Minimize/Restore Front Panel</td>
<td>Turns the Front Panel into an icon or restores the Front Panel from its icon</td>
</tr>
<tr>
<td>Restart Workspace Manager</td>
<td>Stops then restarts the Workspace Manager (typically used after you have customized configuration files)</td>
</tr>
<tr>
<td>Log out</td>
<td>Begins the logout process (equivalent to the Front Panel Exit control)</td>
</tr>
</tbody>
</table>

**Note** - You cannot access this menu through your keyboard.
♦ **To Choose a Window Menu Item**

**Mouse**

◊ Press mouse button 1 over the Window menu button or icon, drag to the item, then release the mouse button.

Or:

1. Click the Window menu button to display the menu.
   
   If the window is an icon, click the icon.

2. Click a menu item.

To close the menu without choosing an item, click anywhere other than the menu.

**Keyboard**

1. Press Alt+Tab until you’ve placed the keyboard focus, as shown by the highlight, on the window or window icon.

2. Press Alt+Spacebar to display the Window menu.

3. Press the key for the item’s mnemonic, the underlined character in the item name.

To close the menu without choosing an item, press Esc.

♦ **To Choose a Workspace Menu Item**

1. Move the pointer over the workspace backdrop.

2. Press mouse button 3, drag to the item, then release the mouse button.

To close the menu without choosing an item, move the pointer away from the menu and click.

**Note** - You cannot choose a Workspace menu item through your keyboard.
♦ To Choose a Menu Item with the Mouse

1. Display the menu:
   • Pull-down (menu bar) menu: Using mouse button 1, click the menu name.
   • Pop-up menu: Click mouse button 3 inside the application.
   • Object’s pop-up menu: Click the object with mouse button 3.

2. Click the item.

   You can also choose a menu item by pressing the mouse button, dragging to the item, then releasing the mouse button.

To close a menu without choosing an item, move the pointer away from the menu and click.

♦ To Choose a Menu Item with the Keyboard

Pull-down Menus

1. Press Alt+Tab until you've placed the keyboard focus, as shown by the highlight, on the application window.

2. Display the menu by holding down Alt and then pressing the key for the menu’s mnemonic (the underlined character in the menu’s name as shown in the menu bar).

3. Press the key for the item’s mnemonic.

   Or, press an arrow key to move to the item, then press Return.

Pop-up Menus

1. Press Alt+Tab until the keyboard focus is on the application window or workspace object.

2. Press Shift+F10 to display the pop-up menu.

3. Press the key for the item’s mnemonic.

   Or, press Down Arrow to move to the item, then press Return.

To close a menu without choosing an item, press Esc.
For more information about using your keyboard for desktop navigation, refer to Appendix A, “Keyboard Shortcuts for the Desktop.”

**Leaving the Desktop**

This section describes how to log out of and exit the desktop, and how to lock your display to prevent unauthorized use of your system when you are away from it and have not logged out.

♦ **To Log Out**

**Caution** - Before logging out of the desktop, save your work in all open application windows. Remember to check each workspace.

- Click the Exit control in the Front Panel.

- Or, choose Log out from the Workspace menu:
  1. Move the pointer over the workspace backdrop.
  2. Press mouse button 3 to display the Workspace menu.
  3. Drag to choose Log out, then release the mouse button.

**Note** - You cannot display the Workspace menu using your keyboard.

As you log out of the desktop, your current session is saved. When you log back in, the desktop will appear as it did before you logged out.

Applications that do not get saved as part of the current session include:
- Applications that you run in terminal emulator windows
- Non-desktop applications that do not preserve their state during logout
You’ll need to restart these applications when you log in. For more information, see Chapter 2, “Starting a Desktop Session.”

♦ **To Lock Your Display**

To prevent unauthorized use of your system when you are away from it and have not logged out:

◊ Click the Lock control in the Front Panel.

To unlock your display, type your password.

For information about screen lock options, refer to Chapter 7, “Customizing the Desktop Environment.”

**Getting Help**

You can request help by:

- Pressing F1 or the Help key
- Choosing an item from an application’s Help menu
- Clicking the Help button in a dialog box
- Opening the Help Manager to browse all the available help

For more information on using help, refer to Chapter 3, “Getting Help.”

The quickest and easiest way to get help is to press the F1 key. When you press F1, the application you are using displays the help topic most closely related to your current activity.

Some keyboards have a dedicated Help key that may take the place of the F1 key.
Help Menu

Most applications have a Help menu for requesting specific kinds of help.

<table>
<thead>
<tr>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
</tr>
<tr>
<td>Tasks</td>
</tr>
<tr>
<td>Reference</td>
</tr>
<tr>
<td>On Item</td>
</tr>
<tr>
<td>Using Help</td>
</tr>
<tr>
<td>About ...</td>
</tr>
</tbody>
</table>

To learn more about using help windows, choose Using Help from an application’s Help menu. Or, you can press F1 while using a Help window.

To Display the Help Manager

The Help Manager lists all the online help volumes installed on your system.

1. Click the Help Manager control in the Front Panel.
   The Help Viewer opens, displaying the Help Manager.

2. Choose the Common Desktop Environment topic to display the list of help volumes for the desktop.

3. Browse the list of titles. To open a volume, click its title.
Starting a Desktop Session

A desktop session occurs between the time you log in and the time you log out.

The login screen, displayed by the Login Manager, is your gateway to the desktop. It provides a place for you to type your login name and password. The Options menu on the login screen lists your login options. In addition to running a desktop session, you can run a failsafe session. You can also select the language for your session.

---

<table>
<thead>
<tr>
<th>Starting and Ending a Desktop Session</th>
<th>35</th>
</tr>
</thead>
<tbody>
<tr>
<td>To Use a Session in a Different Language</td>
<td>36</td>
</tr>
<tr>
<td>Starting a Failsafe Session</td>
<td>37</td>
</tr>
<tr>
<td>Starting a Command-Line Session</td>
<td>37</td>
</tr>
<tr>
<td>Using a Home Session</td>
<td>38</td>
</tr>
</tbody>
</table>

Starting and Ending a Desktop Session

A desktop session starts when you log in. Session Manager is started after Login Manager authenticates your login and password.

Session Manager provides the ability to manage sessions—to remember the state of your most recent session and return you there the next time you log in.
Session Manager saves and restores:

- The appearance and behavior settings - for example, fonts, colors, and mouse settings.
- The window applications that were running - for example, your File Manager and Text Editor windows. Certain types of applications can't be saved and restored by Session Manager. For example, if you start the vi editor from a command line in a Terminal window, Session Manager cannot restore your editing session.

♦ To Log In to a Desktop Session

1. Type your login name and press Return or click OK.
2. Type your password and press Return or click OK.
   
   If Login Manager does not recognize your name or password, click Start Over and start the log in process over again.
   
   Once you've logged in, Session Manager starts a session:
   - If this is the first time you've logged in, you'll get a new session.
   - If you've logged in before, your previous session will be restored.

♦ To Log Out

- Click the Exit control in the Front Panel.
- Or, choose Log out from the Workspace menu.

When you log out of a regular desktop session, Session Manager saves information about your current session so that it can be restored the next time you log in. Information about non-desktop applications may not be saved.

♦ To Use a Session in a Different Language

1. Choose Language from the Options menu on the login screen.
2. Choose the language group that includes the language you need.
3. Select a language.
4. Log in.

The default language for your system is set by your system administrator. The Options menu enables you to access other languages. Choosing a language in the Options menu sets the LANG environment variable for your session. The default language is restored at the end of the session.

**Starting a Failsafe Session**

A failsafe session is a session that starts a single Terminal window (and optionally Workspace Manager). It is useful when you need access to a single Terminal window to execute several commands before logging in to a desktop session.

♦ **To Log In to a Failsafe Session**

1. Choose Session from the Options menu.
2. Choose Failsafe Session from the Session submenu.
3. Log in.

♦ **To Log Out of a Failsafe Session**

◊ Type the `exit` command in a Terminal window.

**Starting a Command-Line Session**

Command Line Login mode enables you to temporarily leave the desktop to work in your operating system environment. Command Line Login mode is not a desktop session. When your system is in Command Line Login mode, the desktop is suspended. You log in using your operating system mechanism rather than Login Manager. There are no windows because the X server is not running.
To Log In to and Out of a Command-Line Session

Note - Certain types of configurations (for example, X terminals) do not provide a Command Line Login mode option.

To enter Command Line Login mode:
1. Choose Command Line Login from the Options menu.
   The login screen disappears and is replaced by a console prompt.
2. Supply your login and password as prompted.

To leave Command Line Login mode:

Type `exit` at a command-line prompt.

Using a Home Session

Ordinarily, the desktop saves session information when you log out and uses that information to start your next session. If you start or stop applications during your session, or use Style Manager to change the appearance and behavior of your system, changes you make are reflected in your next session. This type of session is called a current session.

The desktop also provides a home session. A home session is a session that you explicitly save. It's like taking a snapshot of your current session at some point in time. Once you've saved a home session, you can specify that logging in always restores that session instead of the current session.

To Save a Home Session

1. Click the Style Manager control in the Front Panel.
2. Click the Startup control in Style Manager.
   The Startup dialog box is displayed.
3. Click Set Home Session in the Startup dialog box.
4. Click OK in the confirmation dialog box that appears.
   This saves the current state of your session.
To Automatically Start the Home Session at Login

1. Click the Style Manager control in the Front Panel.
2. Click the Startup control in Style Manager.
   The Startup dialog box is displayed.
3. Select Return to Home session.
4. Click OK.

When you choose Return to Home session, Session Manager will not save your session at logout.

To Choose between the Current and Home Session for Each Session

1. Click the Style Manager button in the Front Panel.
2. Click the Startup control in Style Manager.
   The Startup dialog box is displayed.
3. Select Ask Me at Logout.
4. Click OK.

You decide what will be your next session—current or home—at logout time. If you choose to return to the home session, the current session information is not saved. (You cannot change your mind the next time you log in.)
Online help is available for each of the standard applications in the Common Desktop Environment (CDE). Whether you are using File Manager, Calendar, or Mailer for example, you request and display help topics in the same way. You can also browse help information on your system using the desktop Help Manager.

Other applications installed on your desktop may take advantage of using the desktop's Help System or provide help in other ways.

<table>
<thead>
<tr>
<th>Requesting Help</th>
<th>42</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Help Windows</td>
<td>45</td>
</tr>
<tr>
<td>Selecting Help Topics</td>
<td>46</td>
</tr>
<tr>
<td>Moving between Help Topics</td>
<td>48</td>
</tr>
<tr>
<td>Searching for Specific Information</td>
<td>51</td>
</tr>
<tr>
<td>Browsing Help on Your System</td>
<td>54</td>
</tr>
<tr>
<td>Printing Help Topics</td>
<td>58</td>
</tr>
</tbody>
</table>
Requesting Help

Here are the ways you can request Help:

• Press F1—also known as the “help key”—to get context-sensitive help
• Choose a command from an application’s Help menu
• Open Help Manager from the Front Panel to browse help on your system
• Open the Help subpanel to choose help about the desktop or to choose On Item Help

Press F1 — The Help Key

When you have a question, the quickest and easiest way to get help is to press F1. When you press F1, the application you are using displays a help topic most closely related to the component—a window or button for example—that is highlighted. Because the application determines which help topic is most appropriate, this type of help is called context-sensitive.

The F1 key is a quick way to get help on an application menu or dialog box. For example, to request help about the File Manager File menu, display the File menu and press F1. File Manager displays a description of each item in the menu. Or, if a dialog box is open, pressing F1 will display an explanation of the dialog box. The F1 key is a shortcut for clicking the dialog box’s Help button.

Note - Some computers have a dedicated “Help” key on the keyboard. If yours does, it may take the place of the F1 key.

Using an Application’s Help Menu

Most applications have a Help menu that contains commands for requesting different types of help such as an introduction, application tasks, or reference information.
Getting Help

A typical CDE Help menu includes these commands:

- **Overview**
  Displays the home topic for the application. The home topic is the first topic of the application's help topic hierarchy.

- **Tasks**
  Displays task instructions for most operations performed with the application.

- **Reference**
  Displays reference summaries for various components, such as windows and dialog boxes, menus, and application resources.

- **On Item**
  Enables you to click an item in any window of an application and view a description of the item.

- **Using Help**
  Provides help on using the help windows.

- **About Application**
  Displays the version and copyright information for the application.

Applications can include additional choices. Also, non-CDE applications may have different commands in their Help menus.

**On Item Application Help**

On Item help is interactive. It enables you to move the pointer to a specific item (such as a menu, button or dialog box) and click the item to display its corresponding help.
To Select On Item Help

1. Choose On Item from the Help menu.
   The pointer changes to a ? (question mark).

2. Move the pointer to an item in the application and click mouse button 1.
   A description of the item is displayed.

Using Help Manager

Help Manager is a special help volume that lists all the online help registered on your system. Clicking the Help Manager control in the Front Panel opens the Help Manager help volume.

Figure 3-2 Help Manager control

Click any of the underlined titles to view the corresponding help information. For additional instructions about using Help Manager see “Browsing Help on Your System” on page 54.

For convenience, you can also find help about the desktop and the Front Panel in the Help subpanel. It also provides On Item help for the Front Panel and its subpanels.

Figure 3-3 Help subpanel
Using Help Windows

The Help System is built into each of the CDE applications (and possibly other applications installed on your system). When you ask for help while using an application, the application displays a help window.

Applications can use two types of help windows to display help topics: a general help window and a quick help window, shown in Figure 3-4.

![General help window and quick help window](image)

**Figure 3-4  Types of help windows**

General help windows have a topic tree and a topic display area. The topic tree is a list of help topics that you can browse to find help on a subject. When you choose a topic, it is displayed in the lower portion of the help window called the topic display area.

Quick help windows are streamlined help windows. A quick help window has just a topic display area and one or more buttons.
Selecting Help Topics

There are two ways to select a help topic. You can choose a topic from the topic tree. Or, within a help topic, you can select a hyperlink. A hyperlink is an active word or phrase that “jumps” to another related help topic. Any underlined text in a help window is a hyperlink.

Graphic images can also be used as hyperlinks. For more information about hyperlinks, see “Using Hyperlinks” on page 47.

Using the Topic Tree

The topic tree is an outline of a help volume’s major topics. Subtopics are indented under main topics. The current topic, whose contents are displayed in the topic display area, is marked with an ⇒ (arrow). You can scroll the topic display area to see all your choices or resize the entire help window.

You can also change the size of the topic pane. To do so, drag the sash control shown in Figure 3-5. Then release the mouse button to set the new size.
To Select A Topic

1. Move the pointer into the topic tree.
2. Click mouse button 1 on the topic you want to display.

Using Hyperlinks

Any underlined text in a help window is a hyperlink. It is easy to “jump” to related help topics using hyperlinks—just click the underlined text.

What Hyperlinks Look Like

A solid underline identifies a standard hyperlink that displays the new topic in the current help window. For example, the last paragraph in Figure 3-5 shows a hyperlink of this type.

A dashed underline indicates a definition link, which displays a quick help window.
A graphic—an icon, for example—can also be a hyperlink. A grey open-cornered border identifies a graphic hyperlink. Figure 3-6 shows the different hyperlink formats that can be used in help topics.

Figure 3-6 Hyperlink formats

**Links That Display a New Window**

Most hyperlinks display the related topic in the same window. However, if you choose a hyperlink that jumps to a help topic for another application, a new window is displayed. Links that jump from one application’s online help into another’s are called cross-volume or cross-application hyperlinks.

♦ **To Select A Hyperlink**

1. Move the pointer to the underlined text or graphic image.
2. Click mouse button 1.

**Moving between Help Topics**

To move between help topics, use these commands on the Navigate menu:

- **Backtrack** Returns to the previous topic. Backtrack enables you to return to each topic you have visited.
- **History** Displays a History dialog box that lists help volumes and topics you have visited. Select a help topic to re-display it.
- **Home Topic** Returns to the home topic, or beginning of the help volume.

For convenience, Backtrack and History are also provided as push buttons.
Help Pop-up Menu

In a general help window, you can also use the Help pop-up menu as a shortcut. The pop-up menu includes both Backtrack and Home Topic, which are frequently used commands.

Quick help windows do not have a pop-up menu.

♦ To Display the Help Pop-up Menu

1. Point to the topic display area and press mouse button 3.

2. Choose Backtrack or Home Topic.

Knowing Where You Are

Each application that provides online help has a help volume. A volume consists of a group of help topics that describe the application and explain how to use its features. For instance, an application could organize its help using these main topics: Concepts, Tasks and Reference.
The home topic is the first topic, or beginning of the help volume. Main level topics are accessible from the home topic, or may also be listed in your application's Help menu.

**Browsing between Different Help Volumes**

Frequently hyperlinks take you to another topic in your application's help volume. While browsing the Tasks topics, for example, you might select a hyperlink to a topic in the Reference section.

A group of related applications, however, may use hyperlinks to cross-reference information in different help volumes. For example, an application could include a hyperlink to the desktop's introductory help volume that explains basic mouse and keyboard skills.

Because hyperlinks can quickly take you from one piece of information to another, you may need to know where you are. A quick look at your help window can give you the information you need.

- The line located below the menu bar reports the name of the volume you are viewing. This is helpful when you have explored several help volumes using Help Manager, the help index, or cross-volume links.

- Within the topic tree, the first item is the home topic, or the beginning of the help volume. After exploring topics, you can easily return to the home topic by scrolling to the top of the topic tree. Or, you can choose Home Topic from the Navigate menu or pop-up menu.
• An ⇒ (arrow) points to the title of the current topic. As you choose topics, the arrow moves to identify your selection. Scrolling the topic tree shows you where you are located relative to other topics.

Knowing Where You’ve Been

A general help window keeps track of the topics that you have visited. The History command opens a dialog box that lists the help volumes and help topics you have visited.

![History dialog box](image)

Figure 3-9 History dialog box

◆ To Use History To Return to a Topic

1. Click the History button.
2. Choose the title of the help volume or topic that you want to display.
3. When you’re done, click Close.

Searching for Specific Information

Like a book, a help volume has an index of important words and phrases that you can use to find help topics on a subject. You can browse or search the index of the current volume, selected volumes, or all help volumes available on your system.
Because the help index can be quite large even for a single volume, index entries can be expanded or contracted. A + (plus) sign indicates that the index entry relates to more than one help topic. The number shows the count of help topics. You can click the index item to list the topics.

For instance, the result of an index search for the word “display” is shown in Figure 3-10. The -36 prefix tells you that there are 36 index entries that contain the keyword “display.” Clicking any title marked by a + (plus) expands the list and the + (plus) changes to a - (minus) sign. The last index entry shown in the figure has been expanded in this way.

To Search for Topics Using the Help Index

Note - The help index is available only in a general help window.
1. To open the index, click the Index button.

   The index lists all of the entries for the current help volume. You can choose All Volumes to view an index for all available help volumes or choose Selected if you want to select only certain volumes.

2. Select the Entries with field, type the word or phrase you are looking for, and press Return.

   Index searches are not case sensitive. Wildcards such as * (asterisk) and ? (question mark) can be used (see “Pattern Searches” below).

3. Select the index entry you want to view.

   If the entry has a + (plus sign) prefix, the list will expand to show additional choices. Then select a help topic to view.

   You may view as many topics as you want.

4. Click Close when you are done.
Pattern Searches

In a pattern search certain characters (known as "wildcards") have special meaning. You can combine these characters in a variety of ways.

Two frequently used wildcards are asterisk (*) and question mark (?). The * matches any string of characters (including no characters), and ? matches any single character. Other wildcards include:

- . (period)          Matches any character
- | (vertical bar)    Specifies two search patterns and matches either pattern (logical OR)
- ( ) (parentheses)   Encloses a pattern expression

To search for a character that has special meaning in a regular expression, precede the character with a \ (backslash).

Examples

- mouse.*clicking    Matches entries that contain the word "mouse" followed by any number of characters followed by "clicking"
- mouse | click       Matches entries that contain the word "mouse" or "click"
- (session | style).*manager Matches entries that contain "Session Manager" or "Style Manager"

Browsing Help on Your System

You can browse all application help volumes registered on your system without having to start each individual application—just start Help Manager from the Front Panel.

At the top level, Help Manager groups help volumes into help families. For example, the help family Common Desktop Environment lists help volumes for the standard desktop applications. You can browse and display any of the volumes listed.
♦ **To Open Help Manager**

1. Click the Help Manager control in the Front Panel (see Figure 3-2 on page 44).

   A help window displays a list of help families with online help. This is the top level of Help Manager.

   ![Figure 3-11 Top-level view in Help Manager](image)

2. Scroll the window to find the product group you are interested in and click its title (underlined).

   This lists the help volumes available for that product.

3. To open a particular help volume, click its title (underlined text).

4. To return to the top level of Help Manager, click the Top Level button.
Example
To browse File Manager's online help:

1. Click the Help Manager control.
2. Choose Common Desktop Environment.
3. Scroll the list of help volumes until you see File Manager Help.
4. Click File Manager Help.

File Manager’s help is displayed. This is the same help information you would see if you opened File Manager and chose Overview from the Help menu.

Figure 3-12 File Manager help viewed in Help Manager
To Duplicate a Help Window

1. Choose New Window from the Help Manager File menu.

   The current help window is duplicated. You can size the new window and select topics independently of the original window.

2. To remove the window, choose Close from the File menu.

   Note - The New Window command is only available in the Help Manager help window (see “Browsing Help on Your System” on page 54.

Displaying a Man Page

Manual reference pages, traditionally known as “man pages,” can be displayed using the Man Page Viewer action. The action icon is located in the Desktop_Apps folder in Application Manager.

Figure 3-13 Man Page action icon
To Display a Man Page

1. Click the Application Manager control in the Front Panel.

2. Double-click the Desktop_Apps icon.

3. Click the Man Page Viewer icon.

   A dialog box is displayed, prompting you to enter a man page name.

4. Type the name of the man page you want to see and press Return.

   The man page is displayed in a quick help window.

5. Click Close to dismiss the man page.

Printing Help Topics

Sometimes you may want to have a printed version of a help topic for a particular application. You can print an individual help topic, a table of contents and index, or the entire help volume. Printing options, such as paper size, number of copies, and destination printer, can also be set in the Print dialog box.

Printed help topics are directed to your default printer unless you provide a different printer name in the dialog box. Printed output is text only.
To Print a Help Topic

1. Choose Print from the File menu. (In a quick help window, click the Print button.)
   
   You can use the default values in the Print dialog box and skip to step 5 or enter new values for your print job.

2. Optional. Type the name of the printer that you want to use.

3. Optional. Type the number of copies to print.

4. Optional. Click the paper size button to choose a paper size.

5. Select the topic or topics you want to print.
   
   Current Topic (the default) Prints only the current topic
   
   Current and Subtopics Prints the current topic and its subtopics
   
   Table of Contents and Index Prints the help volume table of contents and index
   
   Entire Volume Prints the contents of the help volume including the table of contents and index

6. Click Print.
Printing Configuration

The Print dialog box displays the name of your default printer. You can change the default printer name by modifying the LPDEST environment variable. You can also change the printer for a specific application by modifying the application's application defaults file.

♦ To Set the Printer Resource for an Application

◊ Edit your HomeDirectory/.Xdefaults file by adding this resource:
  
  application_name*printer name

  If you do not have an .Xdefaults file, create the file in your home directory.

Example

You want to direct all printed help topics of an application named ImageScan to a printer named laser2 rather than to your default printer.

Add this resource to your .Xdefaults file:

ImageScan*printer: laser2

Modifying Help Window Colors

You can change the colors of the topic tree or topic display area of a help window by setting application resources. Choosing constrasting colors is important. This ensures that text (foreground color) will be visible against the background color.
To Change Help Window Colors for an Application

1. Edit your HomeDirectory/.Xdefaults file by adding these resources:

   application_name*DtHelpDialog*DisplayArea.foreground:    color
   application_name*DtHelpDialog*DisplayArea.background:    color
   application_name*DtHelpDialog*TocArea.foreground:        color
   application_name*DtHelpDialog*TocArea.background:        color
   application_name*DtHelpQuickDialog*DisplayArea.foreground: color
   application_name*DtHelpQuickDialog*DisplayArea.background: color

   Substitute the name of the application whose help windows you want to change for application_name.

   You can ask your system administrator for a list of colors that you can use or refer to your system documentation.

2. Save and close the file.

   When you restart your application, it will use the new color values for the topic tree and topic display area in its help windows.

Example

These resource entries change the foreground and background colors of the topic tree (TocArea) and topic display area (DisplayArea) for an application named DtCardCatalog.

DtCardCatalog*DtHelpDialog*TocArea.foreground:    yellow
DtCardCatalog*DtHelpDialog*TocArea.background:    blue
DtCardCatalog*DtHelpDialog*DisplayArea.foreground:    yellow
DtCardCatalog*DtHelpDialog*DisplayArea.background:    blue
DtCardCatalog*DtHelpQuickDialog*DisplayArea.foreground:    yellow
DtCardCatalog*DtHelpQuickDialog*DisplayArea.background:    blue

Quick help windows do not have a topic tree, so the TocArea resource is omitted.
Using the Front Panel

The Front Panel is a special desktop window that contains a set of controls for doing common tasks. The Front Panel moves with you as you switch workspaces.

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Front Panel Skills</td>
<td>65</td>
</tr>
<tr>
<td>A Tour of the Front Panel</td>
<td>71</td>
</tr>
<tr>
<td>Customizing the Front Panel</td>
<td>77</td>
</tr>
<tr>
<td>Customizing Workspaces</td>
<td>80</td>
</tr>
</tbody>
</table>

Front Panel Elements

The two main elements of the Front Panel are the Main Panel and the subpanels. The Main Panel includes the workspace switch.

Main Panel

The Main Panel is the horizontal window at the bottom of the display.
It contains a number of controls you use often, including the workspace switch, which contains buttons for changing to other workspaces.

Many of the controls in the Front Panel start applications when you click them—for example, the File Manager and Style Manager controls.

Some controls are drop zones—for example, the Printer and Trash Can controls. You can drag a file from File Manager or Application Manager to the control.

Certain controls, such as the clock and busy light, are indicators that tell you something about the state of your system. Other controls have a dual purpose; for example, the Calendar and Mailer controls are both indicators (showing today's date and the arrival of new mail, respectively) and buttons for starting applications.

**Subpanels**

If a control in the Main Panel has an arrow button on top of it, then that control has a subpanel.

Subpanels always contain:

- An Install Icon control. Use this control to customize the subpanel.
- A labelled copy of the control in the Main Panel.
The Workspace Switch

The workspace switch contains the buttons you use to change from one workspace to another. The workspace switch also contains several controls.

Each workspace occupies the entire display, as though your display has several layers. Workspaces multiply the amount of display area available for windows.

Basic Front Panel Skills

This section covers basic skills for using Front Panel controls and subpanels.

♦ To Activate a Front Panel Control

◊ Click or double-click the control.

Some controls do not have a click action—for example, the Clock control and the busy light.

♦ To Open a Subpanel

Controls that have subpanels have an arrow button on top of the control.
◊ Click the arrow button above the control.

◊ To Close a Subpanel

The subpanel closes automatically when you choose a control unless you have moved the subpanel from its original location.

- Click the arrow control for the subpanel.
- Or, double-click the window button in the upper left corner of the subpanel

Front Panel Pop-Up Menus

Each control in the Front Panel has a pop-up menu. The menu is different for each control.
♦ **To Display a Front Panel Pop-Up Menu**

1. Point to the control.
2. Press and hold down mouse button 3.

**Contents of the Pop-Up Menus**

The contents of the pop-up menu depend on the behavior of the control and its location.

**Main Panel Controls**

If the control starts an application, the first entry in the menu is a command that starts the application. Choosing the menu item has the same effect as clicking the control.

In addition, the pop-up menu may contain these items:

- **Add Subpanel**
  - Adds a subpanel to the control

- **Delete Subpanel**
  - Removes the subpanel and its contents

- **Help**
  - Displays On Item help for the control

**Switch Area**

The switch area is the portion of the workspace switch not occupied by other controls or workspace buttons.
The switch area pop-up menu contains these items:

- **Add Workspace**: Adds a workspace and creates a workspace button in the workspace switch.
- **Help**: Displays help for the workspace switch.
Workspace Buttons

Use the workspace buttons to change workspaces. Each button has its own menu.

The workspace button pop-up menu includes these items:

- **Add Workspace**: Adds a workspace to your list of workspaces
- **Delete**: Deletes the workspace
- **Rename**: Changes the button into a text field for editing the name
- **Help**: Displays help for the workspace switch

Subpanel Controls

The pop-up menus for subpanels include a command for making the control the current Main Panel control.

The pop-up menu for subpanel controls includes these items:

- **Copy to Main Panel**: Duplicates the control in the Main Panel, replacing the current Main Panel control
- **Delete**: Deletes the control from the subpanel
- **Help**: Displays On Item help for the control
Front Panel Help

You can get help on:
• Individual controls
• Using and configuring the Front Panel

♦ To Get On Item Help on a Front Panel Control
◊ Choose Help from the control’s pop-up menu.
   Or:
   1. Display the Help subpanel.
   2. Click the On Item Help control.
      The pointer changes shape.
   3. Click the control on which you want help.

♦ To Get Help on Using and Configuring the Front Panel
1. Display the Help subpanel.
2. Click the Front Panel Help control.
   This displays the Help Viewer and Front Panel help volume.

♦ To Move the Front Panel or a Subpanel
Subpanels are moved like other windows—by dragging the title bar.
The Main Panel is moved using its move handles.
♦ **To Minimize the Front Panel**

Minimizing the Front Panel turns it into an icon.

◊ Click the Front Panel’s minimize button.

The Front Panel window icon is labeled with the workspace name.

**A Tour of the Front Panel**

This section introduces the contents of the Main Panel and the subpanels:

- Personal Applications subpanel
- Personal Printers subpanel
- Help subpanel

Your Front Panel may be customized with different or additional controls.
The Main Panel

The Main Panel is the horizontal window at the bottom of the display.

Table 4-1 describes the Main Panel controls.

<table>
<thead>
<tr>
<th>Name</th>
<th>Click Behavior</th>
<th>Drop Behavior</th>
<th>Indicator Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clock</td>
<td>None</td>
<td>None</td>
<td>Current time of day</td>
</tr>
<tr>
<td>Calendar</td>
<td>Starts the desktop Calendar application</td>
<td>Dropping an appointment file adds the appointment to the calendar</td>
<td>Current date</td>
</tr>
<tr>
<td>File Manager</td>
<td>Opens a File Manager view of your home folder</td>
<td>Dropping a folder opens a File Manager view of that folder</td>
<td>None</td>
</tr>
<tr>
<td>Personal Applications (Text Editor)</td>
<td>Starts the desktop Text Editor application</td>
<td>Opens the file in a new Text Editor window</td>
<td>None</td>
</tr>
<tr>
<td>Mailer</td>
<td>Starts the desktop Mailer application</td>
<td>Opens the contents of the file in Mailer’s New Message window</td>
<td>Changes appearance when new mail arrives</td>
</tr>
<tr>
<td>Lock</td>
<td>Locks the display and keyboard. You must type your password to unlock the system.</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Workspace switch</td>
<td>Changes workspaces</td>
<td>None</td>
<td>Indicates current workspace</td>
</tr>
<tr>
<td>Name</td>
<td>Click Behavior</td>
<td>Drop Behavior</td>
<td>Indicator Behavior</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------------------------</td>
<td>---------------------------------</td>
<td>--------------------------------------------------------</td>
</tr>
<tr>
<td>Busy light</td>
<td>None</td>
<td>None</td>
<td>Blinks when the system is running an action</td>
</tr>
<tr>
<td>Printer (Default)</td>
<td>Displays the status of the default printer</td>
<td>Prints the file on the printer</td>
<td>None</td>
</tr>
<tr>
<td>Exit</td>
<td>Begins logout from the current session</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Style Manager</td>
<td>Opens the desktop Style Manager application</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Application Manager</td>
<td>Opens an Application Manager window</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Help Manager</td>
<td>Opens a Help Viewer window displaying the top level of help information</td>
<td>Dropping a master volume file (*.sdl) opens a Help Viewer window with that help volume</td>
<td>None</td>
</tr>
<tr>
<td>Trash Can</td>
<td>Opens the Trash Can window</td>
<td>Moves the file to the Trash Can</td>
<td>Different appearance when empty and non-empty</td>
</tr>
</tbody>
</table>
**Personal Applications Subpanel**

Use the Personal Applications subpanel for applications you use frequently. The default applications are Text Editor, Terminal, and Icon Editor.

Table 4-2 describes the Personal Applications subpanel controls.

<table>
<thead>
<tr>
<th>Name</th>
<th>Click Behavior</th>
<th>Drop Behavior</th>
<th>Indicator Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Install Icon</td>
<td>None</td>
<td>Installs an icon dragged from File Manager or Application Manager into the subpanel</td>
<td>None</td>
</tr>
<tr>
<td>Text Editor</td>
<td>Starts the desktop Text Editor application</td>
<td>Opens the file in a new Text Editor window</td>
<td>None</td>
</tr>
<tr>
<td>Terminal</td>
<td>Starts the desktop Terminal Emulator</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Icon Editor</td>
<td>Starts the desktop Icon Editor application</td>
<td>Opens a bitmap or pixmap file in a new Icon Editor window</td>
<td>None</td>
</tr>
</tbody>
</table>
Personal Printers Subpanel

Use the Personal Printers subpanel for printers you use frequently.

Table 4-3 describes the Personal Printers subpanel controls.

Table 4-3 Personal Printers Subpanel Controls

<table>
<thead>
<tr>
<th>Name</th>
<th>Click Behavior</th>
<th>Drop Behavior</th>
<th>Indicator Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Install Icon</td>
<td>None</td>
<td>Installs an icon dragged from File Manager or Application Manager into the subpanel</td>
<td>None</td>
</tr>
<tr>
<td>Default printer (duplicate of Main Panel control)</td>
<td>Display the status of print jobs on the default printer</td>
<td>Prints the file on the default printer or another printer of your choice</td>
<td>None</td>
</tr>
<tr>
<td>Print Manager</td>
<td>Starts the desktop Print Manager</td>
<td>Prints the file on the default printer</td>
<td>None</td>
</tr>
</tbody>
</table>
Help Subpanel

The Help subpanel enables you to access the Help Manager, Desktop Introduction, and Front Panel help volumes, and On Item help.

Table 4-4 describes the Help subpanel controls.

<table>
<thead>
<tr>
<th>Name</th>
<th>Click Behavior</th>
<th>Drop Behavior</th>
<th>Indicator Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Install Icon</td>
<td>None</td>
<td>Installs an icon dragged from File Manager or Application Manager into the subpanel</td>
<td>None</td>
</tr>
<tr>
<td>Help Manager</td>
<td>Opens a Help Viewer window displaying the top level of help information</td>
<td>Dropping a master volume file (*.sdl) opens that help volume</td>
<td>None</td>
</tr>
<tr>
<td>Desktop Introduction</td>
<td>Displays the help volume “Introducing the Desktop”</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Front Panel Help</td>
<td>Displays the Front Panel help volume</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>On Item Help</td>
<td>Provides on-item help for the Front Panel. Click this control, then click the control on which you want help.</td>
<td>None</td>
<td>None</td>
</tr>
</tbody>
</table>
Customizing the Front Panel

There are two types of Front Panel customization:

• Easy customization
  This is customization you can do using the desktop’s interface, including:
  • Adding controls to subpanels
  • Interchanging Main Panel and subpanel controls
  • Adding subpanels
  • Adding and deleting workspaces
  • Renaming workspaces

• Advanced customization
  This is customization that requires you to create or edit a Front Panel configuration file. For more information, see the CDE Advanced User’s and System Administrator’s Guide.

♦ To Put a Subpanel Control in the Main Panel

1. Point to the subpanel control you want to put in the Main Panel.
2. Choose Copy to Main Panel from the control’s pop-up menu.
**To Add an Application or Other Icon to a Subpanel**

You can add any type of File Manager or Application Manager icon to the Front Panel. However, the most convenient use for this feature is adding application icons.

1. Display the object's icon in File Manager or Application Manager.
2. Display the subpanel to which the object is to be added.
3. Drag the object to the Install Icon control and drop it on the control.

**How Installed Icons Work**

The behavior of controls added to the Front Panel using the Install Icon control depend on the type of icon that was dropped.

<table>
<thead>
<tr>
<th>Type of Icon Installed</th>
<th>Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>The same behavior as the file's icon in File Manager</td>
</tr>
<tr>
<td>Folder</td>
<td>Opens a File Manager view of the folder</td>
</tr>
<tr>
<td>Application group</td>
<td>Opens an Application Manager view of the application group</td>
</tr>
<tr>
<td>Application icon</td>
<td>The same behavior as the application's icon in File Manager or Application Manager</td>
</tr>
</tbody>
</table>

**Adding and Removing Subpanels**

Any control in the Main Panel can have a subpanel.

**To Add a Subpanel**

1. Point to a control in the Main Panel that does not have a subpanel.
2. Choose Add Subpanel from the control's pop-up menu.

**To Remove a Subpanel**

1. Point to the control whose subpanel you want to remove.
2. Choose Delete Subpanel from the control's pop-up menu.
To Replace a Control in the Main Panel

The easiest way to replace a control in the Main Panel is to exchange it with a subpanel control. If the control does not have a subpanel, you can create one temporarily or permanently.

1. If the control you want to replace does not have a subpanel, create one by choosing Add Subpanel from the control's pop-up menu.

2. Display the new subpanel.

3. If the control you want to put in the Main Panel is not already in the subpanel, add it to the subpanel.

   See “To Add an Application or Other Icon to a Subpanel” on page 78.

4. Choose Copy to Main Panel from the subpanel control's pop-up menu.

To Remove All User Customizations

Note - This procedure does not affect advanced customizations made by manually editing Front Panel configuration files.

1. Open Application Manager and double-click the Desktop_Tools application group icon.

2. Double-click Restore Front Panel.

   The screen will go blank for several seconds while the Workspace Manager is restarted.

The Restore Front Panel action removes all customization made using:

- The Install Icon control
- The Front Panel’s pop-up menus
Customizing Workspaces

You can use the Front Panel workspace switch to rename workspaces and change the number of workspaces.

♦ To Rename a Workspace

1. Point to the workspace button of the workspace you want to rename.
2. Choose Rename from the button’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).
   The workspace button turns into a text field.
3. Edit the text field.
4. Press Return.

♦ To Add Workspaces

1. Point to any area in the workspace switch and press mouse button 3 to display the pop-up menu.
2. Choose Add Workspace from the pop-up menu.
   The new workspace, named New, is placed at the end of the set of workspaces.
3. Rename the workspace (see “To Rename a Workspace” above).

♦ To Remove Workspaces

If you remove a workspace that contains windows, those windows are moved to the next workspace.
1. Point to the workspace button of the workspace you want to remove.
2. Choose Delete from the button’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).
To Customize the Controls in the Workspace Switch

This is an advanced task that requires you to create a Front Panel configuration file. Advanced customization is covered in the CDE Advanced User’s and System Administrator’s Guide.

Initially, the workspace switch has these four positions.

![Workspace Switch Diagram]

Use this procedure to replace one of these controls. (Blank is also a control.)

1. Install the application you want placed in the switch into the Personal Applications subpanel.

   For example, if you want to add a Display System Load control to the switch, drag it from the Desktop_Tools application group to the Personal Applications subpanel.

2. Locate the Front Panel configuration file created automatically when you installed the control in the Personal Applications subpanel. The definition is located in the directory 
   

   For example, when Display System Load is added to the Personal Applications subpanel, it creates the file Xload1.fp.


4. Open the file in the HomeDirectory/.dt/types directory for editing.

   Edit the lines that define the CONTAINER_TYPE and CONTAINER_NAME to the following:

   CONTAINER_TYPE SWITCH
   CONTAINER_NAME Switch

Using the Front Panel
5. Edit the line that defines the position (POSITION_HINTS). For example, to put the control in the Blank location, set:

```c
POSITION_HINTS 3
```

6. Save the configuration file.


   The file name must end with .fp. For example, you might create a new file HomeDirectory/.dt/types/DeleteBlank.fp.

8. Open the file for editing.


   This file is read-only. You will not have to write to it.

10. In /usr/dt/appconfig/types/language/dtwm.fp, find the definition for the switch control you are replacing.

    For example, this is the definition for the Blank control:

```c
CONTROL Blank
{
    TYPE blank
    CONTAINER_NAME Switch
    CONTAINER_TYPE SWITCH
    POSITION_HINTS 3
    ICON FpblnkS
    HELP_TOPIC FPOnItemSwitch
    HELP_VOLUME FPanel
}
```

11. Copy the definition for the control you are replacing from /usr/dt/appconfig/types/language/dtwm.fp to the new configuration file.

    For example, you would copy the definition for the Blank control to the new file HomeDirectory/.dt/types/DeleteBlank.fp.
12. Add the line `DELETE True` to the end of the definition, within the curly braces:

```
CONTROL Blank
{
...
HELP_VOLUME FPanel
DELETE True
}
```

13. Save the file.

14. Choose Restart Workspace Manager from the Workspace menu. You will see the new control in the switch.
Managing Files with File Manager

Use File Manager to create, find, and use desktop objects: files, folders, and applications. Each object is represented by an icon in File Manager.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introducing the File Manager Window and Desktop</td>
<td>86</td>
</tr>
<tr>
<td>Basic File System Concepts</td>
<td>87</td>
</tr>
<tr>
<td>Basic File Management Skills</td>
<td>90</td>
</tr>
<tr>
<td>Manipulating Files and Folders</td>
<td>96</td>
</tr>
<tr>
<td>Navigating to Folders and Subfolders</td>
<td>99</td>
</tr>
<tr>
<td>Deleting Objects to the Trash Can</td>
<td>102</td>
</tr>
<tr>
<td>Using File Manager Objects on the Desktop</td>
<td>106</td>
</tr>
<tr>
<td>Locating Files</td>
<td>108</td>
</tr>
<tr>
<td>Customizing File Manager Views</td>
<td>111</td>
</tr>
</tbody>
</table>
To Open File Manager

◊ Click the File Manager control in the Front Panel.

Introducing the File Manager Window and Desktop

The File Manager main window is a view of a folder on your system. The folder you are currently viewing is called the current folder.

- Current folder path: Displays the path to the current folder.
- Menu bar and menus: Contain the commands available in File Manager.
- Object viewing area: Shows the objects (files and folders) in the current working folder.
- Object icons: Icons representing the files and folders in the current folder.
Basic File System Concepts

This section describes basic file system concepts.

Files

A file is a container that holds information. Most of the files you use contain information (data) in some particular format—a document, a spreadsheet, a chart. The format is the particular way the data is arranged inside the file. The format of a file is known as its data type.

When File Manager is in one of its icon-view modes, you can identify the data type of a file by the icon used to represent the file. Each data type has a different icon.

Most application programs understand a limited number of data types. For example, a document editor probably cannot read a spreadsheet file. The desktop helps you recognize different types of files using a data type database. A data type identifies the files of a particular format and associates them with the appropriate applications. These associations mean you don't have to remember commands to accomplish frequent tasks. In most cases, when you double-click a file, the desktop will automatically launch the application that understands that file's data type.

The maximum allowable length of a file name varies from system to system. Some operating systems do not allow file names longer than 14 characters. If necessary, consult with your system administrator.

Folders

A folder is a container for files, similar to a folder in a file cabinet. In fact, File Manager uses a folder icon to represent a folder. A folder can contain other folders—sometimes called subfolders. With folders and subfolders, you can create multiple layers of organization that form a hierarchy. In other contexts, folders are often referred to as directories.

If you drew a picture of the folder hierarchy with each subfolder underneath the folder that contains it—its parent folder—and drew a line from each folder to its parent, the picture would look like an upside-down tree. Therefore, we often call the folder hierarchy a folder tree.
Within any single folder, each file name must be unique. However, files in different folders may have the same name.

As you navigate from folder to folder, your current location is referred to as the current folder.

**Objects**

Since files and folders are both represented in File Manager as icons, the term object is used to describe them both. Objects are discrete things on the desktop that you can create and manipulate.

On the desktop, applications can also be represented as objects. For example, Application Manager contains objects representing the applications available on your system.

**Paths**

The location of a file is often specified by listing the folders and subfolders that lead to the file—this list is called a path. A file's path is visible in two places in File Manager. First it is shown in the iconic path as a string of folders. Second, it is shown in a text form in the text path line above the view area. These two areas can be turned off. (See “To Configure the Headers” on page 111 for more information.)

**Paths and Path Names**

The path to an object is a way to specify where the object is located in the file system. There are two ways to specify the path: absolute path and relative path.

**Absolute Paths**

A path is an absolute path if it begins at the root folder. The root folder is the single common folder on your system where the hierarchy begins. If a path begins with a slash (/), it is an absolute path specified from the root folder. For example, the following is an absolute path to the file letter:

```
/usr/dt/config/letter
```
Relative Paths

A path is relative if it describes the location of a file or folder as it relates to the current folder. If you are in a folder and you want to move down the folder tree, you don't need to type the absolute path name. You can just type the path starting with the name of the next folder in the path. If a path does not begin with a slash, it is a relative path. For example, if the current folder is `/usr/dt` and you want to move to the folder `/usr/dt/config/letters`, you would use the following relative path:

```
config/letters
```

Two special folder names are useful when specifying relative paths. The `.,” folder (sometimes called “dot”) represents the current folder. The “..” folder (sometimes called “dot-dot”) represents the parent folder—the folder one level up in the folder hierarchy. For example, if your current folder is `/usr/dt/config`, then the relative path to the `Dtwm` file becomes:

```
../app-defaults/language/Dtwm
```

because the file is in the `/usr/dt/app-defaults/language` folder, one level above the current folder and in the app-defaults/language subfolder.

See Also

- “To Change to Another Folder” on page 99
- “To Find an Object by Name” on page 109
- “To Find a File by Contents” on page 110

If you still want to learn more about your computer's file system, refer to the online help or documentation for your operating system. There are also many commercial books available that cover the basics of file systems and file management.
Basic File Management Skills

To get started using File Manager, you need to learn a few basic skills. Each icon in File Manager represents an object that you can manipulate in a variety of ways, including:

- Object selection
- Dragging and dropping
- Using pop-up menus
- Renaming objects
- Getting online help on objects
- Opening objects

♦ To Select a Single File or Folder

When you select the icon of a file or folder, its name is highlighted. Many choices in File Manager’s menus apply to the currently selected file or folder. You select an object so that you can use one of the Selected menu choices on that object. The Selected menu contains choices that affect only the currently selected objects. The contents of this menu will change as you select different kinds of objects in the view area. These choices will appear dimmed until you select an icon.

Mouse

♦ Click once on the icon.

Keyboard

1. Use the Tab and arrow keys to move the highlight to the icon you want to select.

2. Press the Spacebar.

To deselect a file or folder, select another icon or click an empty area within the File Manager window.
♦ **To Select Multiple Files and Folders**

You select multiple objects so that you can use one of the Selected menu choices on these objects. Selecting multiple files is useful if you want to delete several files at once, or move a group of files to a new folder. However, when you select more than one object, the Actions portion of the Selected menu will be empty.

When multiple icons are selected, dragging any one of the selected icons drags the whole group. The Selected menu and various menu commands that apply only to a single object are inactive.

**Mouse**

- Press mouse button 1 in a blank area of the view, drag the mouse to draw a box around the icons you want to select, then release the mouse button.

  Or, you can click mouse button 1 to select the first icon, then hold down the Control key and click mouse button 1 to select each additional icon. This method is useful when the icons you want to select are not located next to each other.

- To remove a single icon from a selected group, hold the Control key down and click the icon you want to remove.

**Keyboard**

1. Select the first file or folder icon by pressing the Spacebar.

2. For each additional icon you want to select, move the highlight to it, then press Control+Spacebar.

♦ **To Drag and Drop a File or Folder**

1. Put the mouse pointer over the file or folder.

2. Press and hold mouse button 1.

3. Drag the icon to where you want to drop it.

4. Release the mouse button.

So, the motion for dropping an object is press...drag...release.
To cancel a drag in progress, press Esc before releasing the mouse button.

![Drag icon showing the object being dragged](image)

Figure 5-1 Drag icon showing the object being dragged

If more than one icon is selected, you drag the entire group by dragging any of the selected icons.

**Note** - You cannot drag and drop an object without a mouse or other pointing device.

**Basic Drag-and-Drop Tasks**

- To move a file to another folder, drop the icon on the destination folder's icon. Or, if both the source and destination folders are open, drag the icon from the source folder's view window and drop it onto the background of the folder's view window.

- To place an icon for a file or folder on the backdrop of your current workspace, drop the file or folder icon outside of any window. A desktop object is really just a reference to the real object, which remains in the File Manager view, unchanged.

- To print a file, drop the file icon onto the Printer control in the Front Panel (or one of the printers in the Personal Printers subpanel).

- To delete a file or folder, drop the file or folder icon onto the Trash Can control in the Front Panel.

If you try to drop an icon in a location that does not support dropped objects, the icon snaps back to its original location in File Manager or on the desktop.
♦ **To Display a Pop-up Menu**

Each object in File Manager has a pop-up menu. The File Manager window itself has a pop-up menu viewable when the pointer is placed in a location in the view window outside the boundaries of the individual file or folder objects.

**Mouse**

1. Point to the icon whose pop-up menu you want to display and press mouse button 3. (On a two-button mouse, press the right mouse button.)

2. To choose a command from the menu, drag to the command, then release. Or, click the command.

**Keyboard**

1. Using the Tab and direction keys, move the highlight to the icon whose menu you want to display.

2. Press Shift+F10.

3. To choose a command from the menu, use the direction keys to highlight the command, then press Return.

4. To cancel the menu without choosing a command, press Esc.

![Sample pop-up menu](image)
To Rename a File or Folder

**Note** - You can't rename actions.

**Mouse**
1. Select the file or folder name by clicking the name beneath its icon.
2. Type the new name.
3. Press Return. If you click outside the name without first pressing Return, your changes will be lost.

To cancel a rename operation, press Esc.

**Keyboard**
1. Use the Tab and arrow keys to move to the icon for the file or folder you want to rename.
2. Press the Spacebar to highlight (select) the icon name.
3. Choose Rename from the Selected menu.
4. Type the new name.
5. Press Return.

To cancel a rename operation, press Esc.

To Get Help on a File or Folder

The description displayed when you ask for help on an icon describes the data type associated with the file or folder. The description is specified in the data-type definition.

**Mouse**
- Select the file or folder, then press F1.
- Or, put the mouse pointer on the object and select help from the object's pop-up menu (displayed by pressing mouse button 3).
• Or, choose On Item from the Help menu, then click the file or folder’s icon.

Keyboard
◊ Use the Tab and arrow keys to move to the icon, then press F1.

See Also
• To find out more about how to use Help, see Chapter 3, “Getting Help.”
• For an introduction to creating data types and actions, see “Creating Personal Actions and Data Types” in Chapter 6, “Running Applications from the Desktop.”

Opening a File or Folder

The most basic action you can perform on an object is to open it. “Open” is a very general term, and the action taken depends on the type of object you are opening. For example, opening a folder changes the File Manager view to show the contents of that folder. Opening a data file usually starts the application that created the file and loads the data file

♦ To Open a File or Folder

• Double-click the icon.
  
  Double-clicking an icon executes the object’s default action, which is always the first action in the Actions portion of the Selected menu. For most data files, the default action opens the file by starting the appropriate application and loading the file.

• Or, select the icon, then go to the menu bar and choose Open (or Open In Place or Open New View) from the Selected menu.

• Or, choose an Open item from the icon’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).
Manipulating Files and Folders

The major identifying features of a file or folder are:

- Its name and location in the folder hierarchy.
- Its owner permissions (properties).
- Whether it is linked to another file. A linked file is a representation of another file. Linked files provide a way for you to have one file that appears to exist in two or more folders.

To Create a New File or Folder

1. Choose New File or New Folder from the File menu.
2. Type the name into the New File or New Folder field.
3. Click OK or press Return.

To close the New File or New Folder dialog box without creating a new file or folder, click Cancel or press Esc.

Other Ways to Create Objects

- Copy an existing object, then rename the copy (see “To Copy a File or Folder” on page 97).
- Create a new file within an application. For example, Text Editor creates a new file when you save a new document.

To Move a File or Folder

Note - If you attempt to move a file or subfolder from a folder where you do not have permission to make changes, File Manager may create a copy of the object, and display an error message indicating that you cannot delete the original file.
Mouse
1. Make the source and destination folders visible:
   Open a File Manager view of the contents of the destination folder or the icon of the closed destination folder.
2. Select the file or folder to be moved and drag it to the destination folder.
If you move a folder, the entire folder and its contents are moved.

Keyboard
1. Use the Tab and direction keys to move the highlight to the file or folder to be moved.
2. Press the Spacebar to select the object.
3. Choose Move to from the Selected menu.
4. Type a name into the Destination Folder text field.
   For example, if you want to move the file `report` into the folder `/u/john`, you would type `/u/john`
5. Click OK or press Return.
If you move a folder, the entire folder and its contents are moved.

♦ To Copy a File or Folder

Mouse
1. Make the source and destination folders visible:
   Open a File Manager view of the contents of the destination folder or the icon of the closed destination folder.
2. Select the file or folder to be copied.
3. Press and hold the Control key.
4. Drag the file or folder and drop it onto the destination folder.
   Make sure that you release the mouse button before you release the Control key. Otherwise, you will move instead of copy the file or folder.
Keyboard
1. Select the icon.
2. Choose Copy to from the Selected menu.
3. Type a name into the Destination Folder text field.
   Note that this must be the new full path name for the file. For example, if you want to copy the file report into the folder /u/jon, you would type /u/jon.
4. Click OK or press Return.

To close the Copy File dialog box without copying a file, click Cancel or press Esc.

♦ To Create a Symbolic Link

A link icon is a copy of an icon that points to the same file or folder as the original icon. Any changes you make after opening the link icon will also appear when you access the file or folder using the original icon.

Mouse
1. Make the source and destination folders visible:
   • Open a File Manager view of the contents of the destination folder.
   • Or, open a File Manager view that shows the icon of the closed destination folder.
2. Select the file or folder to be copied.
3. Press and hold the Shift key and the Control key while dragging and dropping the icon of a file or folder onto the icon of a new folder.
   When you drop the icon, File Manager creates symbolic link in the new folder that points to the original file or folder. Make sure that you release the mouse button before you release the Shift key and the Control key. Otherwise, you will move instead of link the file or folder.
Keyboard
1. Use the Tab and arrow keys to move the highlight to the icon of the file or folder to which you want to link.

2. Press the Spacebar to select the icon.

3. Choose Copy as Link from the Selected menu.

4. Type a name into the Destination Folder text field including the path for the name of the folder where you want this link icon to appear. If you want this link icon to have a different name that the original icon, type a new name in the Name for copy text field.

5. Click OK or press Return.

Navigating to Folders and Subfolders
Each File Manager window (also called a view) shows the contents of a single folder.

If you are not familiar with hierarchical file systems, see “Basic File System Concepts” on page 87.

♦ To Change to Another Folder
You can change to another folder in any of the following ways:

• Double-click a folder icon.

• Select a folder icon and choose Open In Place from the Selected menu to open the folder in the current window or Open New View from the Selected menu to open it in a new window.

• Choose the Open In Place or Open New View command from the folder’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

• Double-click a folder in the iconic path to change the view to that folder.

• Select (click) the current folder line to change it into a text field. Type the name of the path you want and then press Return.

• In the current folder line, double-click a segment of the current path. For example, if the current folder is /users/tom/.dt/types, you can change to the /users/tom folder by double-clicking the word tom.
♦ **To Go to Your Home Folder**

◊ Choose Go Home from the File menu.

♦ **To Change to the Parent Folder**

• Choose Go Up from the File menu
• Or, double-click the .. (go up) icon.

♦ **To Open a Terminal Window in the Current Folder**

This procedure opens a terminal emulator window with the same current folder as the File Manager window. This is a quick way to type a command to affect the contents of the folder you are currently viewing.

◊ Choose Open Terminal from the File menu.

---

**Note** - You must have execute permission for a folder before you can open a Terminal window from it.

To find out how to use terminal emulators, see Chapter 12, “Using Terminal.”

---

**Executing an Action for a File or Folder**

Actions act on objects, and are a basic part of working with them. For example, printing the contents of an object uses the Print action. Starting an application for a data file object uses an Open action, or some other application action.
The Selected menu contains a list of commands followed by a list of actions you can use with the selected icon. The contents of the actions portion of the Selected menu change depending on the type of icon that is currently selected.

The action listed at the top of the action portion of the menu (the default action) is the action that will be taken when you double-click a file or folder. In the menu shown in the figure, the default action is Open In Place.

- **To Execute the Default Action**

  The default action is the first action listed in the actions portion of the Selected menu.

  1. Double-click the object’s icon.

- **To Execute Other Actions**

  1. Select the object's icon.
  2. Choose the action you want to execute from the Selected menu or from the object's pop-up menu.
Deleting Objects to the Trash Can

The Trash Can collects the files and folders that you delete. They are not actually removed from the file system until the trash is “emptied.” You can only change your mind and restore a file you’ve put in the Trash Can if the Trash Can hasn’t been emptied.

♦ To Open the Trash Can Window

◊ Click the Trash Can control in the Front Panel.

♦ To Put an Object in the Trash Can

• Choose Put in Trash from the object’s pop-up menu (displayed by pressing Shift+F10 or mouse button3).
• Or, select the object’s icon, then choose Put in Trash from the Selected menu.
• Or, drag and drop the object’s icon onto the Trash Can control in the Front Panel.
• Or, drag an object’s icon to the open Trash Can window.

♦ To Put Back a File or Folder from the Trash Can

• Drag the object from the Trash Can window to File Manager.
• Or, in the Trash Can window, select the object you want to restore and choose Put back from the File menu.
• Or, choose Put back from the object’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).
♦ **To Delete a File or Folder Permanently**

When you delete a file permanently, it cannot be recovered (unless you have a backup mechanism.)

1. Open the Trash Can.

2. Select the objects you want to empty from the Trash Can.
   
   Select individual objects, or choose Select All from the File menu.

3. Choose Shred from the File menu or from the object’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

4. Click OK in the confirmation dialog box.

**Note** - The Trash Can is automatically emptied when you log out of a session.

---

**File Ownership and Security**

Three groups of users can access files: owner, group, and other. File access is divided into three types of permissions: read, write, and execute.

**Who Has Access?**

The three basic classes of users are:

- **Owner** – Usually the person who created the object.
- **Group** – Users that have been grouped together by the system administrator. For example, the members of a department might belong to the same group.
- **Other** – All other users on the system.
Types of Access Permissions

The access permissions on a file specify how that file can be accessed by the owner, members of the group, and other users.

- **Read Permission** - Allows access to retrieve, copy, or view the contents of the object.
- **Write Permission** - Allows access to change the contents of the object or remove the object.
- **Execute Permission** - For a file, allows access to run the file (for executable files, scripts, and actions). For a folder, allows access to run commands, scripts, and actions within that folder.

If you do not have permission to write inside a folder, the folder will look like this:

![Folder Read-Only]

If you do not have read or execute permission for a folder, the folder will look like this:

![Folder Read-Only]

**Examples**

To make a folder private:

- Change the folder's properties, giving yourself (the owner) read, write, and execute permission, but giving no permissions for group and other. This means that only you and the root user can view the contents of the folder.

To make an object that you've created available for everyone to use but protect it so it isn't inadvertently overwritten:

- Change the file's properties, giving read and execute permission to owner, group, and other. Don't give anyone write permission.
Default Permissions

The default permissions used when you create a new file or folder may be altered by your system administrator. To determine what your current defaults are, create a new file or folder, then open the Permissions dialog box for that file or folder.

Check with your system administrator regarding how to change your default permissions.

♦ To Change the Owner of a File or Folder

You must be the owner or the system administrator (root user) in order to change the ownership of a file or folder.

1. Select the object's icon.
2. Choose Change Permissions from the Selected menu or from the object's pop-up menu (displayed by pressing Shift+F10 or mouse button 3).
3. Type the new owner's name into the Owner Name text field.
4. Click OK or press Return.

Note - If you give ownership of the file to another user, you may not be able to change the permissions again unless that user returns ownership to you.

If you do not have permission to change the properties, some of the controls in the Permissions dialog box are unavailable.

♦ To Change the Permissions on a File or Folder

You must be the owner or the system administrator (root user) in order to change the permissions of a file or folder.

1. Select the icon for the file or folder.
2. Choose Change Permissions from the Selected menu or from the icon's pop-up menu (displayed by pressing Shift+F10 or mouse button 3).
3. Select the permissions for the file or folder.

The permissions selected in the Group row indicate the access privileges for any user belonging to the named group. The permissions selected for the Other row apply to all other users.

- **Read** The file can be read
- **Write** The file can be altered
- **Execute** The file can be run

If you give ownership of the file to another user, you may not be able to change the permissions again unless that user returns ownership to you. If you do not have permission to change the properties, some of the controls in the Permissions dialog box are unavailable.

4. Click OK or press Return.

**Note** - The Group row of permissions shows the permissions for users who are members of the group listed in the Group Name text field. You can specify a different group by typing a new name in this field.

---

**Using File Manager Objects on the Desktop**

The desktop lets you put any file or folder icon directly on the backdrop of the current workspace for quick access. Any icon you drop on the desktop stays where you put it.

File Manager provides a way to view all the objects in your file system. However, the object is only visible when you are viewing the folder it is in.

To make an object more accessible, you can put it directly on the workspace backdrop. The desktop is that area or surface on which windows appear to lie. When an object is placed there, it is called a workspace object. There is a separate desktop for each workspace.

Placing an object on the workspace does not alter the original file or folder. In fact, the icon that appears on the workspace is really just a shortcut for accessing the real file or folder. Any operation you perform on the workspace object is actually performed on the file or folder it represents.
Workspaces in the Desktop
You can have several workspaces on your desktop, so you can set up your working environment by putting the files and folders in the workspaces where you use them most, or in more than one workspace, if needed.

Pop-up Menus
Each workspace object has its own pop-up menu, displayed with mouse button 3 or by pressing Shift+F10 when the icon is selected. This menu contains commands for manipulating the object, including all the actions that appear in the File Manager’s Selected menu when the object is selected. The Workspace pop-up menu is similar to the pop-up menu available within File Manager windows, but contains a few different commands.

♦ To Put a File or Folder on the Workspace Backdrop
This procedure creates a copy of the icon on the workspace backdrop. Any changes you make to the copy on your workspace backdrop will also be made to the original that is still in File Manager.

1. Switch to the workspace where you want to display the object.
2. Then:
   • Drag and drop the object’s icon onto the workspace.
   • Or, select the icon, then choose the Put in Workspace command from the Selected menu or from the icon’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

You can repeat these steps to put an icon on the desktop in as many workspaces as you want.

♦ To Display the Pop-up Menu for a Workspace Object

Mouse
1. Point to the object’s icon.
2. Press mouse button 3.
3. Choose a command from the menu by dragging to the command then releasing the mouse button.

**Keyboard**

1. Move the highlight to the object’s icon using Alt+Tab.
2. Press Shift+F10.
3. Choose a command from the menu by using the direction keys to highlight the command, then press Return.

To cancel the menu without choosing a command, press Esc.

♦ **To Remove an Object from the Workspace**

1. Switch to the workspace where the object resides.
2. Locate the object’s icon on the desktop.
3. Choose Remove From Workspace from the object’s pop-up menu.

Removing an object from the workspace does not alter the original object. That is, the object still exists in File Manager.

**Locating Files**

Keeping track of many files can quickly become difficult. File Manager helps by providing the ability to search for a file or folder by name. You can also search for files based on the contents of the file.
To Find an Object by Name

1. Choose Find from the File menu.

2. Type the name of the file or folder you want to find into the File or Folder Name field.

When you specify a file or folder name, you can include wildcard characters, such as asterisk (*) and question mark (?). The * matches any string of characters (including no characters), and ? matches any single character. For example:

- ba*  Matches all names that begin with the string ba
- ba?  Matches all three-character names that begin with the string ba
- *.dt  Matches all names that end with the .dt suffix
- *.???  Matches all names that have a three-character suffix

The file name and contents can be specified using the same regular expression syntax allowed by the find command. (Refer to the find man page and grep man page for more information.)
3. Type the folder where you want the search to begin into the Search Folder field. (By default, this field contains the name of the current folder.)

Find will search this folder and all of its subfolders.

4. Click Start or press Return.

File Manager begins searching the Search Folder and the folders it contains for files that match the name you provided. Matches that are found are listed in the Files Found list. Once you have found an object, you can select it and click Open Folder to open the folder it is in or Put in Workspace to place its icon on the current backdrop.

To stop the search, click the Stop button or press Return.

♦ To Find a File by Contents

1. Choose Find from the File menu.

2. Optional. You can use the File or Folder Name text field to narrow, and therefore speed up, the search.

   If you enter a partial name (using wildcards) File Manager examines only the files that match the File or Folder Name field. If you leave the File or Folder Name field empty, File Manager searches every file within the search folder. Names can be specified using the same regular expression syntax allowed by the grep command. (Refer to the grep man page for more information.)

3. Type the text string you want to search for into the File Contents field.

   Case is ignored for this string (upper- and lowercase letters are equivalent). You do not have to use complete words. For example, if you type fi it will find both "fish" and "File."

   Contents can be specified using the same regular expression syntax allowed by the grep command. (Refer to the grep man page for more information.)

4. Type the name of the folder where you want the search to begin into the Search Folder field. (By default, this field contains the name of the current folder.)
5. Click Start or press Return.

File Manager begins searching the search folder and the folders it contains for files that contain the File Contents string. Matches that are found are listed in the Files Found list. Once you have found an object, you can select it in the list and then click Open Folder to open the folder it is in or Put In Workspace to place its icon on the current backdrop.

To stop the search at any time, click the Stop button or press Return.

**Customizing File Manager Views**

File Manager provides several ways to see the contents of folders. You can:

- Change the basic viewing structure from one folder at a time to seeing a tree view. See “To Display the Tree View” on page 113.
- Determine the sort order of objects. See “To Change the Order Icons Are Sorted” on page 115.
- Hide (filter) certain objects. See “To Show or Hide Files and Folders” on page 117.
- Change the style used for objects – names and small or large icons, names alone, or a long list of names plus properties.

♦ **To Configure the Headers**

1. Choose Set View Options from the View menu.

2. Determine which headers to display:
   - Select Iconic Path to show current folder path as a string of folder icons at the top of the window.
   - Select Text Path to show the current folder’s full path name in a text field above the view pane.
   - Select Message Line to show a count of the number of files in the folder. The line will appear at the bottom of the window.

3. To implement the chosen option and close the Set View Options dialog box, click OK.

   To implement the chosen option and leave the Set View Options dialog box open, click Apply.
To Configure How Icons are Placed

1. Choose Set View Options from the View menu.

2. Determine how you want to have the icons placed:
   • Select As Placed to leave icons where they are dropped.
   • Select Rows and Columns to automatically align the icons you drop into a grid.

3. To implement the chosen option and close the Set View Options dialog box, click OK.

   To implement the chosen option and leave the Set View Options dialog box open, click Apply.

Using the Tree View

The tree view resembles an outline. Files and folders contained in a folder are listed beneath that folder in an indented list.

![File Manager tree view](image)

**Figure 5-3 File Manager tree view**
In the tree view, a folder can have three states. The states are shown and changed using the buttons to the left of the folder. You can also open and close the tree branches by selecting a folder and then pressing the + and - keys on your keyboard (these are the keys in the center, not the numeric keypad):

+ The folder is in its closed state. None of the folder's contents are shown. Clicking the button expands the folder partially or fully, depending on the tree view option currently in effect.

- The folder is in its fully expanded state. All objects in the folder are shown. Clicking the button fully closes the folder.

+/- The folder is in its partially expanded state. The only contents shown are the folders it contains. (This view is possible only when using the Folders, then Files tree view option.) Clicking the button expands the folder to show the filenames.

♦ **To Display the Tree View**

The tree view will show a folder and the files and folders beneath it.

1. Change to the folder where you want the tree view to start.

2. Choose Set View Options from the View menu.

3. Select By Tree in the Show box.

4. Select one of the tree view options:

   - **Folders only** The tree shows folders only. To view files, double-click a folder name. This is the default view.

   - **Folders, then Files** Folders only appear at first. Click the [+] button next to each folder to view its contents. First click shows subfolders. Second click shows files that are inside. When you click the button the third time, the folder contracts again.

   - **Folders and Files** The tree shows both folders and files automatically.
5. To implement the chosen options and close the Set View Options dialog box, click OK.

   To implement the chosen options and leave the Set View Options dialog box open, click Apply.

You can alter the appearance of files and folders in the tree view by changing the settings in the Show box in the Set View Options dialog box. Changes to the preferences are only for the current session. To make them permanent, see “To Save the Current Preferences as Your Default” on page 116.

If you double-click a folder in tree view, a new view of that folder opens that is not in tree view mode.

♦ To Display the Folder View

   The folder view will show a folder and all the files and folders in that folder.

1. Change to the folder that you want to view.

2. Choose Set View Options from the View menu.

3. Select By Single Folder in the Show box.

4. To implement the chosen options and close the Set View Options dialog box, click OK.

   To implement the chosen options and leave the Set View Options dialog box open, click Apply.

You can alter the appearance of files and folders in the folder view by changing the settings in the Show box in the Set View Options dialog box. Changes to the preferences are only for the current session. To make them permanent, see “To Save the Current Preferences as Your Default” on page 116.
♦ **To Change How Objects Are Represented**

1. Choose Set View Options from the View menu.
2. Select the representation you prefer from the Representation box.
   - By Name Only: Icons will not be displayed in File Manager. File Manager indicates objects that are folders by adding a “/” after their names. Executable programs have a “*” after their name.
   - By Large Icons: This is the default. The objects in File Manager will appear with their name and large icon.
   - By Small Icons: The objects in File Manager will appear with their name and small icon.
   - By Name, date, size, ...: The objects in File Manager will appear with their file date, size, and so on in addition to the file name and icon.
3. Click OK or Apply.

♦ **To Change the Order Icons Are Sorted**

1. Choose Set View Options from the View menu.
2. Select the sort order you prefer from the Order box, and the direction from the Direction box.
   - Alphabetically: A to Z (Ascending) or Z to A (Descending). Icons with names that start with capital letters appear first. Icons with names that start with lowercase letters are at the bottom.
   - By File Type: By object type. For example, files, folders and actions are different types of objects. Within each group of the same type, the icons are sorted alphabetically (based on the order the data types are read into the database).
   - By Date: By date the files were last modified, oldest to newest (Ascending) or newest to oldest (Descending).
   - By Size: By file size, smallest to largest (Ascending) or largest to smallest (Descending).
3. Click OK or Apply.
If you have Placement set to As Placed, icons are sorted only when you choose Clean Up from the View menu or when you click Apply in the Set View Options dialog box. If Placement is set to Rows and Columns, the icons are sorted each time there's a change to the folder's contents, or when you choose Update from the View menu.

♦ To Re-Sort (Clean Up) Objects

The Clean Up command sorts the objects in the current view (according to the settings in the Set View Options dialog box) and lines them up in a grid pattern. The settings in other File Manager windows are not affected.

◊ Choose Clean Up from the View menu.

The Clean Up command is unavailable if you have the Placement preference set to Rows and Columns.

♦ To Save the Current Preferences as Your Default

When you apply changes using the Set Preference dialog box, the changes only apply to the current session. If you want to save the preferences so they will be used the next time you open File Manager:

1. Set the preferences that you want and apply them (using Set View Options and Set Filter Options in the View menu).

2. Choose Save As Default Options from the View menu.

3. Click OK.

These changes to the default view will not take effect until the next time you click the File Manager control in the Front Panel.

After saving the current preferences, all new File Manager views you open use the new preferences and filter list.
Hiding Files and Folders

Hidden files and folders are those whose file types are selected in the filter list.

The criterion for hiding or showing a file or folder is based on its data type. Use the Set Filter Options command to change which data types are shown and hidden. (See “To Specify Which Data Types Are Hidden” below.) The default hidden data types are DOT_FILE, DOT_FOLDER, and CURRENT_FOLDER.

♦ To Show or Hide Files and Folders

◊ Choose Show Hidden Objects from the View menu.

Choosing the command a second time again reverses the toggle (from shown to hidden and back again).

The criterion for hiding or showing a file or folder is based on its data type. Use the Set Filter Options command to change which data types are shown and hidden. (See “To Specify Which Data Types Are Hidden” below.) The default hidden data types are DOT_FILE, DOT_FOLDER, and CURRENT_FOLDER.

♦ To Specify Which Data Types Are Hidden

1. Choose Set Filter Options from the View menu.

Data types that have already been chosen to be hidden are highlighted.

2. In the Select File Types to be Hidden box, select the data types you want to be hidden. File types that are already being hidden are highlighted. Or, to reset the default filter list (DOT_FILE, DOT_FOLDER, and CURRENT_FOLDER), click Defaults.

3. Optional. Type a name pattern into the Also Hide (Optional) field specifying additional file and folder names to be hidden.

The filter list specifies which files are not to be displayed. If you select all object types or type * into the Filter String field no files are displayed. If you type *.txt, then any file whose name ends in .txt will be added to the filter list and not displayed.
Advanced users: The Filter String may be any regular expression. Refer to the `regexp(5)` man page for more information.

4. Click OK.

If you want to view the results before closing the dialog box, click Apply. To reset to the default filter list, choose Defaults. This resets the default values but does not apply them until you click Apply or OK.

**Icon Browsing**

Files with names that end in `.pm` or `.bm` contain icons. These are the files that File Manager uses to build icons. By default, you must open these files to see the icons they contain. If you enable icon browsing, File Manager displays the contents of `.pm` or `.bm` files so you don’t have to open them to see what they look like.

![Fphone.1.pm](image1.png)  ![Fphone.1.pm](image2.png)

Figure 5-4 Icon with icon browsing enabled (left) and disabled (right)

♦ **To Enable Icon Browsing**


2. Open Application Manager and double-click Reload Actions in the Desktop_Tools application group.

3. Restart File Manager.
Note - The maximum default display area for icons is 38x38 pixels. So, if a picture file is larger than 38x38, the picture will be clipped and only the top left 38x38 pixels will be shown. You can increase the size of the display area for icons if you want larger images to be fully visible (see "To Change the Icon Display Area Size"). However, a larger display size area will slow down the opening of folders, and icons will be spread further apart in folder views.

♦ To Disable Icon Browsing

1. Remove your personal copy of the IconBrowse.dt file.

2. Open Application Manager and double-click Reload Actions in the Desktop_Tools application group.

♦ To Change the Icon Display Area Size

1. Open a Terminal window and type dtpad ~/.Xdefaults.

2. When the file is displayed, it may be empty or there may be text already in the file. In either case, add the following four lines of text to the file:

Dtfile*smallIconWidth:24
Dtfile*smallIconHeight:24
Dtfile*largeIconWidth:38
Dtfile*largeIconHeight:38

When you type in these lines, replace the default numbers at the end of each line with the new display area size you want.

3. Choose Save from the File menu.

4. Choose Close from the File menu.

Note - The change will not take effect until you exit the desktop and log back in. If you should want to return to the default display area size, type the default sizes back in or just remove the four lines you added, and then exit and restart the desktop.
This chapter covers several ways to run applications from the desktop.

| Running Applications Using Application Manager | 121 |
| Running Applications Using File Manager        | 132 |
| Running and Organizing Applications Using the Front Panel | 133 |
| Running Applications from a Terminal Emulator Window | 135 |

**Running Applications Using Application Manager**

Application Manager is a container for the applications and other tools available on your system. Most of the applications and tools in Application Manager were placed there by your system administrator or are built into the desktop.

Although configuring Application Manager is primarily a system administration task, you can also make personal customizations to Application Manager.
To Open Application Manager

- Click the Application Manager control in the Front Panel.

![Application Manager control](image1)

**Figure 6-1 Application Manager control**

**Application Manager Window**

The Application Manager window is a special File Manager view of a special folder on your system. It looks very much like a File Manager window, except that the iconic and text path are not shown.

![Application Manager window](image2)

**Figure 6-2 Top-level folder of Application Manager**

The top level of Application Manager is special because other folders and files are never created directly in it. Instead, folders in other locations are gathered into this location automatically when you log in.
Contents of Application Manager

The top level of Application Manager contains a set of application groups.

Each application group is a folder containing one or more icons that you use to start applications.

An icon that starts an application is called an action icon or application icon.
Some application groups contain other useful application files such as sample data files, templates, and “read me” files.

The application groups in your Application Manager are either built-in or registered by your system administrator. Application registration is a process by which an application lets the desktop know of its presence.

The application groups in Application Manager are gathered together each time you log in. The application groups may be located on your system or on other systems throughout the network.

**Built-In Application Groups**

The desktop provides these built-in application groups that are containers for various tools and utilities available on your system:

<table>
<thead>
<tr>
<th>Application Group</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Desktop_Apps</td>
<td>Desktop applications such as File Manager, Style Manager, and Calculator</td>
</tr>
<tr>
<td>Desktop_Tools</td>
<td>Desktop administration and operating system tools such as Reload Application, vi text editor, and Check Spelling</td>
</tr>
<tr>
<td>Information</td>
<td>Icons representing frequently used help topics</td>
</tr>
<tr>
<td>System_Admin</td>
<td>Tools used by system administrators</td>
</tr>
</tbody>
</table>

**Application Manager Menus and Commands**

Since Application Manager is closely related to the File Manager window, it uses most of the same menus, commands, and other features.

For more information about using the Application Manager menus and dialog boxes, see Chapter 5, “Managing Files with File Manager.”

**To Run an Application from Application Manager**

1. Open Application Manager.
2. Double-click the application group’s icon to display its contents.
3. Double-click the application’s action icon.

Figure 6-5 Opening an application window from Application Manager
♦ To Get Help on an Application Icon

Using the Icon’s Pop-up Menu
1. Point to the icon and press mouse button 3 to display its pop-up menu.
2. Choose Help from the pop-up menu.

Using the Help Menu
1. Choose On Item from the Help menu.
2. Click the icon on which you want help.

♦ To Put an Application Icon in the Front Panel
1. Display the application's icon in Application Manager.
2. Display the subpanel to which you want to add the application.
3. Drag the action icon from Application Manager to the Install Icon control in the subpanel.

Figure 6-6 Installing an application (action icon) in the Front Panel
To Put an Application Icon on the Workspace Backdrop

This procedure copies an application icon from Application Manager to the workspace (backdrop). This makes the icon available when you don't have an Application Manager window open.

1. Open the application group containing the application you want to add.
2. Drag the application from Application Manager to the workspace backdrop.

To Update Application Manager

The contents of your Application Manager are built each time you log in. Each time it is built, it searches certain system and network locations for applications.

If your system administrator adds an application to your system or to an application server while you are in a session, you must update your Application Manager if you want the new application to be registered immediately.

There are two ways to update Application Manager:

- Open the Desktop_Tools application group and double-click Reload Applications.
- Or, log out and back in.

To Create a Personal Application Group

A personal application group is an application group that you can alter, since you have write permission to it.

1. From your home folder, change to the .dt/appmanager subfolder.
2. Create a new folder.
   The folder name will become the name of the new application group.
3. Double-click Reload Applications in the Desktop_Apps application group.
   Your new application group will become registered at the top level of Application Manager.
♦ **To Add Applications to a Personal Application Group**

- Copy icons from other application groups to the personal application group.

  For example, you can copy (by pressing Control and dragging) the Calculator icon from the Desktop_Tools application group to your new personal application group.

- Create an action for an application and then place an application (action) icon in the personal application group. See “Creating Personal Actions and Data Types” on page 130.

**Advanced Application Manager Concepts**

This section describes several advanced Application Manager concepts:

- The relationship between file names and icon labels
- The folder location of Application Manager
- Creating personal actions and data types
- Where to obtain additional information about customizing Application Manager

**File Names in Application Manager**

In File Manager and Application Manager, files and folders are represented as icons, and these icons are usually labeled with the file name. Action icons are sometimes an exception to this rule.

For example, display the pop-up menu for the action icon in the Desktop_Clocks application group labeled Digital Clock. Notice that the file name, which is shown at the top of the pop-up menu, is not the same as the label.
In most cases, you do not need to know the action file name. However, there are other situations, in addition to the pop-up menu, where you may see the file name.

For example, if you use the Copy File dialog box to copy the icon (by selecting the file and choosing Copy to from the Selected menu), the dialog box will display the file name.

**Folder Location of Application Manager**

Application Manager behaves very much like File Manager. This is because Application Manager is a File Manager view of a special folder on your system used to gather registered applications. Ordinarily, you do not need to know the location of this special folder. However, its location may be useful to you if you are trying to troubleshoot problems.

Login Manager creates the Application Manager folder each time you log in. Its location is:

```
/var/dt/appconfig/appmanager/special_folder_name
```

where `special_folder_name` is a name assigned by the system that is unique for your system and login name.

**Caution** - You should never attempt to directly modify the `special_folder_name` folder from a command line.
Creating Personal Actions and Data Types

The desktop provides a tool that helps you create icons for running scripts, applications, and other commands. You may want to use this tool if you have a personal application your system administrator has not configured for you.

For example, suppose you have your own favorite spreadsheet application that you usually start by typing a command into a terminal emulator window:

```
FavoriteSpreadSheet -file data_file
```

You can create an icon that runs this command so that you won’t have to continue manually typing it. To do this, you must create a special desktop “macro” called an action. You can also create a data type for the data files if you like.

The desktop includes a tool called Create Action that makes it easy to create actions and data types. To open the Create Action window, double-click the Create Action icon in the Desktop_Tools application group.
Figure 6-7 Create Action window

To see online instructions for using the window:

1. Choose Tasks from the Create Action window's Help menu.
2. Click the hyperlink “To Create an Action With Create Action.”

Create Action:
- Creates an action for your application
- Places an action icon in your home folder.

You can move or copy that icon to other locations—for example, to a personal application group that you've created.
Registering Applications

When an application is registered in Application Manager, it has its own application group. This application group is available to all users on the system.

Registering applications is an advanced task, since it requires you to be the root user. For instructions, see CDE Advanced User’s and System Administrator’s Guide.

Running Applications Using File Manager

If an application uses data files, it may be configured so that the application can be started from File Manager using any of its data files.

♦ To Run an Application from File Manager

• Double-click an application’s data file.
  
  For example, double-clicking a bitmap file (a file whose name ends with .bm) runs Icon Editor.

• Or, select an application’s data file and choose Open from the icon’s pop-up menu or from the Selected menu.
Running and Organizing Applications Using the Front Panel

The Personal Applications subpanel is a container for applications you use frequently.

Initially, it contains:

- **Install Icon**: Drop zone for adding applications to the subpanel.
- **Text Editor**: Duplicates the control in the Main Panel. Opens the desktop Text Editor.
- **Terminal**: Starts the desktop terminal emulator for entering commands manually.
- **Icon Editor**: Starts the desktop Icon Editor for creating and editing bitmaps and pixmaps.

♦ **To Put an Application in the Personal Applications Subpanel**

1. Open the application group containing the application you want to add.
2. Display the subpanel to which you want to add the application.
3. Drag the application from Application Manager to the Install Icon control in the Personal Applications subpanel.

♦ To Run an Application from the Personal Applications Subpanel

◊ To run the application, click its control.

If the application icon that was installed in the subpanel is a drop zone, the control is a drop zone too. You can run an application by dragging a data file from File Manager to its control.

♦ To Replace the Main Panel Personal Applications Control

Initially, the Main Panel contains the Text Editor control. You can replace the Text Editor control with the control of your choice.

1. Add the application you want in the Main Panel to the Personal Applications subpanel.

   See “To Put an Application in the Personal Applications Subpanel” on page 133.

2. In the Personal Applications subpanel, point to the control you want in the Main Panel and choose Copy to Main Panel from the control’s pop-up menu.
Running Applications from a Terminal Emulator Window

A terminal emulator is an application whose window provides a command line. The command line lets you type commands into your system—for example, operating system commands, script names, or commands that run applications.

All applications have a command that users can type to start them. The application's documentation usually describes how to use the command.

The desktop provides a terminal emulator called `dtterm`. Your system may include other terminal emulators.

To open a terminal emulator window, click the Terminal control in the Personal Applications subpanel.

For more information on using `dtterm`, see Chapter 12, “Using Terminal.”

To Start an Application on Your System Using a Terminal Emulator

1. Type the command that starts the application into the terminal emulator window.

   If the application has its own window, you should add an ampersand character (&) to the end of the command. This runs the application “in the background,” which lets you continue using the terminal emulator window while the application is running.

   For example, the following command runs the load meter program `xload` in the background:

   ```
   /usr/bin/X11/xload &
   ```
To Start an Application on Another System Using a Terminal Emulator

There are two ways to use a command line to start an application on another system:

- Using `rlogin`
- Using `remsh`

**Using rlogin**
When you use `rlogin`, you use your terminal emulator to log in to a different (remote) system. You then run the command to start the application on that system.

1. Use the `rlogin` command to log in to the system containing the application.

   ```bash
   rlogin remote_system_name
   ```

   For example:

   ```bash
   rlogin systemA
   ```

2. Type the command to start the application. Use the `-display` option to send the window back to your display.

   For example, assuming your own system’s display name is `MySystem:0`:

   ```bash
   /usr/bin/X11/xload -label systemA -display MySystem:0
   ```

**Using remsh**
The term `remsh` stands for “remote shell.” It provides a one-step way to run an application, since you do not have to log in before running the command.

Type the command:

```bash
remsh remote_system_name -n command
```

The command must include the `-display` option to send the window back to your display.

For example:

```bash
remsh systemA -n /usr/bin/X11/xload -display MySystem:0
```
Customizing the Desktop Environment

Style Manager can be used to customize the appearance of the desktop.

<table>
<thead>
<tr>
<th>Customizing Screen Appearance</th>
<th>138</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customizing System Behavior</td>
<td>144</td>
</tr>
<tr>
<td>Customizing Startup and Logout</td>
<td>150</td>
</tr>
</tbody>
</table>

♦ To Start Style Manager

◊ Click the Style Manager control in the Front Panel.

Figure 7-1  Style Manager Front Panel control
The Style Manager controls and the items that they control are:

- **Color**: Workspace colors and palettes
- **Font**: Application font sizes
- **Backdrop**: Workspace backdrop patterns
- **Keyboard**: Key click volume and character repeat capability
- **Mouse**: Mouse button click settings, double-click speed, pointer acceleration, and pointer movement threshold
- **Audio**: Beeper volume, tone, and duration
- **Screen**: Number of minutes before your screen blanks and whether your screen is covered and locked at that time
- **Window**: How a window acquires focus, if the window raises when it receives focus, and where window icons are placed
- **Startup**: How your session begins and ends

![Figure 7-2 Style Manager controls](image)

### Customizing Screen Appearance

You can change the following aspects of your screen appearance:

- Workspace colors
- Workspace backdrops
- Font sizes
Colors

You set your workspace colors through a color palette. The number of color buttons in the palette is determined by your display type and the Number of Colors selection.

The default is More Colors for Applications, which keeps the number of colors used on a high-color display to a minimum. To increase the number of color buttons on a high-color display, select More Colors for Desktop in the Number of Colors dialog box and restart the current session.

While you can't use more colors than your display allows, you can reduce the number of colors used by the desktop by choosing a lower-valued color usage.

For example, if you have a high-color display and have selected More Colors for Desktop but you want to run a color-rich application such as a computer-aided design (CAD) program, you should choose More Colors for Applications or Most Colors for Applications to decrease the number of colors that the desktop uses. The remaining colors are available for the CAD program.

Color Buttons

Your display type and the Number of Colors selection determine the number of color buttons that make up a palette. You will have two, four, or eight color buttons in the Color dialog box. The different color buttons in the palette control the colors used for different areas of the screen.

If you have eight color buttons, they will be used as follows (buttons numbered from left to right, top to bottom):

1. Active window borders
2. Inactive window borders
3. Switch for workspace 1 and every fourth additional workspace (workspace 5, 9, ...)
4. Text and list areas
5. Main window background and switch for workspace 4 and every fourth additional workspace (workspace 8, 12, ...)
6. Dialog box background and menu bar and switch for workspace 3 and every fourth additional workspace (workspace 7, 11, ...)

7. Switch for workspace 2 and every fourth additional workspace (workspace 6, 10, ...)

8. Front Panel background

If you have four color buttons, they will be used as follows (buttons numbered from left to right):

1. Active window borders
2. Window bodies:
   a. Inactive window borders
   b. Main window and dialog box backgrounds and menu bar
   c. Front Panel background
3. Workspace switches and backgrounds
4. Text and list areas

If you have two color buttons, they will be used as follows (buttons numbered from left to right):

1. Active window borders
2. Everything else
To Select a Palette

1. Click the Style Manager Color control.
2. Select a palette from the Palettes list.
3. Click OK.

Workspace colors come from predefined color palettes. The Color dialog box lists the palettes that came with your system plus any palettes you have added.

To Modify an Existing Palette

1. Click the Style Manager Color control.
2. Select a palette in the Color dialog box.
3. Double-click a color button to open the Modify Color dialog box, or click a color button and then click Modify.
4. Adjust the settings for the level of red, green, blue, brightness, or hue by adjusting the corresponding slider.
   The old and new color samples will be displayed in the upper left corner of the Modify Color dialog box.
5. Click OK in the Modify Color dialog box.
6. Repeat steps 2-4 to modify another color button.
7. Click OK in the Color dialog box.
♦ **To Grab a Color from the Workspace**

1. Click the Style Manager Color control.
2. Select a palette in the Color dialog box.
3. Double-click a color button to open the Modify Color dialog box, or click a color button and then click Modify.
4. Click Grab Color to display the grab pointer.
5. Move the pointer to an area of color on the screen that you want to grab.
6. Click to make that color the new color.

**Note** – This causes the desktop to use one more color that applications cannot have.

♦ **To Create a Custom Palette**

You can create your own palette by copying and modifying an existing palette.

1. Click the Style Manager Color control.
2. Choose Add in the Color dialog box.
3. Type the new palette name and click OK in the Add Palette dialog box.
4. Modify the palette.
5. Click OK in the Color dialog box.

Adding a palette makes a copy of the currently selected palette with a unique name. You then create your custom palette by modifying the copy, so the original palette is not changed.
♦ **To Delete a Palette**

1. Click the Style Manager Color control.
2. Select the palette from the Palettes list.
3. Click Delete.
4. Click OK in the Delete Palette dialog box.

When you delete a palette, Style Manager prefixes the name of the palette with a ~ and stores a copy in the `HomeDirectory/.dt/palettes` directory.

♦ **To Restore a Deleted Palette**

1. Open a File Manager view showing `HomeDirectory/.dt/palettes`.
2. For system-supplied palettes, delete the file `~palette_name.dp`
   For user-added palettes, rename the deleted palette from `~palette_name.dp` to `palette_name.dp`.
3. Restart Style Manager (close, then reopen).

♦ **To Change the Number of Colors Used by the Desktop**

1. Click the Style Manager Color control.
2. Click Number of Colors in the Color dialog box.
3. Select an option to set the number of colors used by the desktop.
   See “Colors” on page 139.
4. Click OK.

You must log out and back in before the change takes effect.

---

**Fonts**

The font size you select in Style Manager is used on window labels and text. The new font size is used as applications are started. Existing windows will not reflect the change.
To Select a Font Size
1. Click the Style Manager Font control.
2. Select a font size.
3. Click OK.

Backdrops
You can select a backdrop pattern to cover each of your workspaces (the screen area underneath your windows). A unique backdrop for each workspace adds variety and helps you to quickly identify the workspace you are in.

To Select a Backdrop
1. Switch to the workspace where you want the backdrop.
2. Click the Style Manager Backdrop control.
3. Select a backdrop.
4. Click Apply.

Customizing System Behavior
You can adjust the following settings for system devices:
• Keyboard click volume and character repeat
• Mouse button click settings, double-click speed, pointer acceleration, and pointer movement threshold
• Beeper volume, tone, and duration
• Screen blanking when not in use
• Window focus, movement, and icon behavior
♦ To Change Keyboard Behavior

1. Click the Style Manager Keyboard control.
2. Select the settings you want:
   • Auto Repeat: Sets characters to repeat when you hold down their keys
   • Click Volume: Determines the volume of key clicks (turned off at 0%)
3. To save the changes, click OK. To return to the default settings, click Default.

♦ To Change Mouse Behavior

1. Click the Style Manager Mouse control.
2. Select the settings you want:
   • Handedness: Reverses mouse buttons 1 and 3.
   • Button 2: Determines whether the middle mouse button is used to extend selections (Adjust) or drag and drop objects (Transfer). If Adjust is selected, transfer actions (drag) will require the use of mouse button 1.
   • Double-Click: Determines the maximum time between clicks of a double-click. (Test the speed by double-clicking in the mouse picture provided.) A new double-click speed does not take effect until the next time you log in.
   • Acceleration: Sets how fast the mouse pointer moves across the display.
   • Threshold: The distance in pixels the pointer moves at a slow speed before moving at the accelerated rate.
3. To save the changes, click OK. To return to the default settings, click Default.

♦ To Change Beep Settings

1. Click the Style Manager Beep control.
2. Select the settings you want:
   • Volume: Determines the volume of the beep (turned off at 0%)
   • Tone: Determines the pitch of the beep from 82 to 9000 Hertz
   • Duration: Determines the length of the beep
3. To save the changes, click OK. To return to the default settings, click Default.

**Screen without Lock Extensions**

You can customize the screen blanker or Front Panel lock, or return the settings to the default. If your system supports lock on timeout, see “Screen with Lock Extensions” on page 147.

If you have a color display, bright colors on the screen can burn into the picture tube. Setting the screen to go blank or be covered prevents this from happening.

♦ **To Change Screen Blanker Settings**

1. Click the Style Manager Screen control.

2. Select the settings you want:
   - **Screen Blanker**: Enables (On) or disables (Off) the screen blanker immediately, even before you click OK. When Screen Blanker is On the Start Blanker slider is active.
   - **Start Blanker**: Specifies the number of minutes from the last pointer movement or keystroke before the screen is blanked. When this value is changed, the new value goes into effect immediately, even before you click OK.

3. To save the changes, click OK. To return to the default settings, click Default.
To Change Front Panel Lock Settings

1. Click the Style Manager Screen control.

2. Select the settings you want:
   - Use Backgrounds For Lock: Enables the lock backgrounds.
   - Transparent Lock: Backgrounds are not used when the screen is locked.
   - Backgrounds List: Displays the available backgrounds in a multiple-select list. Select or deselect a background by clicking on the list item. The last background selected will be displayed to the right of the list.
   - Time Per Background: Specifies the number of minutes each selected background runs before the next one starts when the screen is being saved. The backgrounds are cycled through in the same sequence as they appear in the list. A setting of 0 (zero) results in only the last background (the one currently in the preview area) being used.

3. To save the changes, click OK. To return to the default settings, click Default.

Screen with Lock Extensions

You can customize the screen saver or screen lock, or return the settings to the default. If your system does not support lock on timeout, see “Screen without Lock Extensions” on page 146.

If you have a color display, bright colors on the screen can burn into the picture tube. Setting the screen to go blank or be covered prevents this from happening.
To Change Screen Saver Settings

1. Click the Style Manager Screen control.

2. Select the settings you want:
   - Screen Saver: Enables (On) or disables (Off) the screen saver immediately, even before you click OK. When Screen Saver is On the Start Saver slider is active.
   - Screen Saver List: Displays the available screen savers in a multiple-select list. Select or deselect a screen saver by clicking on the list item. The last screen saver selected will be displayed to the right of the list.
   - Start Saver: Sets the number of minutes from the last pointer movement or keystroke before the screen saver starts. When this value is changed, the new value goes into effect immediately, even before you click OK.
   - Time per Saver: Specifies the number of minutes each selected screen saver runs before the next one starts.

3. To save the changes, click OK. To return to the default settings, click Default.

To Change Screen Lock Settings

1. Click the Style Manager Screen control.

2. Select the settings you want:
   - Screen Lock: Enables (On) or disables (Off) Screen Lock on a timeout. When this setting is changed, the new setting goes into effect immediately, even before the dialog box is closed.

If screen saver and screen lock are both enabled (On) and the Start Lock value is smaller than the Start Saver value, when the screen lock times out it replaces the contents of the screen with the currently selected screen savers. If Start Lock is greater than Start Screen, then the automatic screen lock simply continues the current screen saver.

If the screen saver is disabled (Off) and automatic screen lock is enabled (On), when the screen lock times out the screen contents of the screen are not covered with a screen saver.
• Start Lock: Specifies the number of minutes from the last pointer move or keystroke before the screen lock starts. When this value is changed, the new value goes into effect immediately, even before you click OK.

3. To save the changes, click OK. To return to the default settings, click Default.

Windows

You can change the window focus policy, how active windows are displayed, and where window icons are displayed.

♦ To Change Window Behavior

1. Click the Style Manager Window control.
2. Select the settings you want:
   • Point In Window To Make Active: Makes a window active when the mouse pointer enters it
   • Click In Window To Make Active: Makes a window active when the mouse pointer enters it and you click mouse button 1
3. To save your changes, click OK.
4. Click OK when asked to Restart the Workspace Manager.

♦ To Change How Active Windows Are Displayed

1. Click the Style Manager Window control.
2. Select the settings you want:
   • Raise Window When Made Active: Select this if you want a partially concealed window to be brought to the top when it becomes active
   • Allow Primary Windows On Top: Select this if you want the main window to be allowed to be displayed on top of secondary windows when you click the primary window
   • Show Contents During Move: Select this if you want move the whole window during a window move instead of just moving the outline at first
3. To save your changes, click OK.
4. Click OK when asked to Restart the Workspace Manager.

♦ To Change Where Window Icons Are Displayed

1. Click the Style Manager Window control.
2. Select the settings you want:
   • Use Icon Box: Displays your window icons in an icon box
   • Place On Workspace: Displays your window icons on the workspace backdrop
3. To save your changes, click OK.
4. Click OK when asked to Restart the Workspace Manager.

Customizing Startup and Logout

You can change the following options for startup and logout:

• Session started when you log in
• Session to be your home session
• Logout confirmation preference

Whenever you are logged into the desktop, you are working in a current session. By default, when you log out, the desktop saves your current session and restores it the next time you log in.

You can also save a home session, a session you want to be able to return to regardless of what you do during the current session.

♦ To Change How Your Next Session Starts

1. Click the Style Manager Startup control.
2. Select the settings you want:
   • Resume current session: Starts your next session the way you left your last one including any setting, client, or resource modifications
   • Return to Home session: Starts the session you set as your home session
   • Ask me at Logout: Select this if you want to be asked at logout whether to restart the current session or restore the home session
To define a new home session based on your current session, select Set Home Session.

3. To save your changes, click OK.

♦ **To Set a Home Session**

When setting a home session, be sure to first select and save your desired startup settings.

1. Click the Style Manager Startup control.
2. Click Set Home Session.
3. Click OK in the confirmation dialog box that appears.
4. Click OK in the Startup dialog box.

If you have never set a home session, the system default session is used when you select Return to Home session.

♦ **To Set Your Logout Confirmation Preference**

1. Click the Style Manager Startup control.
2. Select On or Off for Logout Confirmation.
   
   If you set Logout Confirmation to On, you will be asked for confirmation that you want to log out whenever you log out.

3. Click OK.
Mailer is a desktop application that enables you to send, receive, and manage your electronic mail (email) messages.

| Viewing and Acting On Your Mail Messages | 155 |
| Sending Mail Messages                  | 159 |
| Printing Mail Messages                 | 171 |
| Working with Attachments               | 172 |
| Customizing Mailer                     | 175 |
| Mailer Keyboard and Menu Shortcuts     | 180 |

The instructions in this chapter assume you are familiar with basic desktop skills and keyboard navigation. For more information, see Chapter 1, “Basic Skills” and Appendix A, “Keyboard Shortcuts for the Desktop.” Many of the tasks you do in Mailer can be done using drag and drop.
To Start Mailer

Click the Mailer control in the Front Panel.

Figure 8-1 Mailer icons showing new and read mail

Mailer Main Window

The Mailer main window is shown in Figure 8-2 and described below.

Figure 8-2 Mailer main window example

Message Header List Displays information about mail messages
Sash Used to resize the Message Header List and message view area
Message view area Contains header fields and text of message
Attachment list Displays icons of mail message attachments, if any
Viewing and Acting On Your Mail Messages

Once you've started Mailer and begun to collect email messages, you'll want to read, sort, find, delete, and (possibly) undelete them.

After using Mailer you may need to file certain mail messages away for safekeeping. You have a default mailbox (Inbox) where all your messages are received. Since keeping all your mail messages in your Inbox is not practical, you may want to set up other mailboxes to store groups of messages together.

See “To Create a Mailbox” on page 168 for information on how mailboxes can be created or “To File a Message in Other Mailboxes” on page 169.

♦ To Read a Mail Message

1. Choose Check for New Mail from the Mailbox menu to retrieve any messages waiting for delivery to your mailbox.

2. Click to select the message to be viewed from the Message Header List. The text of the message appears in the message view.

Use the Pointer, the Next and Previous buttons, or the View menu to continue to select and read messages in the message view.

To open a message into a single window:

◊ Double-click the message or choose Open from the Message menu. From this window, the Edit and Attachments menus become available.

The message remains in the separate window even when you select another message in your Inbox.
Sorting Mail Messages

The View menu provides several ways to order your messages:

- **Date/Time** sorts messages with the most recent at the bottom.
- **Sender** groups messages by a particular sender.
- **Subject** groups message titles together by the same subject.
- **Size** groups messages from smallest to largest.
- **Status** groups messages together by read and new (useful if you read your mail in non-sequential order).

The message headers are rearranged and redisplayed in the mailbox in the new order.

♦ To Reply to a Message

1. Select the message for reply.
2. Decide on the type of reply:
   - **To reply to the sender**, click Reply to Sender or choose Reply to Sender from the Compose menu.
     A Compose window appears with the email address of the recipient and the message subject filled in.
   - **To reply to the sender and all recipients**, choose Reply to All from the Compose menu.
     A Compose window appears with the email address of the recipients and the subject of the message filled in.
   - **To reply to the sender or all recipients and include a copy of the message**, choose Reply to Sender, Include or Reply to All, Include from the Compose menu.
     A Compose window appears that includes the text of the message with the email address of the recipients and the subject filled in.
3. Type your reply and send your message as usual. For more information, see “To Address, Compose, and Send a Mail Message” on page 160.
♦ To Forward a Message

1. Select or open the message you want to forward.
2. Choose Forward Message from the Compose menu.
   You see the text of the message to be forwarded is displayed within a new message, as well as its attachments, if any. For more information see “To View an Attachment” on page 172.
3. Optional. Remove any attachments you do not want to forward by selecting them and choosing Delete from the Attachments menu.
4. Type the addresses of the message recipients in the To or Cc fields.
5. Add any additional text and click Send.
   See “To Address, Compose, and Send a Mail Message” on page 160 for more information.

♦ To Save a Message as Text

1. Choose Save As Text from the Message menu.
2. Type a file name and location for your message.
3. Click Save.

♦ To Find a Mail Message within a Mailbox

1. Choose Find from the Message menu.
   The Find dialog box appears.
2. Type the text you want to search for in the appropriate field.
   You can search for a match on one or more of the To, From, Subject, or Cc fields.

3. Select Forward or Backward to set the search direction within the mailbox.

4. Click Find to select the first message found.
   If you think there may be several messages, click Select All to mark (by selection) each message header.

   **Note** - You can remove all the text in the fields at any time by clicking Clear.

♦ **To Delete a Mail Message**

1. Select a message for deletion.
   Shift+Click enables you to select several messages in a row by moving the highlight up or down the message header list. Control+Click enables you to select discontiguous messages one at a time from the list.

2. Choose Delete from the Message menu, or click the Delete button.
   The message and attachments (if any) are deleted from the list.

   See “To Delete both an Attachment and the Mail Message” on page 174 for more information on attachments in a mail message.

   **Note** - Even if a message has been deleted, you can get it back unless you made your deletions permanent by choosing Destroy Deleted Messages from the Mailbox menu.
♦ To Undelete a Mail Message

- To restore a message you just deleted, choose Undelete Last from the Message menu.
- To restore an earlier message, choose Undelete from List from the Message menu, select one or more messages from the list of deleted messages, and click the Undelete button.

Note - To make the deletions in the list permanent, choose Destroy Deleted Messages from the Mailbox menu.

♦ To Destroy Deleted Messages When Closing the Mailbox

You can set your options so that when you close your mailbox, the messages you deleted will be permanently destroyed. This means that you cannot get a message back that you deleted once you close your mailbox.

1. Choose Message Header List from the Category menu of the Mail Options dialog box.
   The Message Header List dialog box appears.
2. Select “When I close the mailbox” under Destroy Deleted Messages.
3. Click OK or Apply to make your changes take effect.

Note - You can remove the confirmation notice that appears each time you close the mailbox and asks if you want to destroy deleted messages by deselecting “Show confirmation notice.”

Sending Mail Messages

An email address is like your personal ZIP code for receiving mail messages. This is also the way you send messages to other email users. The format used for email addresses is username@location. Your system administrator uses this format to set up user (email) addresses.

This section gives you most of the information you need to address, compose, and send a message to another user.
Using Aliases

An alias is just a private name for one or more user names (or user addresses). By creating a distribution list of user addresses to which you frequently send mail and giving it an alias, you can just type the name of the alias instead of typing each address in the To field every time you send messages. The name you give to your alias can be descriptive of a group of users or just a name you will remember. This alias only works for your user name from your machine.

♦ To Create an Alias

1. Choose Aliases from the Category menu of the Mail Options dialog box.

2. Type the name for your alias in the Alias field.

3. Type the user addresses that will make up the alias in the Addresses field. Each of these should be in the form username@location and be separated by a comma, space, or both.

4. Click Add to add the information in the Alias and Addresses fields to the Aliases list.

   You can also change or remove an alias in the same manner using either the Change or Delete button.

5. Click OK or Apply to make the settings take effect.

♦ To Address, Compose, and Send a Mail Message

Once you have a user’s email address, you can send a message.

Note - If this is the first time you are using email and if you know your own email address, you can use these procedures to send a test message to yourself.

1. If Mailer is not already started, click the Mailer control in the Front Panel.

   The mailbox appears.
2. Choose New Message from the Compose menu. The (New Message) Compose window appears.

3. Type the email address of the recipient in the To field and press Return. You can send a message to a single user, multiple users, or an alias. For information on aliases, see “Using Aliases” on page 160.

4. Optional. Type the topic or title of the message in the Subject field and press Return.

5. Optional. Type the email addresses of users you want to be carbon copy recipients of this message in the Cc field.

Figure 8-4 Compose window
6. Once your message is addressed, press Return to go to the text area and compose the message.

To find out about editing text in your message, see “Editing Text in a Mail Message” on page 162 or “Formatting Text in a Mail Message” on page 163. Choose Include from the File menu to insert a text file into your message.

You can save the message you are composing at any time by choosing Save As Text from the Compose File menu.

7. Optional. Add files to the message, if necessary.

To find out how to add an attachment, see “To Add an Attachment” on page 173.

**Note** – Choose Log Message from the Compose File menu to save a copy of the message to a mailbox.

8. Click the Send button or choose Send from the Compose File menu.

The Compose window closes and the message is sent.

**Note** – Clicking Close removes the Compose window and discards your message. Be sure to save any text you might want later before closing the Compose window.

---

**Editing Text in a Mail Message**

The Compose Edit menu provides ways to change the message text you are composing:

- **Undo** — Reverses the last editing action in the text area.
- **Cut** — Removes the selected text and stores it on the clipboard. Only one selection can be stored on the clipboard at a time. If text is already there, the most current selection overwrites it.
- **Copy** — Stores a copy of the selected text on the clipboard. Only one selection can be stored at a time. If text is already there, the most current selection overwrites it.
Paste
Inserts the contents of the clipboard at the insertion point.

Paste Special
Inserts the contents of the clipboard at the insertion point surrounded above and below by Begin and End Included Message text, or indented markers.

Clear
Removes the selection and leaves the resulting white space.

Delete
Removes the selection and the resulting white space.

Select All
Selects all the text in the text area.

Find/Change
Opens a dialog box that enables you to search for words or phrases in your message and make changes to occurrences that are found.

Check Spelling
Runs the spell checker on your mail message and display a dialog box that lists words that might be spelled incorrectly. You can Find, Change, or Change All instances of a word.

For more information on editing functions, see Chapter 10, “Using Text Editor.”

**Formatting Text in a Mail Message**

The Compose Format menu enables you to make formatting changes to the message you are composing:

Word Wrap
Toggle the text entry mode that causes lines to automatically wrap at the edge of the message. This may cause problems if the sender has word wrap turned on and the recipient window is a different size.

Settings
Display a dialog box for setting margins and paragraph alignment, and applying format settings to your message.

Templates
Enables you to quickly access the templates (text files) you created for using in your mail messages. For more information, see “To Create Templates for Mail Messages” on page 177.

*Using Mailer*
Add Bcc: Adds the Bcc (Blind Carbon Copy) header to your Compose window. Bcc enables you to send a copy of a message to someone without those on the To or Cc line seeing the user's address. If you added other headers beside Bcc, they show up here.

For more information on editing functions, see Chapter 10, “Using Text Editor.”
♦ To Include a Template in a Mail Message

1. Choose New Message from the Compose menu.
2. Choose Templates from the Format menu and select the desired template from the list.
   Your template is added to your mail message.

For more information on templates, see “To Create Templates for Mail Messages” on page 177.

♦ To Include Multiple Messages in a New Message

1. From the Message Header List, select the email messages to be included in your new message.
   Shift+Click enables you to select several messages in a row by moving the highlight up or down the message header list. Control+Click enables you to select discontiguous messages one at a time from the list.
2. Choose New, Include All from the Compose menu.
3. Compose and send your message as usual.

♦ To Include a Text File in a Mail Message

You can drag and drop a text file from File Manager to the Compose window of a mail message or follow these steps.
1. Choose New Message from the Compose menu.
2. Choose Include from the File menu in the Compose window.
   You see your file system.
3. Indicate the text file to be included in your email message.
4. Click OK.
   The file is included in the text area of your message.
5. Compose and send your message as usual.
To Send an Automatic Message (Vacation Mail)

1. Choose Mail Options from the Mailbox menu.
   The Mail Options dialog box appears.
2. Choose Vacation from the Category menu.
4. Type a subject and message for your vacation message.
   If you use the variable $SUBJECT in your message, the user will see his or her message title in your reply. For example: “I am on vacation. Your message regarding "$SUBJECT" will be read when I return.”
5. Click OK or Apply.
   Your vacation message takes effect the next time someone sends you a message.

Note - To turn off vacation mail, follow steps 1-3 but select Off instead.

To Send Mail Messages in MIME or Sun Format

You can send messages in two different formats: Internet MIME or Sun Mail Tool.

1. Choose Send As from the File menu.
2. Select either Internet MIME or Sun Mail Tool.
   Your message is sent in the selected format.
To Find or Change Text in Your Message

1. Choose Find/Change from the Compose Edit menu.
   The Find/Change dialog box appears.

2. Type (or copy and paste) the text you want to locate in the Find field.

3. Optional. To automatically change the located text to replacement text, type the replacement text in the Change To field.

4. Click the appropriate Find option:
   • Click Find to find and select the text.
   • Click Change to change the first instance.
   • Click Change All to change all instances.

5. Click Close to remove the dialog box.

To Check Spelling in Your Mail Message

1. Click in the Compose window at the beginning of your mail message.

2. Choose Check Spelling from the Compose Edit menu.
   The Spell dialog box appears, displaying a list of potentially misspelled words with the first word highlighted.

3. To correct a word, select it, and type the correction in the Change To field.
   To see a word in context, select it and click Find.
4. Click Change to correct a single occurrence, or Change All to correct all occurrences.

The word is corrected in the text.

♦ To Edit Text in Message View

To edit the text in an existing mail message:

1. Select the message you want to change.
2. Choose Forward Message from the Compose menu.
3. Address the message to yourself.
4. Edit the message in the Compose window and send it.

Note - You may want to create a separate mailbox for these edited messages as they can add to the size of your Inbox.

Creating and Using Mailboxes

Once you create a few mailboxes, you can use them to help you organize your mail. You can create mailboxes by project, users, email lists, or any other system that works for you.

♦ To Create a Mailbox

1. Choose New from the Mailbox menu.
2. Type the mailbox name and location in your file system.
   Refer to “Opening and Saving” on page 178 for more information.
3. Click New.
   The new mailbox is created and opened.
♦ **To Open a Mailbox**

1. Choose Open from the Mailbox menu.

2. Select the mailbox you want to open.
   
   Refer to “Opening and Saving” on page 178 for more information.

3. Click Open
   
   The mailbox is opened into a separate window.

♦ **To Close a Mailbox**

◊ Choose Close from the Mailbox menu or Window menu.

When the last open mailbox is closed, Mailer quits completely.

♦ **To File a Message in Other Mailboxes**

Once you have created a mailbox other than your Inbox, you can file messages in it. You can create mailboxes by project, users, email lists, or any other system that works for you.

There are several ways to file messages in other mailboxes:

- Choosing Other Mailboxes from the Move menu (or the Copy To submenu of the Message menu) and indicating the desired mailbox.

- Adding to your Move menu (or the Copy To submenu on the Message menu) mailboxes where you frequently file messages. For information on adding mailboxes to your Move menu, refer to “To Add Mailboxes to the Move and Copy To Menus” on page 170.

- Setting your Move menu to display the most recently visited mailboxes. For information on this option, refer to “To Add Mailboxes to the Move and Copy To Menus” on page 170.

- Dragging and dropping messages to other mailboxes. See “To Drag and Drop Messages to Other Mailboxes” on page 170 for more information.
♦ To Remove a Mailbox from Your File System

1. Open File Manager and locate the mailbox to be deleted.
2. Choose Delete to Trash from the File menu.
   The mailbox is deleted.


♦ To Drag and Drop Messages to Other Mailboxes

1. Make sure your mailbox is open on the desktop and its Message Header List is visible.
2. Open two or three frequently used mailboxes on the desktop, making sure you can see the Message Header List.
3. Select the message to be copied.
4. Drag the message and drop it onto the appropriate mailbox Message Header List.
   A copy of the message is placed in the target mailbox.

♦ To Add Mailboxes to the Move and Copy To Menus

Once you have set up a number of mailboxes, you may discover that there are several mailboxes you use frequently. You can customize your menus to show these few key mailboxes, which makes filing by mailbox menus much more efficient.

1. Choose Message Filing from the Category menu of the Mail Options dialog box.
   The Message Filing dialog box appears.
2. Type the path to the mailbox and click Add.
   The mailbox is now added to the Move menu and the Copy To submenu of the Message menu.

Use Delete or Change to alter what is in the Path/File Name field once a mailbox name is selected.
Note - You can change the path where Mailer starts looking for your mailboxes if you would like it somewhere other than the default location.

♦ To Display Recently Visited Mailboxes in the Move Menu

1. Choose Message Filing from the Category menu of the Mail Options dialog box.
   The Message Filing dialog box appears.
2. Increase or decrease the amount of mailboxes you have recently opened in the “Display up to: Recently visited mailboxes” field.
3. Click OK or Apply to make the change take effect.
   The desired number of mailboxes appear on the Move menu.

Printing Mail Messages

From your mailbox, you can use the Print button or the Message menu to print a message with the default options or you can set different print options.

♦ To Print a Message with Default Options

1. Select the message to be printed in the Message Header List.
   Shift+Click enables you to select several messages in a row by moving the highlight up or down the message header list. Control+Click enables you to select discontiguous messages one at a time from the list.
2. Click the Print button.

♦ To Print a Message with Specific Options

1. Select the message to be printed.
   Shift+Click enables you to select several messages in a row by moving the highlight up or down the message header list. Control+Click enables you to select discontiguous messages one at a time from the list.
2. Choose Print from the Message menu.

3. Set the following options you want to change:
   - Type a new printer name in the Printer field.
   - Indicate the number of copies in the Copies field.
   - Type a banner page title in the Banner Page Title field.
   - Select Print Page Numbers to print page numbers in your document.
   - Type print command options in the Print Command Options field.

4. Click Print.

♦ To Print a Message Using Drag and Drop

1. Select the message to be printed.

2. Drag the message onto the Printer control in the Front Panel.
   The Print dialog box appears.

3. Set the print options as desired and click Print.
   For more information, see “To Print a Message with Specific Options.”

Working with Attachments

An attachment is an image, document, or executable file that you send or receive with your messages.

♦ To View an Attachment

**Note** - If Open does not appear on the Attachments menu, you cannot open the attachment.

1. Select the attachment icon in the attachment list.
   Choose Show List from the Attachments menu to show the attachment list in the Compose window.
2. Choose Open from the Attachments menu, or double-click the attachment icon.

♦ **To Print an Attachment**

   If your system does not provide the ability to print attachments, the Print item will not be available.

   1. Select the attachment.
   2. Choose Print from the Attachments menu.

♦ **To Add an Attachment**

   1. Compose your email message.
   2. Choose Add File from the Attachments menu.
      
       The Mailer Add dialog box appears. See “Opening and Saving” on page 178 for more information on this dialog box.
   3. Select a file to attach and click Add.
      
       The attachment is added to the attachment list in the lower portion of the Compose window.
       
       To remove an attachment you just added, choose Delete from the Attachments menu.
       
       To restore deleted attachments, choose Undelete from the Attachments menu.
   4. Optional. Use Rename to change the name of the added attachment.
♦ **To Save an Attachment to Your File System**

1. Select the attachment you want to save.
   See “Opening and Saving” on page 178 for more information.
2. Choose Save As from the Attachments menu.
3. Indicate where you want to save the attachment.
4. Type a new name for the file.
5. Click Save.
   The file is saved to the selected location.

   **Note** - You can also drag and drop an attachment to File Manager. See Chapter 5, “Managing Files with File Manager,” for more information.

♦ **To Delete both an Attachment and the Mail Message**

You delete an attachment in the same way you delete a mail message.
1. Select the email message that contains the attachment.
2. Click the Delete button.

♦ **To Attach a File from File Manager**

1. Select the file within File Manager.
2. Optional. If the attachment list is not displayed, choose Show List from the Compose window Attachments menu.
3. Drag the file from File Manager and drop it onto the attachment list in the Compose window.
4. Send the message as usual.

   **Note** - You can also drag an attachment from the attachment list to File Manager. See Chapter 5, “Managing Files with File Manager.”
To Attach a Calendar Appointment

1. Create the calendar appointment.
2. Drag the appointment from the Calendar Appointment Editor dialog box and drop it onto the attachment list in the Compose window.
3. Send the message as usual.

Note - You can also drag a calendar appointment attachment from the attachment list to Calendar. See “To Drag an Appointment from Another Application to Calendar,” in Chapter 11, “Using Calendar.”

Customizing Mailer

Once you have been an email user for some time, you might want to change some of the Mailer defaults.

1. Choose Mail Options from the Mailbox menu.

   The Mail Options dialog box appears.

![Figure 8-7 Mail Options dialog box](image)
2. Select the Options category relating to the area you want to change.

The Mail Options categories are:
- Message Header List
- Message View
- Compose Window
- Message Filing
- Vacation
- Templates
- Aliases
- Advanced

♦ To Display Message Numbers in Your Mailbox

1. Choose Message Header List from the Category menu of the Mail Options dialog box.
   The Message Header List dialog box appears.

2. Select the Display message numbers option.

3. Click OK or Apply to make your changes take effect.
   The numbering appears on the left side of your mailbox.

♦ To Change the Character Marker for Included Text in a Reply

Having a marker for text you include when you reply to a message sets it off from text you want to add. You can customize your marker to a character of your choice.

1. Choose Compose Window from the Category menu of the Mail Options dialog box.
   The Compose Window dialog box appears.

2. Type the character you want to use.
   The default is a right angle bracket (>).

3. Click OK or Apply to make your changes take effect.
♦ To Set How Often Mailer Checks for Messages

1. Choose Message Header List from the Category menu of the Mail Options dialog box.
   The Message Header List dialog box appears.

2. Increase or decrease settings in the Check for New Mail Every field.

3. Click OK or Apply to make your changes take effect.

Creating Templates

You may want to create a template (file) that contains text you frequently use when composing messages, such as a status report format or signature and closing message. For example:

John Person
Email Address: john.person@hismachine
Phone number: (100) 555-1234    Fax number: (100) 555-5678

♦ To Create Templates for Mail Messages

1. Create your template using your text editor and save it in your file system.

2. Choose Templates from the Category menu of the Mail Options dialog box.
   The Templates dialog box appears.

3. Type the name of the template as you want it to appear in the menu in the Menu label field.

4. Type the location, path, and file name of the template.

5. Click Add to add the template name to the Templates list.
   You can click Delete or Change to remove or alter the selected template name.

6. Click OK or Apply to make the changes take effect.
   The template is now part of the Compose window Format menu.
♦ **To Add Custom Fields to Your Format Menu**

Besides the To, Subject, Cc, and Bcc fields in the Format menu, you may want to add some of your own fields such as Reply-To, Return-Receipt, and so on.

1. Choose Compose Window from the Category menu of the Mail Options dialog box.

   The Compose Window dialog box appears.

2. Type a name in the Header Field field as it will appear in the Compose window header (for example, return-receipt).

3. Type a default entry for the defined header field in the Default Value field (for example, your email address).

4. Click Add to add the values to the list.

   You can click Delete or Change to alter the items in the list.

5. Click OK or Apply to make your changes take effect.

**Opening and Saving**

When you perform certain functions (like opening a mailbox or saving a message), there is a standard method to access your file system.
Using Mailer

Figure 8-8  File Selection dialog box

- Enter path or folder name – Indicate the path to the item. This can be a location anywhere in your file system. If folders or file names are selected, the path appears here.

- Filter – Optional. An asterisk (*) shows all files. You can enter wildcard characters to display only those files that match a suffix. For example, *.doc lists only those files with a .doc suffix.

- Folders – Lists your folders beginning with your home folder.

- Files – Lists files within the selected folder.

- Show hidden folders and files – Optional. Enables you to choose whether to list certain files that are usually hidden from view, such as . (dot) files.

- Enter file name – Type the name of the mailbox or select it from the list. From this type of dialog box you are presented with a place to enter a path or folder name or a place to select from the folders and files in your file system.

Click OK to perform the specified action and dismiss the dialog box.

Click Update to display a new list of files after changing the filter key or changing to a new folder.

Click Cancel to halt the operation without applying the changes.
Click Help to display information about this dialog box.

Mailer Keyboard and Menu Shortcuts

You can use keyboard alternatives to the mouse to navigate and perform some functions in Mailer. The mnemonics and shortcuts in Table 8-1 apply to Mailer only. For more information on keyboard shortcuts, see Appendix A, “Keyboard Shortcuts for the Desktop.”

Note - Some Mailer shortcuts may interfere with UNIX key bindings. For more information on UNIX key bindings, see Chapter 10, “Using Text Editor.”

Table 8-1 Keyboard and Menu Shortcuts

<table>
<thead>
<tr>
<th>Task</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check for new mail</td>
<td>Control+M</td>
</tr>
<tr>
<td>Mail Options</td>
<td>Control+I</td>
</tr>
<tr>
<td>Close</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Send</td>
<td>F3</td>
</tr>
<tr>
<td>Message menu - Print</td>
<td>Control+P</td>
</tr>
<tr>
<td>Message menu - Delete</td>
<td>Control+D</td>
</tr>
<tr>
<td>Message menu - Undelete Last</td>
<td>Alt+M, then L</td>
</tr>
<tr>
<td>View menu - Next</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>View menu - Previous</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>Compose menu - New Message</td>
<td>Control+N</td>
</tr>
<tr>
<td>Compose menu - Reply to Sender</td>
<td>Control+R</td>
</tr>
<tr>
<td>Compose menu - Reply to All</td>
<td>Alt+P, then A</td>
</tr>
<tr>
<td>Compose menu - Reply to All, Include</td>
<td>Alt+P, then I</td>
</tr>
<tr>
<td>Compose menu - Forward</td>
<td>Alt+P, then F</td>
</tr>
<tr>
<td>Compose menu - New, Include All</td>
<td>Alt+P, then N</td>
</tr>
<tr>
<td>Compose menu - Add Attachment</td>
<td>Alt+A, then F</td>
</tr>
<tr>
<td>Compose Edit menu - Undo</td>
<td>Control+Z</td>
</tr>
</tbody>
</table>
Table 8-1 Keyboard and Menu Shortcuts (Continued)

<table>
<thead>
<tr>
<th>Task</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compose Edit menu - Cut</td>
<td>Control+X</td>
</tr>
<tr>
<td>Compose Edit menu - Copy</td>
<td>Control+C</td>
</tr>
<tr>
<td>Compose Edit menu - Paste</td>
<td>Control+V</td>
</tr>
<tr>
<td>Compose Edit menu - Delete</td>
<td>Delete key</td>
</tr>
<tr>
<td>Compose Edit menu - Find/Change</td>
<td>Alt+E, then F</td>
</tr>
<tr>
<td>Compose Edit menu - Spelling</td>
<td>Alt+E, then K</td>
</tr>
<tr>
<td>Compose Format menu - Word Wrap</td>
<td>Alt+R, then W</td>
</tr>
<tr>
<td>Attachment menu - Save As</td>
<td>Alt+A, then A</td>
</tr>
<tr>
<td>Separate window message view</td>
<td>Alt+M, then O</td>
</tr>
<tr>
<td>Message menu Select All</td>
<td>Control+/</td>
</tr>
<tr>
<td>Move in Mailbox or Compose window</td>
<td>Tab</td>
</tr>
<tr>
<td>Move between buttons or fields</td>
<td>Tab</td>
</tr>
<tr>
<td>Move forward through Mailbox messages</td>
<td>Down arrow</td>
</tr>
<tr>
<td>Move backward through Mailbox messages</td>
<td>Up arrow</td>
</tr>
</tbody>
</table>
You can easily print files, find or cancel print jobs, and get information about printers and print jobs through the desktop.

<table>
<thead>
<tr>
<th>Your Default Printer</th>
<th>183</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing Files</td>
<td>184</td>
</tr>
<tr>
<td>Printer Applications</td>
<td>189</td>
</tr>
</tbody>
</table>

**Your Default Printer**

Your system may have more than one printer that you can use for printing. One of the printers will be designated as the default printer. The default printer is the printer that your desktop automatically uses if you submit a document for printing and you don't specify a printer name. When you first open your desktop, the default printer is shown in the Front Panel.

To find out how to display a printer other than your default printer in the Front Panel, see “To Change the Front Panel Printer” on page 196.
To Determine the Default Printer

To find out the name of your default printer, double-click the Default printer control in the Personal Printers subpanel in the Front Panel. This starts the Printer Jobs application. The name under the printer icon is the name of your default printer.

To Change the Default Printer

To designate a different printer as the default printer:

1. Go to your home folder and open the file .dtprofile.
2. Add or edit a line that sets a value for the LPDEST environment variable:

   LPDEST=printer_device; export LPDEST

   If you are using csh the syntax is:

   setenv LPDEST printer_device

   Note - This change will take effect the next time you log out and back in again.

For example, the following line would change the default printer to the printer whose device name is laser3d.

   LPDEST=laser3d; export LPDEST

If you are using csh the syntax is:

   setenv LPDEST laser3d

Printing Files

The desktop can print different types of files, as listed in Table 9-1.
Table 9-1 Types of Data That Can Be Printed (Initial Configuration)

<table>
<thead>
<tr>
<th>Type of Data</th>
<th>Data Type Requirement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text file</td>
<td>File name ends with .txt</td>
<td>Text files containing ordinary (ASCII) text data</td>
</tr>
<tr>
<td>PostScript</td>
<td>File name ends with .ps, or content is recognized as PostScript data</td>
<td>PostScript files (requires a PostScript printer)</td>
</tr>
<tr>
<td>PCL</td>
<td>File name ends with .pcl, or content is recognized as PCL data</td>
<td>Printer Control Language files (requires a PCL printer)</td>
</tr>
<tr>
<td>Data</td>
<td>Contains text data</td>
<td>The default data type assigned to all files containing ASCII data that do not match other data types</td>
</tr>
</tbody>
</table>

If applications are installed on your system that create other types of files, your system administrator can add printing capabilities for them.

**Note** - Ensure that your destination printer is capable of printing PostScript™ or PCL files before you try to print them.

**Submitting a File to a Printer**

There are many ways to submit a file to a printer:

- Using the Front Panel
- Using File Manager
- Using Print Manager
- Using applications

**To Print Using the Front Panel**

1. Drag a single file or multiple files from File Manager to the Printer control in the Front Panel or to a Printer icon in the Personal Printers subpanel.

The system then displays a Print dialog box for specifying print options. A Print dialog box appears for each file you drag to the Printer control.
Note – pscolor will not show on your system. It is only included as an example of a printer that has been added to a system.

2. Optional. Use the text fields in the Print dialog box to set additional print options. (See “Setting Print Options Using the Print Dialog Box” on page 187.)

3. Click OK in the Print dialog box to send the job to the printer.

♦ To Print Using File Manager

1. Select the file in File Manager.

2. Choose Print from the Selected menu or the file's pop-up menu.

   The system displays a Print dialog box for specifying various print options.

3. Optional. Use the text fields in the Print dialog box to set additional print options. (See “Setting Print Options Using the Print Dialog Box” on page 187.)

4. Click OK in the Print dialog box to send the job to the printer.
To Print Using Print Manager

1. Start Print Manager from the Personal Printers subpanel.

2. Drag a file from File Manager to a printer icon in Print Manager.
   In Print Manager, you can submit a document by dropping it on a printer icon or into the jobs list area to the right of a printer.

   Note - If you submit a job to a printer that is down (flag is showing), it may never be printed even though it appears in the jobs list.

3. Optional. Use the text fields in the Print dialog box to set additional print options. (See “Setting Print Options Using the Print Dialog Box” on page 187.)

4. Click OK in the Print dialog box to send the job to the printer.

Setting Print Options Using the Print Dialog Box

The desktop displays the Print dialog box when you print text, PCL, PostScript, and data files (see Table 9-1 on page 185).
When application data files, such as word processor documents, are submitted for printing, they may display their own unique Print dialog boxes.

Use the Print dialog box to set these print options:

**Printer**
- The destination for the print job. The text field initially displays the printer on which you dropped the data file. In this example, the document was dropped on a printer named *lj4_n5*.

**Copies**
- The number of copies to print. The default is 1.

**Banner Page Title**
- A title to appear on the banner page. The banner page is a sheet of paper that the printer prints before it prints the first page of your document.

**Print Page Numbers**
- Prints page numbers on each page. If page numbering is selected, Print Manager will not display the true name of your document. Instead, the name in the jobs list will be STDIN:XXXXX, where XXXXX is a five-digit number.

**Print Command Options**
- Other options that change the way printing is done. See the next section for more details on using this field.
Print Command Options

You can use the Print Command Options text field in the Print dialog box to set other print options. Type the proper `lp` command flag in the text field for the print option you want to use. To see a list of the `lp` command flags, type `man lp` in a Terminal window.

For example, one of the `lp` flags is `-m`. This flag tells the print server to send you a mail message that tells you when it is done printing your document. To use this flag you would type `-m` in the Print Command Options field of the Print dialog box. Then when your document is done printing, you will see a message appear in your mailbox from the printer.

Printer Applications

After you submit a document (print job) for printing, you can use the Print Manager or Printer Jobs applications to find out about the progress of the printing. Printer Jobs gives you information about jobs on a single printer. Print Manager shows all the printers that are on your system.

Print Manager

The Print Manager window is shown below. To find out how to modify it, see “Changing the Print Manager Display” on page 197.
To Start Print Manager

- Click the Print Manager control in the Personal Printers subpanel in the Front Panel.
• Or, double-click the Print Manager icon in the Desktop_Apps group in Application Manager.

**Printer Jobs Application**

The Printer Jobs application is the application you see when you open a single printer from the Front Panel. The Printer Jobs application is a simplified version of Print Manager that only shows a single printer instead of all the printers on your system. The functions that are available inside Printer Jobs work the same way as they do in Print Manager.
To Start the Printer Jobs Application

Click the Printer control in the Front Panel.

The pscolor printer is only shown in the figure as an example of a printer that has been added to a system. It will not be on your subpanel.

Displaying Print Job Information

Information about the jobs waiting to be printed on a printer is displayed when you open a printer icon. A display area to the right of the printer icon displays an icon for each of the jobs waiting to be printed on it, and each job’s position in line, job name, and owner.

To Open a Printer Icon

There are three ways to open a printer:

- Click the Open [+] button to the left of the printer icon.
- Select a printer, then choose Open from the Selected menu or from the printer’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).
- Double-click the printer icon.
Note - Your job will not appear in the Print Manager or Printer Jobs window if there are no jobs waiting to be printed when you send your job to the printer.

♦ To Close a Printer Icon

Close a printer if you don’t want to see the jobs waiting to be printed on it.

• Click the Close [-] button to the left of the printer icon.
• Select a printer, then choose Close from the Selected menu or from the printer’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

♦ To Find a Print Job

1. Choose Find from the Printers menu.
   Find is available in Print Manager but not in the Printer Jobs application.

2. Type the name of the print job you want to find in the Job Name field.
   For example, typing cat will find all jobs that include the fragment “cat” in their name, such as “Catchall” and “catalog,” regardless of case.

   To find jobs with the name “cat” only, you would select Exact match.

   To find only jobs that match your capitalization, deselect Ignore case.

Note - Find only finds print jobs that list you as the owner and it searches all printers, even those that are not currently displayed.

3. Click Start Find.

4. Once you have found a job, you can go directly to it in Print Manager or cancel it. To go to a found job, select the job and click Goto. To cancel a found job, select it and click Cancel Print Jobs.
To Cancel a Print Job

1. Select a print job in the Print Manager or Printer Jobs window.
2. Choose Cancel from the Selected menu or from the print job's pop-up menu (displayed by pressing Shift+F10 or mouse button 3).
3. Click Yes in the confirmation dialog box.

Print Job Properties

The following properties can be displayed for print jobs:

- Job name
- Job owner
- Job number
- Job size
- Time job submitted
- Date job submitted

Note - The term “not available” may appear in some fields to indicate that the print system is not supplying that information.

To Display Print Job Properties

1. Select a print job.
2. Choose Properties from the Selected menu or the print job's pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The properties are displayed.
Printers and the Front Panel

The printer shown in the Front Panel is usually your default printer. You can change it to another printer, or add a printer to the Personal Printers subpanel.

♦ To Change the Front Panel Printer

**Note** - This does not change your default printer assignment. To find out how to change the default printer, see “To Change the Default Printer” on page 184.

1. Open the Personal Printers subpanel (by clicking the arrow above the Printer control in the Front Panel) and verify that the icon for the printer you want to move to the Front Panel appears.

   If the printer is not in the Personal Printers subpanel, add it by following the steps in “To Add a Printer to the Personal Printers Subpanel.”

2. In the subpanel, point to the printer icon you want to add to the Front Panel and select Put In Main Panel from the icon’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

   To verify that the printer has been changed, double-click the Printer control in the Front Panel and check the name of the icon in the Printer Jobs window that appears.

♦ To Add a Printer to the Personal Printers Subpanel

1. Open the Personal Printers subpanel (by clicking the arrow above the Printer control in the Front Panel).

2. Start Print Manager.

3. Drag a printer icon from the Print Manager window to the Install Icon control in the open subpanel.
Changing the Print Manager Display

This section describes how to change display parameters in Print Manager.

♦ To Change How Printers and Print Jobs Are Displayed

1. Choose Set Options from the View menu.

2. Select how you want the print jobs represented:
   - Large Icon – Displays printers and print jobs as large icons
   - Small Icon – Displays printers and print jobs as small icons
   - Name Only – Displays printer and print jobs as only text
   - Details – Displays job owner, size, job number, and the date and time each job was submitted
   - Show Labels – Displays a description of each details row to the left of the job list area

   **Note** - The term “not available” may appear in some fields to indicate that the print server is not supplying that information

3. Click OK.

♦ To Change the Update Frequency

1. Choose Set Options from the View menu.

2. Adjust the interval gauge to specify how frequently printers are queried for information about their print jobs. The default is every 30 seconds.

3. Click OK.

♦ To Determine Which Jobs Are Displayed

1. Choose Set Options from the View menu.

2. Select which jobs you want shown:
   - Only Mine – Displays just your print jobs
   - Everyone’s – Displays all print jobs

3. Click OK.
♦ To Display the Print Manager Message Line

1. Choose Set Options from the View menu.
2. Select Message Line to display a message line at the bottom of the Print Manager window.
   The message line shows the number of printers on your system and the number that are currently hidden. It also presents messages telling you when printer updates are being done.
3. Click OK.

♦ To Display the Print Manager Problem Flag

1. Choose Set Options from the View menu.
2. Select Problem Flag to have a flag icon displayed next to printers when a problem is found with one of them.
   For more information on the problem, you can double-click the Flag icon.
3. Click OK.

♦ To Determine Which Printers Are Shown

1. Choose Modify the Show List from the View menu.
   Printers that are visible in the Print Manager window have highlighted names.
2. Click a non-highlighted printer to make it visible in the Print Manager window.
   Click a highlighted printer to remove it from the main window. You can also use Select All to show all the printers or Deselect All to hide all the printers.
3. Click OK.
Printer Properties

The following properties can be displayed:

- Icon label
- Icons
- Description
- Printer queue
- Printer queue status
- Device name
- Device status

♦ To Show a Printer's Properties

1. Select a printer in the Print Manager window or the printer in the Printer Jobs window.

2. Choose Properties from the Selected menu or from the printer's pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

♦ To Change a Printer's Icon

1. Select a printer.

2. Choose Properties from the Selected menu or from the printer's pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

3. Click Find Set.

4. Select the new icon you wish to use.

   If the icon you want is not visible, choose another folder from the Icon Folders menu. This dialog box will only display icons that have a complete set of all three sizes.

5. After you have selected an icon, click OK.

6. Click OK in the Properties dialog box.
To Change a Printer’s Icon Label

1. Select a printer.
2. Choose Properties from the Selected menu or from the printer’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).
3. Type the new icon label in the Icon Label field.
4. Click OK.
This chapter describes how to create and edit short documents such as memos, mail messages, or resource files using Text Editor.

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening and Closing Text Editor</td>
<td>202</td>
</tr>
<tr>
<td>Text Editor Window</td>
<td>203</td>
</tr>
<tr>
<td>Opening and Saving Documents</td>
<td>204</td>
</tr>
<tr>
<td>Moving the Cursor in a Document</td>
<td>209</td>
</tr>
<tr>
<td>Entering Text</td>
<td>208</td>
</tr>
<tr>
<td>Editing Text</td>
<td>212</td>
</tr>
<tr>
<td>Searching a Document</td>
<td>220</td>
</tr>
<tr>
<td>Formatting and Printing Documents</td>
<td>221</td>
</tr>
</tbody>
</table>
Opening and Closing Text Editor

There are several ways to start Text Editor from your desktop.

♦ To Open Text Editor

• Click the Text Editor control in the Front Panel.

• Or, open the Personal Applications subpanel in the Front Panel and click the Text Editor control.

Text Editor can also be started from the command line by typing this command in a Terminal window:

dtpad filename &

The file name is optional.

♦ To Close Text Editor

◊ Choose Close from the File menu or press Alt+F4.

Note - If your keyboard does not have an Alt key, ask your system administrator to identify the corresponding key.
Text Editor Window

You create and edit a document in the Text Editor window. The title bar displays the name of the current document. A new document is named (UNTITLED).

![Text Editor window](image)

Figure 10-1 Text Editor window

You can optionally display a status line that reports the number of lines in your document and enables you to go to a specific line number.

♦ **To Display the Status Line**

The status line displays the line number where the insertion cursor is located and the total number of lines in the document. It also reports Text Editor messages and indicates whether Overstrike mode is active.

◊ Choose Status Line from the Options menu. To remove the status line, choose Status Line again from the menu.
Opening and Saving Documents

You can create a new document or open an existing document. Opening a document displays the contents of a selected file in the Text Editor window.

Saving a document stores the edited contents into a file. You can save a document to its original file or to a new file.

♦ To Create a New Document

A new document named (UNTITLED) is created when you start Text Editor. To enter text in your document, see “Entering Text” on page 208. You provide a new file name when you save the document.

After finishing a document, you can create another document using the New command.

◊ Choose New from the File menu.

The Text Editor window is cleared and a new document is created. If you have not saved your current document, a dialog box is displayed that enables you to save your document.

♦ To Save a Document to a New File

1. Choose Save As from the File menu.

The Save As dialog box lists files and folders located in your current folder. You can store your document in the current folder, a subfolder, or a folder that you specify.

If you used Wrap To Fit, the dialog box includes an additional choice about handling line endings. If Wrap To Fit is set off, the dialog box omits this choice (see “Using Wrap To Fit” on page 208).
2. Optional. If you do not want to save the file to the current folder, choose a subfolder or indicate a different folder.
   • For a subfolder, select the subfolder in the Folders list and press Return.
   • For a different folder, use the .. (go up) icon to change to a folder or type its path name in the Enter path or folder name field.

3. Type a new file name in the Enter file name field.

4. Press Return or click OK.

♦ To Save a Document to the Original File

◊ Choose Save from the File menu to save your work and continue editing your document.
If you used Wrap To Fit, the Save dialog box includes an additional choice about handling line endings (see “Using Wrap To Fit” on page 208).

**Opening an Existing Document**

You can open an existing document in these ways:

- Open the document in Text Editor.
- Select the file icon in File Manager and choose Open from the File Manager Selected menu.
- Double-click the file icon in File Manager.
- Drag the document’s file icon to the Text Editor control in the Front Panel.

**To Open an Existing Document from Text Editor**

1. Choose Open from the File menu.

   The Open a File dialog box lists files and folders in your current folder. You can browse the documents listed, or change to a new folder to locate other files on your system.

![Figure 10-3 Open a File dialog box](image)
2. Select the name of the document you want to open, or type the document name in the Enter file name field.

3. Press Return or click OK.

**Note** - You can also use this shortcut: double-click the document name in the dialog box.

♦ **To Open an Existing Document from File Manager**

1. Display the document's file icon in a File Manager window.

![Document file icon](image)

Figure 10-4 Document file icon

2. Open the document in one of the following ways:
   - Double-click the document.
   - Select the document, then choose Open from the File Manager Selected menu.
   - Drag the document file icon to the Front Panel and drop the icon on the Text Editor control.
Entering Text

As you create a document, you type and edit text. A cursor (I) shows your current position. Characters are inserted unless you set Overstrike mode (see “To Set Overstrike Mode” on page 214).

♦ To Enter New Text

◊ Click in the document and start typing.

To start a new line, press Return. Or, you can use the Wrap To Fit option to automatically wrap text at the edge of the window.

To start a paragraph, press Return twice.

Using Wrap To Fit

Wrap To Fit controls whether lines are automatically wrapped to fit the width of the window. When Wrap To Fit is set on, lines are broken automatically at the edge of the window. Because these line breaks are dynamic, you can resize the Text Editor window and the text automatically adjusts to fit the new window width.

When you save your document, you decide whether to add a line break to each of the wrapped lines, or to retain the dynamic line endings. When you save your document, you choose one of these options:

• Add a newline character (hard return) to the end of each wrapped line to preserve each line ending as it currently appears.

• Or, preserve only line breaks that were created by pressing Return.

♦ To Set Wrap To Fit On or Off

◊ To set Wrap To Fit on, choose the Wrap To Fit toggle button in the Options menu. To set Wrap To Fit off, choose the toggle button again.
Entering Special Characters

Different systems often use certain key combinations to insert special characters. In some instances, a key combination may be reserved by Text Editor. For example, a Text Editor mnemonic for displaying a menu might conflict with a key sequence you want to use on your keyboard.

To insert the correct character you may need to override the reserved behavior by preceding the key combination with Control+Q.

Moving the Cursor in a Document

As you enter and edit text, you move the insertion cursor using the mouse and keyboard cursor keys. Using the mouse, move the pointer to the new location in the document and click mouse button 1.

You can also use the keyboard cursor movement keys:

<table>
<thead>
<tr>
<th>Key</th>
<th>Cursor Movement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up Arrow</td>
<td>Up one line</td>
</tr>
<tr>
<td>Down Arrow</td>
<td>Down one line</td>
</tr>
<tr>
<td>Left Arrow</td>
<td>Left one character</td>
</tr>
<tr>
<td>Right Arrow</td>
<td>Right one character</td>
</tr>
<tr>
<td>Control+Left Arrow</td>
<td>Move left to previous word</td>
</tr>
<tr>
<td>Control+Right Arrow</td>
<td>Move right to next word</td>
</tr>
<tr>
<td>Home</td>
<td>Beginning of the current line</td>
</tr>
<tr>
<td>End</td>
<td>End of the current line</td>
</tr>
<tr>
<td>Control+Up Arrow</td>
<td>Beginning of the previous paragraph</td>
</tr>
<tr>
<td>Control+Down Arrow</td>
<td>Beginning of the next paragraph</td>
</tr>
<tr>
<td>Control+Home</td>
<td>Beginning of the document</td>
</tr>
<tr>
<td>Control+End</td>
<td>End of the document</td>
</tr>
<tr>
<td>Control+G</td>
<td>To the Line field in the status line</td>
</tr>
</tbody>
</table>
Note – If your keyboard uses different key labels, ask your system administrator to identify the corresponding keys.

♦ To Go to a Specific Line

1. Display the status line (see “To Display the Status Line” on page 203).
2. Press Control+G or click in the Line field of the status line.
3. Type the line number you want to go to and press Return.

♦ To Scroll a Document

◊ Select and drag the vertical scroll bar to view more text. Use the horizontal scroll bar to view long lines.

You can also use the scrolling keys:

<table>
<thead>
<tr>
<th>Key</th>
<th>Scroll Movement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Up</td>
<td>Up one page</td>
</tr>
<tr>
<td>Page Down</td>
<td>Down one page</td>
</tr>
<tr>
<td>Control+Page Up</td>
<td>Left one page</td>
</tr>
<tr>
<td>Control+Page Down</td>
<td>Right one page</td>
</tr>
</tbody>
</table>

Selecting Text

Before using edit commands such as cut and paste, you must select the text. You can select text using the mouse or the keyboard.
To Select Text with the Mouse

1. Click at the beginning of the text you want to select.
2. Press and hold mouse button 1 and drag to the end of the text.
To deselect text, click any area in the window.

Note - To modify a selection you have made, press and hold the Shift key and mouse button 1. Then drag forward or backward to adjust the amount of selected text. Or, hold down the Shift key and one of the arrow keys to change the selection.

You can also use these shortcuts for selecting text:

<table>
<thead>
<tr>
<th>Word</th>
<th>Double-click the word</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td>Triple-click the line</td>
</tr>
<tr>
<td>All text</td>
<td>Quadruple-click in the text</td>
</tr>
</tbody>
</table>

Secondary Selection

This method enables you select text and replace it with another selection, which is used as the replacement text.

To Replace Text Using Secondary Selection

1. Select the text that you want to replace.
2. Move the pointer to the beginning of the text you want to replace the first selection with. Hold down the Alt key and mouse button 2 and drag to the end of the text you want to use.
   The text is underlined.

Note - If your keyboard does not have an Alt key, ask your system administrator to identify the corresponding key.

3. Release the Alt key and mouse button.
   The underlined text overwrites your first selection.
To Select Text with the Keyboard

**Text to Select** | **Action**
--- | ---
Text block | Move the cursor to the beginning of the text block. Hold down the Shift key and an arrow key to move the cursor to the end of the text block.

Cursor to beginning of line | Shift+Home
Cursor to end of line | Shift+End
Cursor to beginning of paragraph | Shift+Control+Up Arrow
Cursor to end of paragraph | Shift+Control+Down Arrow
Cursor to beginning of document | Shift+Control+Home
Cursor to end of document | Shift+Control+End
All text | Control+/ 
Deselect all text | Control+\ 

**Editing Text**

Minor edits can be made using the editing keys. You may also want to copy, move, or delete portions of text, find and change a word or phrase, or check the spelling of your document.

**Editing Keys**

| Key | Action |
--- | --- |
Backspace | Deletes the character before the cursor |
Delete | Deletes the character following the insertion cursor |
Control+Backspace | Deletes the previous word |
Shift+Backspace | Deletes characters from the cursor to the beginning of the line |
Control+Delete | Deletes all the characters from the cursor to the end of the current line |
Insert | Toggles Overstrike and Insert mode |
Menu Shortcut Keys

You can also use these shortcut keys when making edits.

- Control+C: Copy selected text
- Control+X: Cut selected text
- Control+V: Paste selected text
- Control+F: Find/Change text
- Control+Z: Undo a cut, delete, clear, include, copy, or paste command

UNIX Key Bindings

UNIX™ key bindings enable you to use a set of extended Emacs keys, such as Alt+B (back word) or Control+N (next line), in Text Editor. To enable UNIX key bindings (which are set off by default) you edit a file in your home directory.

♦ To Enable UNIX Key Bindings

1. Add the following line to the .Xdefaults file in your home directory:
   ```
   #include "usr/dt/app-defaults/language/UNIXbindings"
   ```
   Replace language with the name of your language environment.
   If the .Xdefaults file does not exist, create the file in your home directory.

2. Log out of your current session.

3. Log in and restart Text Editor.

Some Text Editor menu accelerators conflict with UNIX key bindings. When UNIX key bindings are enabled, Text Editor provides alternate menu accelerators for these commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Alternate Menu Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find/Change (Control+F)</td>
<td>Control+S</td>
</tr>
<tr>
<td>Paste (Control+V)</td>
<td>Shift+Insert</td>
</tr>
</tbody>
</table>
Print (Control+P)  no alternate accelerator
Undo (Control+Z)  Control+_

If you want to modify these menu accelerators, copy the contents of the /usr/dt/app-defaults/language/UNIXbindings file into your .Xdefaults file and then make your changes.

Note - When using UNIX key bindings, the Delete key deletes the previous character rather than the character that follows the cursor.

♦ To Set Overstrike Mode

As you type, new characters are inserted. If you want to type over existing characters, change to Overstrike mode.

• Choose Overstrike from the Options menu. To return to Insert mode, choose Overstrike again from the menu.

• Or, use the Insert key to switch between Insert and Overstrike mode.

When Overstrike mode is on, the cursor changes to a block ( ■ ). If you use Overstrike mode often, you may want to display the status line (see “To Display the Status Line“ on page 203) because it indicates whether Overstrike mode is on or off.

♦ To Type Over Text

1. Select the text.
2. Type the replacement text.

You can also choose Overstrike from the Options menu to turn off Insert mode and type over the text directly.

♦ To Delete Text

1. Select the text.
2. Choose Delete from the Edit menu or press the Delete key.
Deleted text cannot be pasted, but it can be recovered with the Undo command (see “To Undo an Edit” on page 215).

If you intend to paste the text that you delete, use the Cut command (see “To Move Text (Cut and Paste)” on page 216).

♦ To Clear Text

The Clear command replaces the selected text with spaces or blank lines.
1. Select the text to be cleared.
2. Choose Clear from the Edit menu.

♦ To Undo an Edit

◊ Choose Undo from the Edit menu or press Control+Z.

Undo reverses the last cut, paste, clear, delete, change, include, or format operation.

♦ To Copy Text

1. Select the text to be copied.
2. Choose Copy from the Edit menu or press Control+C.

A copy of the text is stored on a clipboard where it can be accessed or replaced by other applications.

3. Click where you want to insert the text.
4. Choose Paste from the Edit menu or press Control+V.

You can also use drag and drop to copy text (see “To Copy Text Using Drag and Drop” on page 219).

Note - Use this shortcut to copy a word or phrase: Select the text, move the pointer to where you want to insert the text, and click mouse button 2. This is a quick way to copy text into a dialog box.
To Move Text (Cut and Paste)

1. Select the text.

2. Choose Cut from the Edit menu or press Control+X.
   The text is erased from the document and stored on a clipboard where it can be accessed or replaced by other applications.

3. Move the cursor to where you want to insert the text.

4. Choose Paste from the Edit menu or press Control+V.
   You can also use drag and drop to move text (see “To Move Text Using Drag and Drop” on page 219).

To Correct Misspelled Words

1. Choose Check Spelling from the Edit menu.
   The Spell dialog box lists misspelled or unrecognized words.

2. Select the misspelled word in the Misspelled Word list that you want to find and press Return. Or, just double-click the word.
   The next occurrence of the word is highlighted in your document.

3. Type the correct word into the Change To field.

4. Click Change to correct a single occurrence.
5. To find and change additional occurrences, click Find and then Change. Or, click Change All to replace all occurrences.

6. Click Close when you are done.

**Note** - The Check Spelling feature is only available for the English language.

♦ **To Include a File**

You can insert a text file into your document using a menu command or by dragging a file icon into the Text Editor window (see “To Include a File Using Drag and Drop” on page 219).

1. Position the cursor where you want to insert the text file.

2. Choose Include from the File menu.

The Include a File dialog box lists files and folders on your system. You can browse the documents listed, or change to a new folder to locate other files on your system.

![Include a File dialog box](image)

*Figure 10-6 Include a File dialog box*
3. Select the document you want to insert in the Files list.
4. Press Return or click OK.
Using Drag and Drop

You can use drag and drop to move or copy text between Text Editor documents or other applications. You can also include a file into your document using drag and drop.

♦ To Move Text Using Drag and Drop

1. Select the text that you want to move.
2. With the pointer on the selection, press and hold mouse button 1, and drag to where you want to insert the text.
3. Release the mouse button.
   The text is inserted into your document relative to the position of the drag icon.

♦ To Copy Text Using Drag and Drop

1. Select the text you want to copy.
2. With the pointer on the selection, press and hold the Control key and mouse button 1, and drag to where you want to copy the text.
3. Release the Control key and mouse button.
   The text is copied relative to the position of the drag icon.

♦ To Include a File Using Drag and Drop

When using drag and drop, the contents of the file are copied into the Text Editor window at the position of the insertion cursor. The original file remains intact.

1. Click in your document where you want to include the file.
2. Drag the file icon that you want to include into the Text Editor window.
Searching a Document

You can search for a word or phrase in your document. The Find command begins from the position of the insertion cursor and proceeds through the entire document. You can automatically replace or delete occurrences found in your document.

Searches are case sensitive. To find all occurrences, search for both lowercase and uppercase instances.

To Find Text

1. Choose Find/Change from the Edit menu or press Control+F.

   ![Find/Change dialog box]

   Figure 10-7 Find/Change dialog box

2. Type the text you want to find in the Find field.

3. Press Return or click the Find button to locate the next occurrence of the text.

4. To find additional occurrences, press Return or click Find again.

To Find and Change Text

1. Choose Find/Change from the Edit menu or press Control+F.

2. Type the text you want to find in the Find field.

3. Type the replacement text in the Change To field.
4. Press Return or click the Find button to locate the next occurrence of the text.

5. Click Change to replace a single occurrence.

6. To find and change additional occurrences, click Find and then Change. Or, click Change All to replace all occurrences.

Caution - There is no Undo for Change All.

7. Click Close when you are done.

♦ To Find and Delete Text

1. Choose Find/Change from the Edit menu or press Control+F.

2. Type the text you want to delete in the Find field.

3. Leave the Change To field blank.

4. Press Return or click Find to locate the next occurrence.

5. Click Change to delete a single occurrence.

6. To find and change additional occurrences, click Find and then Change. Or, click Change All to replace all occurrences.

7. Click Close when you are done.

Formatting and Printing Documents

Once your editing is complete, format your document by choosing margins and text alignment.
To Format a Document

1. Choose Settings from the Format menu.

![Format Settings dialog box](image)

2. Enter margins.
   
   The default left margin is 0 and the right margin is dynamically set to the width of the Text Editor window. Margins are specified as a number of character columns.

3. Select left, right, justify (block style), or center alignment.

4. Determine the scope of the formatting:
   - To format a single paragraph, place the cursor in the paragraph, then click Paragraph.
   - To format the entire document, click All.

5. After closing the dialog box, choose Paragraph or All from the Format menu to apply the settings.

To Print an Open Document

1. Open the document in Text Editor.

2. Choose Print from the File menu or press Control+P.

   The Print dialog box displays the name of your system's printer and enables you to set printing options. By default, your document is printed on your system printer. If desired, you can direct your job to a different printer.
3. Optional. Set any of these printing options:
   • Type the number of copies to print.
   • Type text to appear on the printer banner page.
   • Click Print Page Numbers if you want to number the pages.
   • Type command-line printer options.

4. Click Print.

   The Print dialog box closes when you print your document. To close the dialog box without printing your file, click Cancel.

♦ To Print a Closed Document

1. Display the document’s file icon in File Manager.

2. Drag the file icon to the Printer control in the Front Panel.

   The Print dialog box is opened.

3. Optional. Set printing options.

4. Click Print.
Recovering a File

If Text Editor is interrupted due to a system error, it attempts to save your changes in a recovery file in your current folder. The recovery file is named #filename#, where filename is the name of the document. If you had never named your document, the recovery file name is #UNTITLED#.

♦ To Recover a File

1. Start Text Editor.
2. Open the recovery file.
3. Save the document using your original file name or provide a new name for a previously unsaved document.

Text Editor and Other Applications

Other applications can use Text Editor as a tool to edit documents or other types of information. Under certain conditions, an application may choose to restrict your editing choices. In the example below, the File menu has been modified. The Save As command has been replaced with a Copy To File command and the New and Open commands are not available.

Figure 10-10 Text Editor with modified File menu
Using Calendar

Calendar is a desktop application that enables you to schedule appointments and To Do items, set reminders, make and print appointment and To Do lists, browse other calendars, and schedule group appointments.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>To Schedule a Basic Appointment</td>
<td>231</td>
</tr>
<tr>
<td>To Set Appointment Options</td>
<td>232</td>
</tr>
<tr>
<td>Printing Calendars, Appointment, or To Do Lists</td>
<td>238</td>
</tr>
<tr>
<td>Browsing Calendars on a Network</td>
<td>239</td>
</tr>
<tr>
<td>Scheduling Appointments on Other Calendars</td>
<td>241</td>
</tr>
</tbody>
</table>

♦ To Start Calendar

To start Calendar, click the Calendar control in the Front Panel.
Calendar Main Window

The menus and tool bar controls are at the top of the main window. The selected Calendar view is displayed in the lower part of the main window.
Calendar Tool Bar

Calendar’s tool bar provides controls for quick navigation through calendars. The tool bar controls and their functions are described in Table 11-1.

Table 11-1 Calendar Tool Bar Icons

<table>
<thead>
<tr>
<th>Control</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appointment Editor icon</td>
<td>opens the Appointment Editor so you can insert, delete, or edit Calendar appointments.</td>
</tr>
<tr>
<td>To Do Editor icon</td>
<td>opens the To Do Editor so you can create, modify, update, or set reminders for things you have to do.</td>
</tr>
<tr>
<td>Previous View arrow</td>
<td>changes the Calendar view to display the view before the current view. For example, if you are viewing August in month view, clicking the Previous View arrow changes the Calendar display to July.</td>
</tr>
<tr>
<td>Today</td>
<td>changes the Calendar view to display the current day in the format you are viewing. For example, if you are viewing by month, clicking Today displays the current month.</td>
</tr>
<tr>
<td>Next View arrow</td>
<td>changes the Calendar view to display the view after the current view. For example, if you are viewing August in Month view, clicking the Next View arrow changes the Calendar display to September.</td>
</tr>
<tr>
<td>Day View icon</td>
<td>displays the calendar you are viewing with one day’s appointments in the window plus a three-month mini-calendar.</td>
</tr>
<tr>
<td>Week View icon</td>
<td>displays the calendar you are viewing with a week’s appointments in the window plus a week grid showing scheduled times.</td>
</tr>
<tr>
<td>Month View icon</td>
<td>displays the calendar you are viewing with a month’s appointments in the window.</td>
</tr>
<tr>
<td>Year View icon</td>
<td>displays the calendar you are viewing with a year in the window. Appointments are not displayed.</td>
</tr>
</tbody>
</table>
Calendar Views

The Calendar view is the day, week, month, or year displayed in the main Calendar window.

Day View

Day view displays the calendar you are viewing with one day’s appointments in the window. Day view also provides a three-month mini-calendar that displays the month you are viewing and the previous and next months.

Clicking on a day in the three-month mini-calendar changes the Day view to display the selected day. Clicking on a month name in the mini-calendar changes the Calendar display from Day view to Month view.
**Week View**

Week view displays the calendar you are viewing with one week’s appointments in the window. The selected day is highlighted.

Week view also provides a week grid showing at a glance the times that are scheduled (shaded) and the times that are available (unshaded).

Clicking on a day name in the Week view changes the Calendar display from Week view to Day view.
Month View

Month view displays the calendar you are viewing with one month’s appointments in the window. The selected day is highlighted.

Clicking on a day in Month view changes the Calendar display to Day view.
YearView

Year view displays a year calendar. Appointments are not displayed. Clicking on a month name in Year view changes the Calendar display to Month view.

Appointments

Use the Appointment Editor to insert, change, or delete appointments on your calendar.

♦ To Schedule a Basic Appointment

1. In Day, Week, or Month view, display the day for which you want to schedule an appointment.

2. Double-click that day to open the Appointment Editor.
3. Choose the Start and End times.
   The default appointment duration is one hour. If your appointment is longer or shorter, edit the time in the End field.

4. Type a description of the appointment in the What field.
   For example, you may want to enter the appointment's location and purpose.
   If you want to add optional settings to an appointment, see “To Set Appointment Options.”

5. Click Insert.
   The appointment is added to your calendar.

6. Click Cancel to close the Appointment Editor.

♦ To Set Appointment Options

1. Set up a basic appointment, as described above.

2. Click the More button in the Appointment Editor to display additional appointment options.

3. Select the desired appointment in the Appointment Editor list.

4. Select Beep, Flash, Popup, or Mail (or more than one, in combination) for the types of reminders you want.

5. Edit the reminder intervals or the calendar-name@hostname entry if necessary.

6. Optional. To repeat the appointment more than once, choose an option from the Occurs menu, and then choose an option from the For menu. If you don’t see the interval you want, choose Repeat Every from the Occurs menu, and type the desired interval in days, weeks, or months.
7. Choose an option from the Privacy menu.
Others See Time and Text Displays full appointment to others.
Others See Time Only Displays only time commitment, not description.
Others See Nothing Displays nothing to others.
8. Click Change.
   If you set the appointment options at the same time as setting up a basic appointment, click Insert at this step.

**Note** - If you are inserting multiple appointments one after another, be sure to click Clear between insertions. This will reset options that you may not want to carry over from one appointment to the next.

9. Click Cancel to close the Appointment Editor.

♦ **To Change an Appointment**

1. Click the Appointment Editor icon.
2. Select the appointment in the appointment list that you want to change.
3. Edit the appointment date, start or end time, description, reminders, frequency, or privacy.
4. Click Change.
5. Click Cancel to close the Appointment Editor.

♦ **To Delete an Appointment**

1. Click on the Appointment Editor icon to open it.
2. Select the appointment in the appointment list.
3. Click Delete.
4. Click Cancel to close the editor.
♦ To Find an Appointment

1. Choose Find from the View menu.
   The Find dialog box is displayed

2. Type some text in the Find field that can become a keyword for the search; for example, conference.
   The Find field is not case-sensitive.

   By default, Calendar searches the past and future six months in your calendar. If you want to change the search range, click Search all to search your entire calendar (can take a long time) or edit the dates in the Search from fields.

3. Click Find.
   Appointments with matching text are displayed in the Find window.

4. Select the desired appointment in the list.

5. Click Show Appointment to display the entire appointment.

6. Click Close to close the Find dialog box.

♦ To View an Appointment List

This section describes how to create an appointment list and display it on your system. If you want to print your Appointment list, see “Printing Calendars, Appointment, or To Do Lists.”

1. Display the view of the calendar that you want the appointment list to show.

2. Choose Appointment List from the View menu.
Using Calendar

Appointments are listed chronologically and show date, time, and description. For example, if you are viewing by week, the Appointment List displays the week’s appointments.

**To Do Items**

Use the To Do Editor to insert, update, or delete To Do items in your Calendar.

♦ **To Insert a To Do Item**

1. Click the To Do Editor icon.

2. Type or edit the due date for the item in the Due Date field.
3. Type a description of the To Do item in the What field.
4. Click Insert.
5. Click Cancel to close the To Do Editor.
♦ **To Change a To Do Item**

1. In Day, Week, or Month view, display the day for which you want to change a To Do item.
2. Select that day.
3. Click the To Do Editor icon.
4. Select the To Do item in the To Do list.
5. Edit the due date or the description of the To Do item.
6. Click Completed to change the status of the To Do item, if applicable.
7. Click Change.
8. Click Cancel to close the To Do Editor.

♦ **To Delete a To Do Item**

1. Click the To Do Editor icon to open it.
2. Select the To Do item in the To Do list.
3. Click Delete.
4. Click Cancel to close the editor.

♦ **To View a To Do List**

This section describes how to create a list of To Do items and display it on your system. If you want to print your To Do list, see “Printing Calendars, Appointment, or To Do Lists.”

1. Display the view of the calendar that you want the To Do list to show.
2. Choose To Do List from the View menu.
To Do items are listed chronologically and show a check box beside each item, due date, and description. For example, if you are viewing by day, the To Do List displays the day’s To Do items.

**Marking To Do Items Completed**

Calendar keeps track of the state of To Do items: whether they’re completed or pending. In the To Do List dialog box, you can choose to display all To Do items, only completed items, or only pending items.

If you make a To Do list and then want to check off an item on the list, use one of the two methods described below.

♦ **To Mark an Item Directly in the To Do List**

1. Choose To Do List from the View menu.
2. Click the check box beside the To Do item you’ve completed.
3. Click Apply or OK.
   - This changes the item’s state to completed.
   - To return the item’s state to pending, click the check box again and apply your changes.
To Use the To Do Editor To Mark an Item

1. Click the To Do Editor icon.
2. Select the To Do item in the To Do list.
3. Click Completed to mark the item completed.
   To return the item’s state to pending, click Completed again.
4. Click Change.
   This changes the item’s state to completed.
5. Click Cancel to close the To Do Editor.

Printing Calendars, Appointment, or To Do Lists

You can print any of the four Calendar views, plus appointment and To Do lists. Calendar uses the default printer settings when you choose Print Current View from the File menu. To customize printer settings, see “To Change the Printer Settings for Future Print Jobs” on page 252.

To Print Current Day, Week, Month, or Year Views

1. Display the Calendar view you want to print.
2. Choose Print Current View from the File menu.

To Print Your Appointment or To Do List

1. Display the Calendar view containing the day for which you want to print an appointment or To Do list.
2. Select that day.
3. Choose Print from the File menu.
   The Print dialog box is displayed.
4. Choose Appointment List or To Do List from the Report Type menu.
5. Specify a printer in the Printer Name field.
6. Click Print.
To Change the Print Options for a Single Print Job

1. Choose Print from the File menu. The Print dialog box is displayed.

2. Double-click in the Printer Name field to select the contents and type a printer name.

3. Choose the view or list you want to print from the Report Type menu.

4. Click the arrows next to the Copies field to adjust the number of copies to be printed or type the number.

5. Optional. Change the range of time to print in the From or To fields.

6. Optional. Add printer options in the Print Command Options field. For example, to save paper, you may want to specify `-o nobanner` to suppress header pages.

7. To print Calendar data to a file instead of to a printer, select Print to file. Click again on this setting to deselect it.

8. Edit the file name, if desired.

9. Click Print.

10. Click Close to close the Print dialog box.

Browsing Calendars on a Network

If you know the names of other calendars on a network, you can use Calendar to browse those calendars. A practical example is to set up a meeting or appointment for several people. You can use Calendar to check for free times.

To browse other calendars and possibly to insert an appointment, you need:

- The calendar names in the form calendar-name@hostname, such as kent@dailyplanet
- To add calendars to the Browse list
- To determine if you have access to other calendars
By default, Calendar allows the world to have browse permission. Only the calendar owner has insert and delete permission. To change access and permissions, see “To Change Access and Permissions” on page 248.

♦ To Obtain the Names of Other Calendars

Calendar doesn't yet provide a way for you to look up other calendar names.

◊ Call or talk to people and get them to tell you their calendar-name@hostname information.

♦ To Add or Delete Calendars in the Browse List

To add:

1. Choose Menu Editor from the Browse menu.
2. Type the calendar-name@hostname in the User Name field.
3. Click Add Name.
4. Click OK to add the calendar to the Browse list and close the Menu Editor dialog box.

To delete:

1. Select a calendar name in the Browse list.
2. Click Remove Name.
3. Click OK to delete the calendar from the Browse list and close the Menu Editor dialog box.
4. To erase your changes and leave the dialog box displayed, click Reset before clicking Apply.
5. To save your changes and close the dialog box, click OK.

To save your changes and leave the dialog box displayed, click Apply.
To erase your changes and close the dialog box, click Cancel.
To Determine Whether You Have Access to Other Calendars

1. Choose Compare Calendars from the Browse menu.
2. Select one or more entries in the Browse list that you want to check for access.
3. Click Schedule to open the Group Appointment Editor.
4. Look at the Calendar Access list.
   The Calendar Access list displays the calendar names that you selected in the Compare Calendars dialog box.
   A “Y” in the Access column means you have insert access. An “N” means you don’t.
   To add appointments or To Do items to other calendars, ask the owners to grant you insert access. To find out how to grant or deny access to your calendar by others, see “To Change Access and Permissions” on page 248.

Scheduling Appointments on Other Calendars

Once you’ve browsed calendars for free times and have permission to insert appointments on other calendars, you can schedule a group appointment.

Use the Group Appointment Editor to insert, change, or delete group appointment on your and other calendars. If you don’t have insert access to other calendars, you can use the Group Appointment Editor to mail notices of group appointments to other users.

To Schedule a Group Appointment

1. Choose Compare Calendars from the Browse menu.
2. Click one or more entries in the Browse list.
   Notice that the grid overlays calendars one on top of another and displays busy times shaded darker and available times unshaded.
3. Click in an unshaded time block in the grid.
4. Click Schedule.  
The Group Appointment Editor is displayed with the fields for date, 
time, and mail automatically filled out.

5. Type (or edit) the group appointment start time in the Start field.

6. Type (or edit) the group appointment end time in the End field.

7. In the What field, type the appointment description, such as its location 
or purpose.

8. Click More.

9. Choose the repeat interval and duration for the group appointment.

10. Click Insert to add the group appointment to the selected calendars.
    
    If you don’t have insert access on all the calendars, you can send mail to 
    notify others about the group appointment. See “To Mail Reminders to a 
    Group Using Calendar.”

11. Click Cancel to close the Group Appointment Editor.

♦ To Mail Reminders to a Group Using Calendar

Once you've set up a group appointment (date, start and end times, 
description, repeat interval), you may want to mail the group a reminder. 
To send mail:

1. Click More in the Group Appointment Editor to display additional 
options.

2. Click Mail.
    
    Calendar displays a Compose window containing an appointment 
    attachment. The appointment attachment is pre-addressed to the 
    selected users and automatically filled out with the date and 
    appointment start and end times.

3. Click Deliver in the Compose window.
    
    Calendar mails the reminder to the selected users.
Recipients of a mail message with a calendar-formatted reminder can drag the message from the mailer header window and drop it on their calendars to automatically schedule the pre-formatted appointment.

♦ To Create an Appointment Message Using a Mail Program

1. Start the mail program.
2. Open a compose window or create a blank message.
3. Add a section to the message that includes exactly the following format. Replace <tab> with a tab character, <blank line> with a blank line, and replace the italicized format information with actual data.
   <tab>** Calendar Appointment **
   <blank line>
   <tab>Date:<tab>mm/dd/yy
   <tab>Start:<tab>hh:mm am
   <tab>End:<tab>hh:mm pm
   <tab>What:<tab>description line 1
   <tab><tab>description line 2

   An example might be:

   ** Calendar Appointment **

   Date:11/22/94
   Start:10:00 am
   End:11:00 am
   What:Staff meeting
       Monet conference room

4. Insert any additional text into the mail message.
5. Address the message to the recipient and include the subject of the message.
6. Send the message.

For information about using Mailer, see Chapter 8, “Using Mailer.”
♦ **To Drag an Appointment from Another Application to Calendar**

From Mailer or File Manager, and possibly other applications, you can drag an appointment icon to Calendar to schedule it.

**From Mailer**

1. In the Mailer message header list, click the header containing the formatted appointment.
2. Drag the header to Calendar and drop it.
   
   The pointer changes to an icon representing the moving file.
   
   Calendar schedules your appointment and prints a message in the message area stating that the appointment was scheduled.
3. Display the Calendar view containing the day on which you scheduled the appointment.
4. Double-click that day to open the Appointment Editor.
   
   Verify that the appointment is scheduled for the correct day and time.

For more information on using Mailer, see Chapter 8, “Using Mailer.”

**From File Manager**

If you have a file containing a formatted appointment:

1. In an open File Manager window, navigate to a folder containing a file with a formatted appointment.
2. With both the formatted appointment and Calendar visible on your screen, drag the formatted appointment file to Calendar and drop it.
   
   Calendar schedules your appointment.
3. Double-click that day to open the Appointment Editor.
   
   Verify that the appointment is scheduled for the correct day and time.

For more information about File Manager, see Chapter 5, “Managing Files with File Manager.”
To Drag an Appointment from Calendar to Another Application

From Calendar, you can drag an appointment icon to Mailer to mail it to someone or to File Manager to save it in your file system.

To Mailer
1. Use the Appointment Editor to create an appointment but don’t click Insert.

2. Start Mailer and choose New Message from the Compose menu.

   Make sure both the Appointment Editor and Mailer’s Compose window are visible on your screen.

3. Drag the Drag Appt icon from the Appointment Editor and drop it on Mailer’s attachment list.

   The pointer changes to an appointment icon representing the moving file.

   Mailer displays your appointment as a text file in the attachment list.

4. Compose and address your mail message and send it.

   For more information on using Mailer, see Chapter 8, “Using Mailer.”

To File Manager
1. Use the Appointment Editor to create an appointment but don’t click Insert.

2. In an open File Manager window, navigate to a folder where you want to save the appointment in a file.

3. With both the File Manager window and Calendar Appointment Editor visible on your screen, drag the Drag Appt icon from the Appointment Editor and drop it on the File Manager window.

   The appointment is saved in a text file in the folder where you dropped it.

For more information about File Manager, see Chapter 5, “Managing Files with File Manager.”
Customizing Calendar

Calendar provides Options dialog boxes to change the settings for all future appointments. To change the settings for individual appointments, see “To Set Appointment Options” on page 232.

♦ To Change Appointment Editor Defaults

1. Choose Options from the File menu.
   The Calendar Options dialog box is displayed.
2. Choose Editor Defaults from the Category menu.
3. Optional. Change the default appointment duration in the Duration field.
4. Optional. Change the default appointment start time by choosing from the Start menu.
5. Select Beep, Flash, Popup, or Mail reminders.
   Beep Causes your system to emit an electronic beep
   Flash Causes your calendar to flash
   Popup Displays a reminder dialog box
   Mail Sends electronic mail
6. Edit the default time intervals if necessary.
   The time interval fields are active for each reminder you select. They specify the time before an appointment that the reminder will be activated.
7. Choose a privacy option from the Privacy menu.
   Others See Time Only The default – displays only the time of an appointment so others can see you’re busy
   Others See Time and Text Displays the time and text of an appointment in your calendar
   Show Nothing Displays nothing about an appointment in your calendar for maximum privacy
8. Click Apply to apply the new defaults to all future appointments.
9. Click Cancel to close the Calendar Options dialog box.

Changing the Display Settings

You can customize many parts of the Calendar display:

- Determine the initial calendar that displays
- Set time boundaries
- Set the default view

♦ To Set the Initial Calendar Displayed

You can set Calendar to display a calendar other than your own when you first start it.

1. Choose Options from the File menu
   The Calendar Options dialog box is displayed.
2. Choose Display Settings from the Category menu.
3. Double-click in the Initial Calendar View field and type calendar-name@hostname for the calendar you want to view each time you start Calendar.
4. Click Apply.
5. Click Cancel to close the Options dialog box.

♦ To Set the Time Boundaries on Day and Week Views

Time boundaries are the earliest and latest hours you want displayed in your calendar.

1. Choose Options from the File menu.
2. Choose Display Settings from the Category menu.
3. Move the Begin and End sliders to adjust the earliest and latest hours you want displayed on your calendar.
4. Select 12 Hour or 24 Hour time display.
5. Click Apply.
6. Click Cancel.

♦ To Set the Default Calendar View

Calendar displays the default Calendar view each time you start it. The initial default view is by month. You may want to set the default to the view you use most often, such as Week view.

1. Choose Options from the File menu.
2. Choose Display Settings from the Category menu.
3. Select Day, Week, Month, or Year from the Default View options.
4. Click Apply.
5. Click Cancel.

♦ To Change Access and Permissions

You can set access to your calendar, controlling what others can do in your calendar. To determine whether you have access to other calendars, see “To Determine Whether You Have Access to Other Calendars” on page 241.

♦ To Grant Access to Your Calendar

1. Choose Options from the File menu.
2. Choose Access List and Permissions from the Category menu.
   The Access List and Permissions dialog box is displayed.

   **Note** - Depending on the version of your calendar, your Access List and Permissions dialog box may look different than the one pictured in Figure 11-1. If so, go to Figure 11-2 on page 250 and follow the instructions after that figure.
3. In the User Name field, type calendar-name@hostname for the calendar to which you want to grant access.
   The default permission is for browse access only.

4. Select Browse, Insert, or Delete permissions.

   **Browse** The default – enables others to see information in your calendar

   **Insert** Others can add appointments or To Do items to your calendar

   **Delete** Others can delete appointments or To Do items from your calendar

5. Click Add Name to add the calendar to the Access list with the permissions you’ve chosen.

6. To erase your changes and leave the dialog box displayed, click Reset before clicking Apply.

   To save your changes and close the dialog box, click OK.

   To save your changes and leave the dialog box displayed, click Apply.
7. To erase your changes and close the dialog box, click Cancel. Saving your changes grants the selected access to the specified calendar.

If your Access List and Permissions dialog box resembles Figure 11-2, follow the instructions after the figure.

![Figure 11-2 Access List and Permissions dialog box – Version 2](image)

1. In the User Name field, type calendar-name@hostname for the calendar to which you want to grant access.
   
   The default permission is for view access to public appointments only.

2. Select View, Insert, or Change permissions.
   Permissions control whether others can perform specific operations on your calendar. You can choose more than one permission.

3. Select Public, Semiprivate, or Private access rights.
   Access rights control the specific types of appointments others can see.
Public Enables another calendar to display the time and text of your appointments marked Others See Time and Text.

Semiprivate Enables another calendar to display the time and text of your appointments marked Others See Time Only.

Private Enables another calendar to display the time and text of your appointments marked Others See Nothing.

4. Click Add to add the calendar to the Access list with the permission and access rights you’ve chosen.

5. To erase your changes and leave the dialog box displayed, click Reset before clicking Apply.
   To save your changes and close the dialog box, click OK.
   To save your changes and leave the dialog box displayed, click Apply.
   To erase your changes and close the dialog box, click Cancel.

Saving changes grants the selected access and permissions to the specified calendar.

♦ To Deny Access to Your Calendar

1. Choose Options from the File menu.

2. Choose Access List and Permissions from the Category menu.

3. Select the calendar for which you want to deny access in the Access list.

4. Click Remove Name (or Delete) to remove the user from the Access list.
   To erase your changes and leave the dialog box displayed, click Reset before clicking Apply.
   To save your changes and close the dialog box, click OK.
   To save your changes and leave the dialog box displayed, click Apply.
   To erase your changes and close the dialog box, click Cancel.

Saving changes removes access for the specified calendar.
To Change the Printer Settings for Future Print Jobs

To print a Calendar view or appointment or To Do list using the default printer settings, see “To Print Current Day, Week, Month, or Year Views” on page 238. To change the printer settings for future print jobs:

1. Choose Options from the File menu.
   The Options dialog box is displayed.
2. Choose Printer Settings from the Category menu.
   The Printer Settings dialog box is displayed.
3. Select Printer or File.
4. Type the name of your default printer.
5. Edit the Options field to specify print command-line options, if any.
   For example, to save paper, you may want to specify -o nobanner to suppress header pages.
6. Edit the page dimensions or position, if necessary.
7. Edit the number of units, if desired.
   For example, if you are printing Week view and you set Units to 2, you will print the current week and the next week.
8. Edit the number of copies if you want more than one.
9. Choose the desired privacy option for the information you want printed.
   See Step 7 of “To Change Appointment Editor Defaults” on page 246 for privacy options.
10. To erase your changes and leave the dialog box displayed, click Reset before clicking Apply.
    To save your changes and close the dialog box, click OK.
    To save your changes and leave the dialog box displayed, click Apply.
    To erase your changes and close the dialog box, click Cancel.
♦ To Change the Date Format

1. Choose Options from the File menu.
2. Choose Date Format from the Category menu.
   The default date format in Calendar is MM/DD/YY.
3. Choose the desired date order option.
4. Choose the desired date separator.
5. To erase your changes and leave the dialog box displayed, click Reset before clicking Apply.
   To save your changes and close the dialog box, click OK.
   To save your changes and leave the dialog box displayed, click Apply.
   To erase your changes and close the dialog box, click Cancel.

♦ To Change the Default Time Zone

You can set Calendar to view your or another calendar’s appointments in a time zone other than your local one.

1. Choose Time Zone from the View menu.
2. Choose the Custom Time setting.
3. In the Hours field, edit the number of hours before or after Greenwich Mean Time that you want your calendar set to.
   For example, to synchronize your calendar for Pacific Standard Time, choose GMT+8 hours. For Finland, choose GMT-2 hours. For Japan, choose GMT-9 hours. You may have to adjust by one hour for daylight, or summer, time.
4. To revert to your own time zone, click the My Time setting in the Time Zone dialog box.
5. Click OK to apply changes and close the dialog box.
Accessing Calendar through a Command-Line Interface

Calendar offers the capability to look up, insert, and delete appointments through a terminal emulator command-line interface.

dtcm_editor

Use the standalone Appointment Editor to create a Calendar-formatted appointment and save it in a file.

1. Type dtcm_editor filename at the command line.
   The standalone Appointment Editor is displayed.

2. Type a date in the Date field.
   Remember to use the date format set in the Date Format dialog box.

3. Choose the Start and End times for the appointment.

4. Type a description of the appointment in the What field.

5. Choose a frequency for the appointment from the Occurs menu.

6. Click Save to write the appointment contents to the file you specified on the command line.
dtcm_lookup

Use dtcm_lookup to view appointments on your calendar.

1. Type dtcm_lookup at the command line to view appointments for the default view. For example, if Day view is the default, to view appointments for the current day:

   system% dtcm_lookup
   Appointments for Monday October 31, 1994:
   1) Halloween
   2) 2:30pm-3:30pm Staff meeting
   3) 6:00pm Trick-or-treating
   4) 7:15pm-10:00pm Choir practice

2. To choose the calendar, date, or range of time for which to look up appointments, use the following syntax:

   dtcm_lookup [-c calendar] [-d date] [-v view]

   For example:

   system% dtcm_lookup -c hamilton@artist -d 10/28/94 -v day
   Appointments for Friday October 28, 1994:
   1) 9:00am-10:00am Project meeting
   2) 1:30pm-2:00pm Testing

dtcm_insert

Use dtcm_insert from the command line to insert appointments on your calendar. For example:

   system% dtcm_insert -d 11/1/94 -s 11:30am -e 12:30pm -w workout
   Appointments for Tuesday November 1, 1994:
   1) 10:00am-11:00am one-on-one
   2) 11:30am-12:30pm workout
   3) 12:30pm-1:00pm eat lunch

   dtcm (Calendar) automatically prints the appointments scheduled so you can see that the new appointment was inserted.
**dtcm_delete**

Use `dtcm_delete` from the command line to delete appointments from your calendar. For example:

```shell
system% dtcm_delete -d 11/1/94
```

Appointments for Tuesday November 1, 1994:
1) 10:00am-11:00am one-on-one
2) 11:30am-12:30pm workout
3) 12:30pm-1:00pm eat lunch

Item to delete (number)? 3

Appointments for Tuesday November 1, 1994:
1) 10:00am-11:00am one-on-one
2) 11:30am-12:30pm workout

When you don't want to delete any more items, press Control+C.

**dtcm**

Use `dtcm` to run Calendar from the command line. For example:

```shell
system% dtcm &
```
Using Terminal

A terminal emulator displays a window that allows you to enter operating system commands, use UNIX commands, and copy and paste text.

<table>
<thead>
<tr>
<th>Default Desktop Terminal Emulator</th>
<th>258</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting a Terminal Window</td>
<td>258</td>
</tr>
<tr>
<td>To Close a Terminal Window</td>
<td>261</td>
</tr>
<tr>
<td>Using a Terminal Window</td>
<td>261</td>
</tr>
<tr>
<td>Running dtterm on Another System</td>
<td>263</td>
</tr>
<tr>
<td>Customizing dtterm</td>
<td>265</td>
</tr>
<tr>
<td>dtterm Global Options</td>
<td>266</td>
</tr>
<tr>
<td>dtterm Terminal Options</td>
<td>271</td>
</tr>
<tr>
<td>Terminal Control Characters</td>
<td>277</td>
</tr>
<tr>
<td>Changing the Default Terminal Emulator</td>
<td>278</td>
</tr>
</tbody>
</table>

Note - Illustrations shown in this chapter were taken from the default CDE screens. Your screens may be different from the illustrations if you or your system administrator have customized them.
Default Desktop Terminal Emulator

The default terminal emulator on the desktop is dtterm. The dtterm terminal emulator emulates that portion of the VT220 terminal that is consistent with ANSI and ISO standards.

The dtterm command-line prompt is a special character that is displayed in the left margin of your terminal emulator. It can be a `'`, `'`, `$`, or another special character. A small box or bar, called a cursor, shows where characters will appear in the window when you type something on the keyboard.

![dtterm terminal window](image)

Starting a Terminal Window

There are several ways you can start a Terminal window:

- From the Front Panel
- From Application Manager
- From File Manager
- From the Window menu
- From an existing Terminal window
To Start a Terminal Window from the Front Panel

1. Click the arrow above the Text Editor control (or the control that appears as the second one to the left of the workspace switches) in the Front Panel.

2. Click the Terminal control in the Personal Applications subpanel.

The default Terminal window appears.

To Start a Terminal Window from Application Manager

1. Click the Application Manager control on the Front Panel.

2. Double-click Desktop_Apps to open the Desktop_Apps group.
3. Double-click the Terminal icon (you may have to scroll down to see it).

♦ To Start a Terminal Window from File Manager

1. Click the File Manager control on the Front Panel.

The File Manager window appears.

2. Choose Open Terminal from the File Manager File menu.
♦ To Start a Terminal Window from the Window Menu

◊ Choose New from the Window menu of an existing Terminal window.
   An exact replica of the Terminal window appears.

♦ To Close a Terminal Window

◊ Type `exit` at the command line and press Return.
   • Or, choose Exit from the Terminal Window menu.
   • Or, choose Close from the Window menu (displayed through the button at the upper left of the window frame).

Note - Typing `exit` at the command line is the preferred method of closing a Terminal window. The other two methods don't terminate any background processes you may have started, which can sometimes cause problems.

If you started the Terminal window from a command line, you can stop it by pressing Control+C in the window from which you started it.

Using a Terminal Window

The Terminal window provides a means to start other applications, enter UNIX commands, and copy and paste text between and within windows.

♦ To Start Applications in a Terminal Window

◊ Type the command to start the application at the command-line prompt.

   The general syntax for starting an application is:

   ```
   application [options] &
   application
   options
   ```

   The application name

   A list of optional information to be passed to the application
& Indicates that the application runs in the background; that is, you can continue to use the Terminal window while the application is also running.

Refer to the man page or other documentation for each application to find the command and options to use for that application.

**Example**
To start a digital clock from the command line, type
xclock -digital &

♦ **To Enter a Command**

◊ Type the command and press Return.

**Examples**
To obtain a list of the files in the current directory, type:
```
ls [Return]
```
To obtain a list of the files in the current directory and print it on the default printer, type:
```
ls | lp [Return]
```

♦ **To Copy and Paste Text**

1. Use mouse button 1 and drag over the text you want to move. The text appears highlighted.
2. Release mouse button 1 after all the text you want is highlighted. The highlighted text is copied to an internal clipboard where it is kept until another copy occurs. The text is not removed from your original source.
3. Click mouse button 2 where you want to insert the text. A copy of the contents of the clipboard is pasted at the location you indicated. You can make additional copies by repeating the above steps.
To Resize the Window Contents

When you change the size of a Terminal window, applications running in the window may not know about the resizing. Use this procedure to resize the application's output.

To resize the window contents, type the following at the command-line prompt:

```bash
eval `resize`
```

Note that `resize` is enclosed within a set of single close quotation marks rather than double quotation marks.

Running dtterm on Another System

You can run `dtterm` on another system through various commands:

- The `-display` option
- The `rlogin` command
- The `remsh` command

Using the `-display` Option

```bash
-dsplay host:display[.screen]
```

where

- `host`: The name of a valid system on the network.
- `display`: The number of the display on the host.
- `screen`: Optional. The screen within the display. The default is 0.

You can find these values by typing `env`, and examining the DISPLAY line. The terminal emulator is running on your system, but the window shows on another system.

Example

The following command starts a `dtterm` window on the host computer named `hpcvxdm`:

```bash
dtterm -display hpcvxdm:0 &
```
Using \texttt{rlogin}

You can use \texttt{rlogin} in an existing Terminal window to log in to a remote host. Once the window is acting as a terminal to the remote host, you can run applications there, redirecting the display back to your system if you desire.

For example, the following command logs onto a system named \texttt{there}, runs the client \texttt{xload}, and redirects the display back to your original system. Assume your system is named \texttt{here}.

\begin{verbatim}
  rlogin there
  xload -display here:0
\end{verbatim}

Using \texttt{remsh}

The \texttt{remsh} command starts a shell on a remote host, performs some client (often starting a terminal emulator on that host), and redirects the display back to your original system if desired.

It has the syntax:

\begin{verbatim}
  remsh remote -n client -display system:display[.screen]
\end{verbatim}

where:

remote \hspace{1cm} The remote host name

client \hspace{1cm} The program you want to run on the remote host

system:display[.screen] The host and display on which the results are to be displayed

The \texttt{remsh} command is often used when customizing a menu to access other hosts.

\textbf{Example}

The following command runs \texttt{xload} on the remote host named \texttt{there}, and directs output back to your system, \texttt{here}.

\begin{verbatim}
  remsh there -n /usr/bin/X11/xload -display here:0.0 &
\end{verbatim}
Customizing dtterm

There are several ways in which you can customize dtterm:

• Run it with special options, such as the menu bar and scroll bar
• Run the terminal emulator on another system
• Change global options such as cursor style and background color
• Change terminal options such as keyboard and screen control

Displaying the Menu Bar

By default, dtterm appears with a menu bar. You can remove it if you wish.

♦ To Remove the Menu Bar

◊ Choose Menu Bar from the Options menu.

The menu bar disappears from the dtterm window.

♦ To Restore the Menu Bar

1. Click mouse button 3 anywhere within the dtterm window.

A pop-up menu appears containing items identical to those of the menu bar.
2. Choose Menu Bar from the Options menu.
   The menu bar appears at the top of the dtterm window.

**Displaying the Scroll Bar**

By default, dtterm appears without a scroll bar.

♦ **To Display the Scroll Bar**

◊ Choose Scroll Bar from the Options menu.
   The scroll bar appears in the dtterm window.

   To remove the scroll bar from the window, choose Scroll Bar from the Options menu again.

**dtterm Global Options**

There are four areas that you can control from the Global Options dialog box:

- Cursor control
- Color control
- Scroll behavior
- Bell control

◊ To display the Global Options dialog box, choose Global from the Options menu.
Cursor Control

You can control three aspects of the dtterm cursor:

• Cursor style
• Blinking cursor
• Blink rate

♦ To Determine Cursor Style

1. If the Global Options dialog box is not displayed, choose Global from the Options menu.

2. Click the Cursor Style button and choose the cursor style option you want:
   • Box (the default)
   • Underline
• None (the cursor is invisible)

3. Click OK at the bottom of the Global Options dialog box or press Return to save your selection and exit the window.

   To save your selection and retain the window, click Apply.

The changes you make will be visible on existing dtterm windows; you don’t have to start a new one.

♦ To Determine Cursor Blinking

   The dtterm cursor blinks by default. You can turn off the blinking or change the blink rate (see “To Set the Cursor Blink Rate”).

1. If the Global Options dialog box is not displayed, choose Global from the Options menu.

2. Click the Blinking Cursor button in the Cursor Control section and choose to either have the cursor blink (Enabled) or not blink (Disabled).

3. Click OK at the bottom of the Global Options dialog box or press Return to save your selection and exit the window.

   To save your selection and retain the window, click Apply.

   Note that when this option is set to Disabled, the Blink Rate option and text field are both inactive and appear dimmed.

♦ To Set the Cursor Blink Rate

   The blink rate determines how often the dtterm window’s cursor blinks. The default blink rate is 250 milliseconds. To change the cursor blink rate:

1. If the Global Options dialog box is not displayed, choose Global from the Options menu.

2. In the Blink Rate text field, type the value in milliseconds you want.

3. Click OK at the bottom of the Global Options dialog box or press Return to save your selection and exit the window.

   To save your selection and retain the window, click Apply.
The changes you make will be visible on existing *dtterm* windows; you don't have to start a new one.

♦ **To Switch Foreground and Background Colors (Color Control)**

1. If the Global Options dialog box is not displayed, choose Global from the Options menu.

2. Click the Window Background button in the Color Control section and choose the color display you want:
   - Normal displays the foreground and background colors normally.
   - Inverse switches the foreground and background colors.

3. Click OK at the bottom of the Global Options dialog box or press Return to save your selection and exit the window.

   To save your selection and retain the window, click Apply.

♦ **To Determine Scroll Behavior**

Smooth scrolling displays each line sent to the Terminal window immediately, rather than storing it in a buffer. This results in scrolling that is more pleasing to the eye, but is slower. The default is smooth scrolling disabled. To enable smooth scrolling:

1. If the Global Options dialog box is not displayed, choose Global from the Options menu.

2. Click the Smooth Scrolling button and choose the type of scrolling you want:
   - Disabled (the default) disables smooth scrolling.
   - Enabled starts smooth scrolling.

3. Click OK at the bottom of the Global Options dialog box or press Return to save your selection and exit the window.

   To save your selection and retain the window, click Apply.
Bell Control

There are three types of Bell Control options in dtterm:

- Bell type
- Margin warning
- Margin distance

❖ To Set the Bell Type

1. If the Global Options dialog box is not displayed, choose Global from the Options menu.

2. Click the Bell Type button in the Bell Control section and choose the type of bell you want:
   - Audible (the default) causes the bell to make a sound.
   - Visible causes the bell to blink the background color.

3. Click OK at the bottom of the Global Options dialog box or press Return to save your selection and exit the window.

   To save your selection and retain the window, click Apply.

❖ To Set the Margin Warning

The Margin Warning option is used in conjunction with the Margin Distance option to warn the user either visually or aurally that the cursor is within a specified distance from the right margin. To set the margin warning:

1. If the Global Options dialog box is not displayed, choose Global from the Options menu.

2. Click the Margin Warning button in the Bell Control section.

3. Choose Enabled or Disabled.

4. Click OK at the bottom of the Global Options dialog box or press Return to save your selection and exit the window.

   To save your selection and retain the window, click Apply.

Note that the Margin Distance option (see “To Set the Margin Distance”) is inactive when Margin Warning is disabled.
♦ To Set the Margin Distance

The Margin Distance option is only active when the Margin Warning option is set to Enabled. You set the distance from the right margin of the *dtterm* window at which you want the bell to ring (or appear, if Bell Type is set to Visible). The default value is 10 characters.

To change the distance:

1. If the Global Options dialog box is not displayed, choose Global from the Options menu.
2. Click inside the Margin Distance text field in the Bell Control area and type the number of characters from the right margin of the window at which you want the margin warning to be issued.
3. Click OK at the bottom of the Global Options dialog box or press Return to save your selection and exit the window.

   To save your selection and retain the window, click Apply.

The changes you make will be visible on existing *dtterm* windows; you don’t have to start a new one.

*dtterm* Terminal Options

There are two areas that you can control from the Terminal Options dialog box:

- Keyboard control
- Screen control

♦ To display the Terminal Options dialog box, choose Terminal from the Options menu.
Changes you make through the Terminal Options dialog box are effective on existing dtterm windows; you don't have to start a new one.

**Keyboard Control**

You can control four aspects of your keyboard through the Terminal Options dialog box:

- Cursor key mode
- Keypad mode
- Newline sequence
- User function keys
♦ **To Set the Cursor Key Mode**

1. If the Terminal Options dialog box is not displayed, choose Terminal from the Options menu.

2. Click the Cursor Key Mode button in the Keyboard Control section and choose the mode you want:
   - In Normal mode (the default), the cursor keys move the cursor in the specified direction.
   - In Application mode, the cursor keys generate escape sequences that the application uses for its own purpose.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save your selection and exit the window.
   To save your selection and retain the window, click Apply.

♦ **To Set the Keypad Mode**

The keypad mode determines the behavior of keys on the numeric keypad.

1. If the Terminal Options dialog box is not displayed, choose Terminal from the Options menu.

2. Click the Keypad Mode button in the Keyboard Control section and choose the mode you want:
   - In Numeric mode, when keys on the numeric keypad are pressed, the corresponding numeral is displayed in the dtterm window.
   - In Application mode, keys pressed on the numeric keypad generate escape sequences that the application uses for its own purpose.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save your selection and exit the window.
   To save your selection and retain the window, click Apply.
To Determine the Newline Sequence

The Newline Sequence option determines how carriage returns at the ends of lines are treated.

1. If the Terminal Options dialog box is not displayed, choose Terminal from the Options menu.

2. Click the Newline Sequence button in the Keyboard Control section and choose the mode you want:
   - Return Only (the default) generates only a carriage return.
   - Return/Line Feed generates both a carriage return and a line feed.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save your selection and exit the window.
   To save your selection and retain the window, click Apply.

To Set the User Function Keys

The User Function Keys option either locks or unlocks (the default) the user function keys.

1. If the Terminal Options dialog box is not displayed, choose Terminal from the Options menu.

2. Click the User Function Keys button in the Keyboard Control section and choose Locked or Unlocked (the default).

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save your selection and exit the window.
   To save your selection and retain the window, click Apply.
**Screen Control**

There are three aspects of screen control in a *dtterm* window:

- 132 column switching
- End-of-line wrapping
- Reverse end-of-line-wrapping

♦ **To Set 132 Column Switching**

This option corresponds to the following *dtterm* command-line options and resource:

- `-132`
- `+132`
- `c132`

1. If the Terminal Options dialog box is not displayed, choose Terminal from the Options menu.

2. Click the 132 Column Switching button in the Keyboard Control section and choose the mode you want:
   - Disabled (the default) does not change the display when an application switches to 132 columns.
   - Enabled automatically enlarges the *dtterm* window to display 132 columns when the application switches to 132 columns.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save your selection and exit the window.

To save your selection and retain the window, click Apply.

♦ **To Set End-of-Line Wrapping**

This option determines whether text wraps at the end of a line. It corresponds to the following *dtterm* command-line options and resource:

- `-aw`
- `+aw`
- `autoWrap`
1. If the Terminal Options dialog box is not displayed, choose Terminal from the Options menu.

2. Click the End-of-Line Wrapping button in the Keyboard Control section and choose the mode you want:
   - Enabled means characters automatically wrap to the next line when the end-of-line is reached.
   - Disabled means text does not wrap.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save your selection and exit the window.
   To save your selection and retain the window, click Apply.

♦ To Set Reverse End-of-Line Wrapping

This option determines the behavior of backspacing at the end of a line. It corresponds to the following \texttt{dtterm} command-line options and resource:

- \texttt{-rw}
- \texttt{+rw}
- \texttt{reverseWrap}

1. If the Terminal Options dialog box is not displayed, choose Terminal from the Options menu.

2. Click the Reverse End-of-Line Wrapping button in the Keyboard Control section and choose the mode you want:
   - Enabled means backspace characters automatically wrap to the next higher line when the end-of-line is reached.
   - Disabled (the default) means no wrapping occurs.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save your selection and exit the window.
   To save your selection and retain the window, click Apply.
Terminal Control Characters

Because `dtterm` only emulates a terminal, your control characters might not be what you are used to on a physical terminal. The `ttyModes` resource enables you to set control characters for your terminal emulator.

By default, Login Manager sets the control characters listed in Table 12-1.

<table>
<thead>
<tr>
<th>Control Name</th>
<th>Character</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>erase</td>
<td>Control+H</td>
<td>Backspace erases characters</td>
</tr>
<tr>
<td>intr</td>
<td>Control+C</td>
<td>Interrupt: Cancel the current operation and re-display the command-line prompt.</td>
</tr>
<tr>
<td>kill</td>
<td>Control+U</td>
<td>Stop an operation or application.</td>
</tr>
<tr>
<td>start</td>
<td>Control+Q</td>
<td>Accept keyboard input: Used to continue an application that has been paused.</td>
</tr>
<tr>
<td>stop</td>
<td>Control+S</td>
<td>Do not accept keyboard input: Used to pause an application.</td>
</tr>
<tr>
<td>swtch</td>
<td>Control+@</td>
<td>Switch between layers in a shell.</td>
</tr>
</tbody>
</table>

For example, to interrupt an operation in progress, you press Control+C.

The syntax for the `ttyModes` resource is:

```plaintext
ttyModes:  Control+C name
```

where name is the control, and C is the character. (^ is another way of expressing Control.) For example, the default value of `ttyModes` describing the preceding list is:

```plaintext
ttyModes: erase ^H intr ^C kill ^U start ^Q stop ^S swtch ^@ |
```

To Set Terminal Control Characters

1. Use the EditResources action to update the `ttyModes` resource.
2. Choose Restart Workspace Manager from the Workspace menu.
Changing the Default Terminal Emulator

There are several other terminal emulators you can use in addition to dtterm. You can start most of them from an existing terminal emulator command line; however, if you want to consistently use a terminal emulator other than dtterm, you should change the default assignment. See the "CDE Advanced User's and System Administrator's Guide." for more information.
Icon Editor is a tool for creating both bitmap and pixmap image files for use as icons or backdrops.

<table>
<thead>
<tr>
<th>Basic Drawing Tasks</th>
<th>282</th>
</tr>
</thead>
<tbody>
<tr>
<td>Saving Icon Files</td>
<td>285</td>
</tr>
<tr>
<td>Color Usage</td>
<td>287</td>
</tr>
<tr>
<td>Advanced Drawing Tasks</td>
<td>288</td>
</tr>
</tbody>
</table>

Icon Editor enables you to create and edit images in two formats:

Table 13-Icon Formats

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
<th>File Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>X pixmap (XPM)</td>
<td>Multicolor images that include static and dynamic colors</td>
<td>* .pm</td>
</tr>
<tr>
<td>X bitmap (XBM)</td>
<td>Two-color images limited to a foreground and background color (used for black and white icons)</td>
<td>* .bm</td>
</tr>
</tbody>
</table>
You create images by selecting drawing tools and colors, and using them in the work area. As you draw, Icon Editor displays an actual-size copy of your icon in both formats. You need to consider the two-color version of the icon even if you are drawing an image for use on color systems, because icons may revert to two colors if there are not enough free colors available on the workspace.

For information on designing icons, read the Visual Design chapter in the CDE Style Guide and Certification Checklist."
To Start Icon Editor

◊ Open the Personal Applications subpanel and click the Icon Editor control.

Icon Editor starts with an empty drawing work area.

Other Ways to Start Icon Editor

You can also start Icon Editor and have it load an icon into the work area in one of the following ways:

• In a File Manager view, locate the icon file and double-click on it to open it. (The default action for pixmap and bitmap files runs Icon Editor and loads the file.)

• Drop an icon file on the Icon Editor control in the Personal Applications subpanel.

• Click the Application Manager control in the Front Panel, then open Desktop_Apps and double-click on Icon Editor.

• Type the following command in a Terminal window:

```
dticon -f filename &
```
Basic Drawing Tasks

This section describes how to create and edit an icon and how to use the Icon Editor drawing tools.

♦ To Open an Existing Icon

1. Choose Open from the File menu.
   
   If you have unsaved changes, Icon Editor warns you that your changes will be lost by loading another icon. Click Cancel to cancel the Open command. Click OK if you don’t want to save your changes.

2. Type the name of the file you want to load in the Enter file name field, or select the icon file you want to load from the Files section of the Open File dialog box.

3. Click Save.

   **Note** - When you load a file, the Output Format (in the Options menu) is automatically set to the format of the file you load.

You can also open an existing icon by double-clicking the icon file in File Manager.

♦ To Start a New Icon

◊ Choose New from the File menu.

   If you have unsaved changes, Icon Editor warns you that your changes will be lost by starting a new icon. Click Cancel to cancel the New command or click OK if you don’t want to save your changes.

   Icon Editor clears the work area and resizes it to the default size (32x32).

   If you have an icon already loaded, you can choose Clear Icon from the Edit menu to start a new icon with the same size and name as the previously loaded icon.
♦ **To Clear an Icon**

1. Save your current icon, if necessary.
2. Choose Clear Icon from the Edit menu.
   The entire icon drawing work area is cleared.

♦ **To Draw an Image**

1. Select one of the drawing tools (listed in Table 13-2 on page 284).
2. Select a color (static color, static gray, or a dynamic color).
3. Begin drawing with the tool you've selected.
   More details on drawing with each tool are provided below.

**Drawing Tools**

The drawing tools area of Icon Editor is shown in Figure 13-2.

![Icon Editor drawing tools](image)

Figure 13-2 Icon Editor drawing tools
## Table 13-2 Using the Drawing Tools

<table>
<thead>
<tr>
<th>Tool</th>
<th>Purpose</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pencil</td>
<td>For drawing freehand lines and individual pixels.</td>
<td>Press and hold to draw freehand lines.</td>
</tr>
<tr>
<td>Line</td>
<td>For drawing straight lines.</td>
<td>Press and hold to stretch the line. Release to draw the line.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>For drawing solid or outlined rectangles.</td>
<td>Press and hold to stretch the outline of the rectangle. Release to draw the rectangle.</td>
</tr>
<tr>
<td>Circle</td>
<td>For drawing solid or outlined circles.</td>
<td>Point to where you want the center of the circle, press and hold, drag to the desired size, and release.</td>
</tr>
<tr>
<td>Eraser</td>
<td>For erasing large areas of the image.</td>
<td>Press and hold; then drag over the area to erase. To erase individual pixels, select the Pencil tool and the Transparent color.</td>
</tr>
<tr>
<td>Flood</td>
<td>For flooding a region of one color with the selected color.</td>
<td>Click any pixel within the region to be flooded. The selected pixel and all adjacent pixels of the same color are recolored with the selected color. The filled region extends in all directions, bounded only by pixels of a different color.</td>
</tr>
<tr>
<td>Open Polygon</td>
<td>For drawing connected straight lines.</td>
<td>Click the starting point; then click for each segment. Double-click to end the last segment.</td>
</tr>
<tr>
<td>Closed Polygon</td>
<td>For drawing connected straight lines, where the first line and last line are connected to form a closed polygon.</td>
<td>Click the starting point; then click for each segment. Double-click to end the last segment.</td>
</tr>
<tr>
<td>Ellipse</td>
<td>For drawing solid or outlined ovals.</td>
<td>Press and hold, drag to the desired size and shape, and release.</td>
</tr>
</tbody>
</table>
To Undo a Drawing Operation

◊ Choose Undo from the Edit menu.

Only the single, most recent change can be undone.

Saving Icon Files

When saving icon files, you must use the appropriate file-name suffix. There are two suffixes appended to the base name of the icon, one for size and one for format. Many icon names are in these general forms:

```plaintext
basename.size.format
basename.format
```

The basename is the image name used to reference the image.

Size is a single letter indicating the standard size of the icon: l for large (48x48 pixels), m for medium (32x32), s for small (24x24), or t for tiny (16x16). (See “Icon Size Conventions” on page 286.) If your icon is not a standard size, you can omit this letter.

Format is pm for X pixmaps (the color icon format) or bm for X bitmaps (the monochrome icon format).

If you save an icon in XBM format that has transparent color in it, an icon mask file is also saved. The icon mask file is named basenamem.size_m.format. If you move the icon you saved to another folder, you must also move the mask file.
For example, suppose you specify an icon named `mail` for a file type you’ve written. If you have a color display and have set the File Manager preferences to use tiny icons, the assumed icon name is `mail.t.pm`. If it had transparent color and you saved it in XBM format, two files would be created: `mail.t.bm` and `mail.t_m.bm`.

**Icon Size Conventions**

Table 13-3 lists the recommended sizes—in pixels, width x height—for creating new icons for use in CDE. Icons can be up to 256x256.

Table 13-3 Icon Size Recommendations

<table>
<thead>
<tr>
<th>Resolution</th>
<th>High</th>
<th>Medium</th>
<th>Low</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Manager (Large)</td>
<td>32x32</td>
<td>32x32</td>
<td>32x32</td>
</tr>
<tr>
<td>File Manager (Small)</td>
<td>16x16</td>
<td>16x16</td>
<td>16x16</td>
</tr>
<tr>
<td>Application Manager (Large)</td>
<td>32x32</td>
<td>32x32</td>
<td>32x32</td>
</tr>
<tr>
<td>Application Manager (Small)</td>
<td>16x16</td>
<td>16x16</td>
<td>16x16</td>
</tr>
<tr>
<td>Front Panel</td>
<td>48x48</td>
<td>48x48</td>
<td>32x32</td>
</tr>
<tr>
<td>Front Panel subpanels</td>
<td>32x32</td>
<td>32x32</td>
<td>16x16</td>
</tr>
<tr>
<td>Minimized windows</td>
<td>48x48</td>
<td>48x48</td>
<td>32x32</td>
</tr>
<tr>
<td>Workspace</td>
<td>32x32</td>
<td>32x32</td>
<td>32x32</td>
</tr>
</tbody>
</table>

♦ **To Save the Icon**

1. Choose an output format from the Options menu:
   - XBM for two-color X bitmap format
   - XPM for multicolor X pixmap format (the default)

2. Choose Save from the File menu.

   If the icon is unnamed or you choose Save As, Icon Editor prompts you for a file name. Type the name and then click Save.

**Note** - If you save an icon in XBM format that has transparent color in it, an icon mask file is also saved. The icon mask file is named `basename.size_m.format`. If you move the icon you saved to another folder, you must also move the mask file.
♦ **To Save the Icon with a New Name**

1. Choose Save As from the File menu.
2. Type (or select) the file name under which you want to save the icon file.
3. Click Save.

   If the file already exists, you will need to click OK in the warning dialog box to overwrite the existing file.

**Color Usage**

Icons in the desktop use a palette of 22 colors:

- Eight static grays
- Eight static colors: red, blue, green, cyan, magenta, yellow, black, and white
- Five dynamic colors: Foreground, Background, TopShadow, BottomShadow, and Select
- A transparent “color” that allows the background to show through

These colors are the default colors in Icon Editor. This set of colors provides a reasonable palette with which to create icons. This limited palette was chosen to maximize the attractiveness and readability of icons without using an unnecessary number of colors.

The dynamic colors represent the colors used to display the application on which your icon will appear. If your icon appears in File Manager, File Manager determines what the background color is. Dynamic colors are useful for icons that you want to change color as different color palettes are selected in Style Manager. Dynamic colors are also useful if the icon will be used in more than one place and you want it to use the colors of the application where it appears.

TopShadow and BottomShadow can be used for drawing a shadow under your icon. You can use these colors to make the icon appear to be etched into the surface. This is only recommended for Front Panel style icons.
The transparent color is useful for creating icons that have the illusion of being nonrectangular, since it allows the color behind the icon to show through. If your icon does not fill the entire bounding box, you should fill the unused area with the transparent color.

**Advanced Drawing Tasks**

After you become familiar with the basic drawing facilities in Icon Editor, you may want to try some more advanced operations. Many of these operations require you to first select an area of the icon. This is done using the Selection tool (next to the eraser).

When an area of the icon is selected, you can:

- Cut, copy or move it
- Resize (scale) it
- Flip it (horizontally or vertically)
- Rotate it (right or left)

♦ **To Select an Area of the Icon**

1. Click the Selection tool (next to the eraser).
2. Drag a box around the area you want to select.

   When an area is selected, a box flashes around the selected area.

♦ **To Cut a Region of the Icon**

1. Select the area of the icon you want to cut using the Selection tool.
2. Choose Cut from the Edit menu.

   When you cut a portion of an icon, the exposed area becomes transparent (that is, filled in with the Transparent color).

   Note that after cutting a region, you can paste it back into the icon by choosing Paste from the Edit menu.

♦ **To Copy a Region of the Icon**

1. Select the area of the icon you want to copy using the Selection tool.
2. Choose Copy from the Edit menu.
3. Choose Paste from the Edit menu.
4. Position the outline where you want to paste the copy, and then click.
   You may repeat steps 3 and 4 as many times as you like to paste multiple copies of the region you copied.

♦ **To Move a Region of the Icon**

1. Select the area of the icon you want to move using the Selection tool.
2. Choose Cut from the Edit menu.
3. Choose Paste from the Edit menu.
4. Position the outline where you want to paste the copy, and then click.
   You may repeat steps 3 and 4 as many times as you like to paste multiple copies of the region you cut.

♦ **To Rotate Part of the Icon**

1. Select the area of the icon you want to rotate using the Selection tool.
2. Choose Rotate then Left or Rotate then Right from the Edit menu.
3. Position the outline where you want to paste the rotated area, and then click.

♦ **To Flip (Mirror) Part of the Icon**

Flipping an area creates a pixel-for-pixel mirror image of the selected area.
1. Select the area of the icon you want to flip using the Selection tool.
2. Choose Flip then Vertical or Flip then Horizontal from the Edit menu.
Resizing Icons

You can resize the entire icon or a region of the icon.

♦ To Resize the Current Icon

1. Choose Resize Icon from the Edit menu.
   Icon Editor displays a dialog box that prompts for the new size.
2. Edit the current width and height to specify the new size.
3. Click OK.

Note – If you make the icon smaller, the right and bottom edges are clipped off. If you make the icon larger, the existing image remains in the upper left of the icon.

♦ To Resize (Scale) a Region of the Icon

1. Select the area of the icon you want to resize using the Selection tool.
2. Choose Scale from the Edit menu.
3. Drag a box that defines the size and shape that you want the scaled image to be.
   The size of the box is shown in the upper right area. This determines how the selected portion of the image will be scaled; it does not determine where to place the results.
4. Position the outline where you want to paste the scaled copy, and then click.

Hotspots

Bitmap images (XBM format) can be used as special mouse pointer shapes. A hotspot marks a single pixel within the image that is the true point of the mouse pointer.
♦ To Add a Hotspot

You can only have one hotspot in an icon.
1. Choose Add Hotspot from the Edit menu.
2. Click the pixel where you want the hotspot.

♦ To Delete a Hotspot

◊ Choose Delete Hotspot from the Edit menu.

Screen Captures

You can copy any area from any part of the screen into the Icon Editor. You can copy ("grab") a text or graphic that is displayed and load it into the Icon Editor work area.

♦ To Capture (Grab) a Region of the Display

1. Save your current icon, if necessary.
2. Choose Grab Screen Image from the Edit menu.
3. Drag a box around the portion of the workspace you want to capture (press mouse button 1, drag, and release).

Note - Capturing a region of the display could cause the icon to use up some of the available colors on the desktop.
Modifying the View of an Icon

You can change the view of an icon in the Icon Editor work area by changing the magnification or using a grid.

♦ To Hide the Grid
◊ Choose Visible Grid from the Options menu.

This will hide the grid. Choose Visible Grid from the Options menu again to display the grid. The grid is displayed by default.

♦ To Change the Magnification of an Icon

1. Choose Magnification from the Options menu.
2. Choose the Magnification level you want from the submenu.
Keyboard Shortcuts for the Desktop

This appendix describes keyboard alternatives to using your mouse.

<table>
<thead>
<tr>
<th>Menu Shortcuts</th>
<th>294</th>
</tr>
</thead>
<tbody>
<tr>
<td>Moving the Keyboard Focus</td>
<td>295</td>
</tr>
<tr>
<td>Opening and Closing Windows</td>
<td>296</td>
</tr>
<tr>
<td>Online Help Keyboard Navigation</td>
<td>302</td>
</tr>
</tbody>
</table>

Keyboard shortcuts offer a way to accomplish desktop tasks such as moving and selecting windows and controls, choosing menus, and navigating in workspaces without the use of your mouse.

When you use the keyboard to navigate on the desktop, note that:

- The Alt key is the same as the Extend char key on some keyboards.
- Return is the same as Enter on some keyboards.
- In Style Manager, the Window Behavior setting must be Click In Window To Make Active (this is the default).

For more information on the Window Behavior setting, refer to Chapter 7, “Customizing the Desktop Environment.”
Menu Shortcuts

Menu items that appear dimmed are unavailable. They are available only under certain conditions.

An underlined character in a menu name or item is called a mnemonic. The sequence of keys listed to the right of some menu items is called a shortcut key.

Mnemonics and shortcut keys provide quick keyboard access to menu items.

To choose an item from a pull-down menu using the menu’s mnemonics:

1. Hold down Alt and press the underlined letter in the menu’s name.
2. Press the underlined letter in the menu item’s name.

Keyboard Focus and the Highlight

Keyboard focus uses the highlight to show you which element of a window, menu, or control will respond to your input. To activate a selected menu item or control (such as a button), press the Spacebar.

In windows and dialog boxes, you can move the keyboard focus among tab groups. A tab group is a collection of related controls, such as a set of buttons.

This portion of a dialog box shows the keyboard focus on the OK button.
## Moving the Keyboard Focus

To move the keyboard focus, as shown by the highlight:

### Within a Window, Dialog Box, or the Front Panel

<table>
<thead>
<tr>
<th>Press</th>
<th>To move to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab</td>
<td>The next tab group</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>The previous tab group</td>
</tr>
<tr>
<td>Down Arrow</td>
<td>The next control in the tab group</td>
</tr>
<tr>
<td>Up Arrow</td>
<td>The previous control in a tab group</td>
</tr>
<tr>
<td>F10</td>
<td>The window’s menu bar—use the arrow keys to display menus and move among their items</td>
</tr>
<tr>
<td>Shift+F10</td>
<td>The selected object’s pop-up menu—use the arrow keys to move among the menu’s items</td>
</tr>
<tr>
<td>Alt+Spacebar</td>
<td>The Window menu</td>
</tr>
</tbody>
</table>

### Within a Workspace

<table>
<thead>
<tr>
<th>Press</th>
<th>To move to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+Tab or Alt+Esc</td>
<td>The next window or icon</td>
</tr>
<tr>
<td>Shift+Alt+Tab</td>
<td>The previous window or icon</td>
</tr>
<tr>
<td>Alt+Up Arrow</td>
<td>The bottom window in a stack of windows (bringing it forward)</td>
</tr>
<tr>
<td>Alt+Down Arrow</td>
<td>The bottom of the window stack</td>
</tr>
<tr>
<td>Alt+F6</td>
<td>The next window belonging to an application, or between the Front Panel and a subpanel</td>
</tr>
<tr>
<td>Shift+Alt+F6</td>
<td>The previous window belonging to an application, or between the Front Panel and a subpanel</td>
</tr>
</tbody>
</table>

### Within a Menu

<table>
<thead>
<tr>
<th>Press</th>
<th>To move to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Down Arrow</td>
<td>The next menu item</td>
</tr>
</tbody>
</table>
Up Arrow The previous menu item
Press the Spacebar to choose a selected item from within a menu.
Press Esc to dismiss a menu.

Opening and Closing Windows

♦ To Open an Application Window

From the Front Panel:
1. Press Alt+Tab to move the keyboard focus to the Front Panel.
2. Press the arrow keys to move the highlight within the Front Panel and select a control.
3. Press Return or the Spacebar to choose the control and open the application's window.

From Application Manager:
1. Open the Application Manager window by choosing its Front Panel control as described above.
2. Press the arrow keys to move the highlight to an application group icon within the Application Manager window.
3. Press Return twice to open the application group.
4. Press the arrow keys to move the highlight to an application or action icon, then press Return twice to start the application.

From a terminal emulator window:
1. Open a terminal emulator window by choosing its Front Panel control as described above.
2. When the window opens, type the command that starts the application.

♦ To Close an Application Window

Closing a window removes it from all workspaces.
Caution - Before closing an application window, save your work.

1. Press Alt+Tab to move the highlight to the window you want to close.

♦ To Select a Window or Icon

◊ Press Alt+Tab to move the highlight to the window or icon you want to select.

When a window or icon is selected, its border changes color to show that it is active and will receive input from the mouse or keyboard.

♦ To Turn a Window into an Icon (Minimize)

1. Press Alt+Tab to move the highlight to the window you want to minimize.
2. Press Alt+Spacebar to display the Window menu.
3. Choose the Minimize item:
   - Press Down Arrow until you select Minimize, then press Return.
   - Or, press N, the menu’s mnemonic for Minimize.

♦ To Restore a Window from an Icon

1. Press Alt+Tab to move the highlight to the icon you want to restore.
2. Press Alt+Spacebar to display the Window menu.
3. Press Down Arrow to choose Restore, then press Return.
To Move a Window or Window Icon

1. Press Alt+Tab to move the highlight to the window or icon you want to move.
2. Press Alt+Spacebar to display the Window menu.
3. Press M, the menu’s mnemonic for Move.
4. Press the arrow keys to relocate the window or icon.
   Hold down Control while you press an arrow key to speed up the movement of the window or icon.
5. When you’ve moved the window or icon where you want it, press Return.
   To cancel the move operation, press Esc.

To Resize a Window

1. Press Alt+Tab to move the highlight to the window you want to resize.
2. Press Alt+Spacebar to display the Window menu.
3. Press S, the menu’s mnemonic for Size.
4. Press the arrow keys to stretch or shrink the window. An outline appears to show you the window’s size.
   Hold down Control while you press an arrow key to size the window faster.
5. When the outline shows the size you want, press Return.
   To cancel the resize operation, press Esc.

To Scroll a Window’s Contents

1. Press Alt+Tab to move the keyboard focus, as shown by the highlight, to the window whose contents you want to scroll.
2. Press Tab to move to the window area you want to scroll.
3. Press the arrow keys, Prev and Next, or Page Up and Page Down.
Hold down Control while you press an arrow key to scroll faster.

♦ To Select a List Item

Some windows and dialog boxes display lists from which you select options or settings.

1. Press Tab to move the highlight to the list.
2. Press the arrow keys to move through the list.

To select more than one contiguous item in lists that allow you to do so, press Shift+Down Arrow or Shift+Up Arrow.

3. Press Tab to move the highlight to the appropriate button (such as OK), then press Return.

♦ To Display a Pull-down Menu

To display a pull-down menu from a window's menu bar:

1. Press Alt+Tab to move the highlight to the application window.
2. Press F10 to move the highlight to the name of the first menu in the menu bar, then use the arrow keys to display menus and move among their items.
3. Press Return to choose a highlighted item.

To dismiss a menu without choosing an item, press Esc.

♦ To Use a Pop-up Menu

With the keyboard focus on the component whose pop-up menu you want to display:

1. Press Shift+F10 to display the pop-up menu.
2. Choose a menu item:
   - Press the Down Arrow key to move through the menu, highlight the item you want, then press Return.
   - Or, type the underlined letter in the menu item’s name (its mnemonic).
• Or, type the shortcut key, as listed to the right of the item’s name.

♦ To Use the Window Menu

1. Press Alt+Tab or Alt+Esc to move the keyboard focus, as shown by the highlight, to the window or icon.
2. Press Alt+Spacebar to display the Window menu.
3. Press the key for the menu item’s mnemonic (the underlined character in the item’s name).

To close the menu without choosing an item, press Esc.

♦ To Switch to Another Workspace

1. Press Alt+Tab until you’ve placed the keyboard focus, as shown by the highlight, on the Front Panel.
2. Press the arrow keys to move the highlight to the button for the workspace you want to display.
3. Press Return or the Spacebar.

♦ To Rename a Workspace

1. Press Alt+Tab until you’ve placed the keyboard focus, as shown by the highlight, on the Front Panel.
2. Press the arrow keys to move the highlight to the button for the workspace you want to rename.
3. Press Shift+F10 to display the workspace button’s pop-up menu.
4. Press the Down Arrow key to select Rename, then press Return. The button becomes a text field.
5. Edit the workspace’s name in the text field.
6. Once you’ve renamed the workspace, press Return.
♦ To Move among Windows

To move to the next window or icon, press Alt+Tab or Alt+Esc.

To move to the previous window or icon, press Shift+Alt+Tab or Shift+Alt+Esc.

To shuffle through a stack of windows, press Alt+Up Arrow or Alt+Down Arrow.

To move between the windows belonging to an application, or the Front Panel and a subpanel, press Alt+F6 or Shift+Alt+F6.

♦ To Display a Window in Other Workspaces

1. Press Alt+Tab to move the keyboard focus, as shown by the highlight, to the window you want to display in other workspaces.

2. Display the Window menu by pressing Alt+Spacebar.

3. Press the Down Arrow key to select Occupy Workspace, then press Return.

The Occupy Workspace dialog box appears.

4. Press Tab until the keyboard focus is in the Workspaces list.

5. Select the workspaces in which you want the window to appear:
   - Press Down Arrow or Up Arrow to move through the list.
   - To select more than one workspace, press Shift+Down Arrow or Shift+Up Arrow.

6. Press Tab to move the keyboard focus to OK, then press Return or the Spacebar.

♦ To Choose a Front Panel Control

1. Press Alt+Tab to move the keyboard focus to the Front Panel.

2. Press the arrow keys to move the highlight within the Front Panel and select a control.

3. Press Return or the Spacebar to choose the control and open the application’s window.
♦ **To Choose a Subpanel Control**

1. Press Alt+Tab to move the keyboard focus to the Front Panel.

2. Press the arrow keys to move the highlight within the Front Panel to one of the subpanel arrow controls, then press Return.

3. Press the arrow keys to move the highlight among the controls within the subpanel, then press Return or the Spacebar to choose a selected control.

   To close the subpanel without choosing a control, press Esc.

♦ **To Move the Front Panel**

1. Press Alt+Tab to move the keyboard focus to the Front Panel.

2. Press Alt+Spacebar to display the Front Panel menu.

3. Press M, the menu’s mnemonic for Move.

4. Press the arrow keys to relocate the Front Panel.
   Hold down Control while you press an arrow key to speed up the movement of the Front Panel.

5. When you’ve moved the Front Panel to where you want it, press Return.

   To cancel the move operation, press Esc.

**Online Help Keyboard Navigation**

♦ **To Get Help in Any Window**

   ◊ Press F1 (or the Help key if your keyboard has one).
◊ **To Choose a Help Topic Hyperlink**

Choose hyperlinks to display related information. Help topic hyperlinks appear as:

- Underlined text
- An open-cornered box surrounding a graphic

1. If the help window does not already have the keyboard focus, press Alt+Tab to move the highlight to the help window.

2. Press Tab and the arrow keys to move the highlight to the hyperlink you want to choose, then press Return.

To return from a hyperlink to the previous topic:

◊ Press Control+B, the keyboard accelerator for Backtrack.

For more information about using Help, refer to Chapter 3, “Getting Help.”
You can customize the desktop user interface in many different languages. Various elements such as screens, default languages, fonts, input (keyboard) methods, and icons can be changed. In addition, the menus, online help, and error messages can be localized and are available in multiple languages.

<table>
<thead>
<tr>
<th>Default Language at Login</th>
<th>305</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logging In to a Language-Specific Session</td>
<td>306</td>
</tr>
<tr>
<td>Creating or Editing a Language-Specific File</td>
<td>306</td>
</tr>
<tr>
<td>Using a Language-Specific Terminal Emulator</td>
<td>307</td>
</tr>
<tr>
<td>Specifying Fonts</td>
<td>307</td>
</tr>
<tr>
<td>Changing Fonts</td>
<td>308</td>
</tr>
<tr>
<td>Choosing Your Input Method and Keyboard</td>
<td>310</td>
</tr>
</tbody>
</table>

**Default Language at Login**

The messages and menus in the initial login window are displayed in the default language. If the default language has not been set up, the messages and menus are displayed using a generic “C” locale environment. You can change the language from the Options menu in the login screen.
Logging In to a Language-Specific Session

Logging in to a specific language through the desktop is easy. However, specific hardware requirements such as keyboards and printers may be required to make the localized session more usable. These requirements vary by language, character set, and country. Software and fonts can further increase the effective localization of your system. To log in to a language-specific session:

1. Use the Options menu in the login screen to select a language.
   The list of languages includes all the supported languages.

2. Log in normally with your name and password.

Creating or Editing a Language-Specific File

You can create, edit, and print language-specific files. You can also give files language-specific names. However, for system administration files that are shared across a network, the file names should just contain ASCII characters. Different systems on the network might be using different locales.

If you have logged in to the desktop in a specific language, all applications will be invoked using that language. However, you can still invoke an application with another language.

If you want to create a file with a different language, invoke a new instance of Text Editor specifying your desired language.

♦ To Create or Edit a Language-Specific File

1. In a Terminal window, set the LANG environment variable to the desired language. For example, to set the locale to Japanese, you can type:

   `LANG=Japanese_localename`

   where `Japanese_localename` sets the value of the LANG environment variable for the Japanese character set. Refer to your specific platform to determine the value for `Japanese_localename`.

2. In the same window, call Text Editor (`dtpad`) under the desired language by typing:

   `/usr/dt/bin/dtpad &`
To start Text Editor with the Japanese language directly, type:

```
/usr/dt/bin/dtpad -xnlanguage Japanese_locale
```

You can now enter Japanese characters if the locale specific files have been installed. You can also use the Text Editor session to edit a previously created Japanese file.

See “To Specify Fonts from the Command Line” on page 308 for an example of specifying a font set.

**Using a Language-Specific Terminal Emulator**

The following example uses `dtterm` and will start a Japanese terminal emulator. It assumes that the default language is not Japanese, that you are using the Korn shell, and that the locale specific files have been installed.

◊ From a command line in a Korn shell Terminal window type:

```
LANG=Japanese_locale dtterm
```

where `Japanese_locale` sets the value of the LANG environment variable for the Japanese character set. Refer to your specific platform to determine the value for `Japanese_locale`.

**Specifying Fonts**

The user usually changes fonts using Style Manager, which in turn restarts Workspace Manager, resetting the desktop fonts. You can also customize fonts at the command line or in resource files. In an internationalized environment, the user must specify fonts that are independent of the code set. This is necessary because the specification can be used under various locales with different code sets than the character set (charset) of the font. Therefore, all font lists should be specified with a font set.

**Font Specification**

A font specification within a fontlist can be either an X Logical Function Description (XLFD) name or an alias for the XLFD name. For example, the following are valid font specifications for a 14-point font:

```
-dt-interface system-medium-r-normal-serif-*-*-*-*-p-*-iso8859-1
```

Or,

```
*-r-*-14-*iso8859-1
```
Font Set Specification

The font set specification within a fontlist is a list of XLFD names or their aliases (sometimes called a base name list). The names are separated by semi-colons, and any blank space before or after the semi-colon is ignored. Pattern-matching (wildcard) characters can be specified to help shorten XLFD names.

A font set specification is determined by the locale that is running. For example, the Japanese locale defines three fonts (character sets) necessary to display all of its characters. The following example identifies the set of Mincho fonts needed.

- Sample name list with character set:
  -dt-interface system-medium-r-normal-serif-*-*-*-*-*p-*-*14;
  -dt-mincho-medium-r-normal--14-*-*m-*jisx0201.1976-0;
  -dt-mincho-medium-r-normal--28-*-*m-*jisx0208.1983-0;

- Sample single pattern name without character set:
  -dt-*medium-*24-*m-:

The preceding two cases can be used with a Japanese locale as long as there are fonts that match the base name list.

Changing Fonts

You can change the fonts of dtterm by using either of the following methods:

- Specifying fonts from the command line
- Specifying fonts within a resource file

♦ To Specify Fonts from the Command Line

To change the fonts for the menu from the command line, type:

dtterm -xrm 'fontList: fontset'

where fontset is a font set specification. A font set specification can be specified by a full X Logical Font Description (XLFD) name list, a simple XLFD pattern, or an alias name. Note that a font set specification is determined by the locale that is running.
**Examples**

To use a larger font except for the menu font, type:

```
dtterm -xrm '*fontList:-dt-interface user-medium-r-normal-l*-**-***:'
```

To use a smaller font except for the menu font, type:

```
dtterm -xrm '*fontList:-dt-interface user-medium-r-normal-s*-**-***:'
```

These specifications will work for any locale.

♦  **To Specify Fonts within a Resource File**

For example, to change the fonts for the `dtterm` command in a resource file:

1. Edit the `Dtterm` resource file in the `/usr/dt/app-defaults/language` directory.

   You can use either the class name (`Dtterm`) or the application name (`dtterm`) for a resource file of `Dtterm`.

   Also, setting the LANG environment variable alters the search path of resource files to include the `/usr/dt/app-defaults/language` directory, where `language` is the locale name.

   After setting the LANG environment variable, the search path for resource files would include the following two folders:

   `/usr/dt/app-defaults/language/Dtterm`
   `/usr/dt/app-defaults/C/Dtterm`

2. Insert the font set you want to use at the bottom of the file.

   For example, to use a monospace font, put this line at the bottom of the file:

   ```
dtterm -fn -dt-interface user-medium-r-normal-**-***
```

3. Save the file.
Choosing Your Input Method and Keyboard

Each locale has a single default input method associated with it. If the user does nothing, this default is selected. Because there may be many input methods installed at any one time, the following sections explain how various input methods are selected on behalf of the user.

Using Input Method Modifiers

When there is more than one input method for a locale, use the XmNinputMethod resource to identify the one you would like used. This is done by specifying a modifier. The modifier must be of the following form, where modifier is the name used to uniquely identify the input method:

```
inputMethod :@im=modifier
```

The modifier string specified in the XmNinputMethod resource is used to choose which input method is used.

Alternatively, set the XMODIFIERS environment variable. The syntax is the same as for the XmNinputMethod resource, but values are not. Values for XMODIFIERS are vendor specific.

Specifying the Input Method Style

The input method style determines how pre-editing will occur. It is controlled by the XmNpreeditType resource. The syntax, possible values, and default value type of the XmNpreeditType resource are:

```
Syntax value[,value,....]

Possible values OverTheSpot, OffTheSpot, Root, None
Default value OverTheSpot, OffTheSpot, Root
```

The string list, separated by a comma, specifies the priority order for this resource. The first value supported by the input method is used.

For more information, see the CDE Advanced User’s and System Administrator’s Guide"
Changing the X Keyboard Map at the Server

If the keymaps currently used by the X server do not match the physical keyboard on the system, you can change them manually by using the xmodmap command or a vendor keyboard mapping utility. For information on the xmodmap command, type man xmodmap.
## Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>access privileges</td>
<td>Permissions granted to a user or group of users to perform various operations on a file or folder (directory). See permission.</td>
</tr>
<tr>
<td>action</td>
<td>A desktop construct that provides a method for running applications, executing commands, and other activities such as printing, removing files, and changing directories. Actions are defined in a database of configuration files.</td>
</tr>
<tr>
<td>action icon</td>
<td>An icon that represents an action in a File Manager or Application Manager window, or in the workspace. An action icon is created by creating an empty executable file with the same name as the action it represents.</td>
</tr>
<tr>
<td>action label</td>
<td>The name displayed under the icon of an action. See action name.</td>
</tr>
<tr>
<td>action name</td>
<td>The name associated with an action, which by default is displayed under the icon for the action. See action label.</td>
</tr>
<tr>
<td>active</td>
<td>A window, window element, or icon that is currently affected by keyboard and mouse input. Active windows are differentiated from other windows on the workspace by a distinctive title-bar color or shade. An active window element is indicated by a highlight or selection cursor.</td>
</tr>
</tbody>
</table>
active window
A window that receives keyboard input.

address
An electronic mail location of a user.

alias
An alternative name or names assigned to a program or to an electronic mail address.
In electronic mail, an address for mailing to a group of users. An alias can be created to send electronic mail to a small group of people or to many people.

AppBuilder
A software application used for constructing a graphical user interface.

application
See software application.

application group
An Application Manager folder that holds a specific software application or set of software applications.

application icon
See action icon.

Application Manager
A window containing objects representing the system actions available to you.

application server
A host computer that provides access to a software application.

Apply
A choice that causes a selection (or group of selections) in a dialog box to take effect.

Appointment Editor
In Calendar, a window you use to schedule, change, or delete an appointment.

Appointment List
A chronological list of appointments displayed by Calendar.
arrow button
An element of a scroll bar used to scroll a window by small increments. Also, a control in the Front Panel used to slide up or slide down a subpanel.

arrow keys
The four directional keys on a keyboard. Also see navigation keys.

attachment
In Mailer, a data object within an electronic mail message that is displayed as an icon in the Attachments list. An attachment can be text, sound, or a graphic. Multiple messages can be added (attached) to a single electronic mail message.

backdrop
The pattern that covers the workspace background.

background
The underlying area of a window on which elements, such as buttons and lists, are displayed.

Backtrack
In Help Manager, a button and Navigate menu item you use to follow links backward, in the reverse order they were traversed.

base name
The file name of an icon file minus the file-name suffixes for size (.1, .m, .s, .t) and type (.bm, .pm). For example, the base name of an icon file named myicon.m.pm is myicon.

bitmap
An image stored in a raster format. Usually refers to an image limited to two colors (a foreground and a background color). Contrast with pixmap.

busy light
A control that blinks when a Front Panel action has been invoked prior to the appearance of a window or when reloading actions.

button
A generic term for a window control. See push button.

Calculator
A software application that mimics the function of a hand-held calculator.
Calendar
A software application that enables you to schedule appointments and create To Do lists.

Calendar view
The day, week, month, or year displayed in the main Calendar window.

Cancel
A push button that removes a window without applying any changes made in that window.

CDE
An acronym for Common Desktop Environment, a graphical user interface running on UNIX.

check box
A nonexclusive control whose setting is indicated by the presence or absence of a check mark. A check box has two states, on and off.

choose
To use the mouse or keyboard to pick a menu item, button, or icon that begins a command or action. Contrast with select.

click
To press and release a mouse button without moving the mouse pointer. Unless otherwise specified, mouse button 1 is assumed.

client
A system or software application that requests services from another application, usually across a network.

clipboard
A buffer that temporarily stores the last cut, copy, or pasted data.

Clock
A Front Panel control that displays the local time.

Close
A menu item used to remove a window and all related secondary windows from all workspaces.
command-line prompt
A prompt, usually %, >, or $, that shows the computer is ready to accept commands. In a terminal emulation window, you display the command-line prompt by pressing Return.

Compose window
In Mailer, the window you use to create new electronic mail messages. Several message-composing options are available from the Compose window menu bar.

configuration file
A file that is used to customize the properties of an application.

container
A control intended to hold objects or data. A folder and a notebook are examples of containers. In Mailer, your electronic mailbox and filing system that contains all mail messages. Once a message is put in a container, you can display, modify, delete, print, include, forward, and reply to it.

control
A generic term for a variety of elements (such as buttons, check boxes, and scroll bars) that perform an action or indicate an option setting. See Front Panel control.

Create Action
A software application that enables you to associate an icon with a command so that the command can be issued by clicking on the icon. Create Action is also used to define specific data types for an application’s data files and to associate icons with those data types.

current folder
The currently opened folder in an active File Manager view.

current item, current selection
The currently highlighted item in a list.

current session
The session saved by Session Manager when you log off. At the next login, unless you specify otherwise, this session automatically opens, enabling work to continue where you left off. Contrast with home session.
cursor

A graphical device that shows the area that will receive keyboard or pointing device input.

customization

The process of changing settings to alter the appearance and behavior of the desktop and applications running on the desktop.

data type

A mechanism that associates particular data files with the appropriate applications and actions. Data types can determine the type of a file based on file-naming conventions, such as a particular extension name, or on the contents of the file.

default

A value set automatically by an application.

desktop

See workspace.

dialog box

A window displayed by an application that requires user input.

dimmed

Reduced contrast to show unavailable emphasis.

directory

A collection of files and other subdirectories. In graphical user interface applications, may be called a folder.

double-click

To quickly press a mouse button twice without moving the mouse pointer. Unless otherwise specified, mouse button 1 is assumed. Double-clicking can often be used as an alternative to selecting menu items.

drag

To press and hold down any mouse button while moving the pointer—and the object under the pointer—on the screen.

drag and drop

To directly manipulate an icon by using a pointing device to move and place the icon somewhere else. Also referred to as drag transfer.
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>drag transfer</td>
<td>See drag and drop.</td>
</tr>
<tr>
<td>drop</td>
<td>After starting the drag of an object, the act of releasing the mouse button. If the object is dropped in an appropriate area, an action is initiated.</td>
</tr>
<tr>
<td>drop target</td>
<td>A rectangular graphic that represents the drop zone in an application.</td>
</tr>
<tr>
<td>drop zone</td>
<td>An area of the workspace, including the Trash Can, Print Manager, and Mailer Front Panel controls, that accepts a dropped icon. Icons can be dropped on the workspace for quick access.</td>
</tr>
<tr>
<td>element</td>
<td>A generic term for any entity that can be considered a standalone item in a broader context, such as an item in a list or a control in a window.</td>
</tr>
<tr>
<td>email</td>
<td>Short name for “electronic mail.” Email usually describes text messages addressed and sent to you electronically and are received in your electronic mailbox. Sometimes just known as “mail.”</td>
</tr>
<tr>
<td>environment variables</td>
<td>Standard UNIX variables that are used by the shell and by applications.</td>
</tr>
<tr>
<td>error message</td>
<td>A message that requires the user’s immediate attention. Error messages are used to convey a message about a user error.</td>
</tr>
<tr>
<td>execute</td>
<td>A file or folder (directory) access permission. For files, execute permission enables the user to run a program or shell script file. For folders (directories), execute permission enables the user to access the folder (directory) contents.</td>
</tr>
<tr>
<td>Exit button</td>
<td>A Front Panel control used to log out of the desktop.</td>
</tr>
</tbody>
</table>
**extended selection**

To add multiple items to a selected set by augmenting the selection technique. For example, you can add to a selection by moving the pointer to a new item and pressing Control and the SELECT mouse button simultaneously.

**file**

A unit of data, such as text, program, image, and so on, that is stored in a folder (directory).

**File Manager**

The software application that manages the files and directories on your system.

**file name**

The name of the file as it is stored in a folder (directory) or on a storage device. A file name consists of a base name and any suffixes. A fully qualified file name also includes the path.

**file server**

A host computer that stores data files used by applications.

**file suffix**

A suffix added to the end of a file name, often used in file typing or to categorize files for the user.

**file type**

Characteristics of a file that determine how it is used. The type of a file may be determined by a portion of its name (for example, the file extension) or by its content.

**filter**

Used to display only objects that meet certain criteria, such as a name pattern match, and to hide all other objects from view.

**focus**

The place to which keyboard input is directed, indicated by the highlight.

**folder**

An icon that represents a directory.

**font**

A complete set of characters (letters, digits, and special characters) of one size and one typeface. Ten-point Helvetica bold is an example of a font.
foreground
The content of a window and the color or shading used to distinguish it from the window's background.

Front Panel
A centrally located window containing controls for accessing applications and utilities, including the workspace switch. The Front Panel occupies all workspaces.

Front Panel control
An object in the Front Panel used as an interface to basic system services and frequently performed tasks and operations. Controls in the default Front Panel are: Clock, Calendar, Mailer, Text Editor, Help Viewer, File Manager, Printer, Style Manager, Application Manager, and Trash Can.

Front Panel move handles
An area on each end of the Front Panel used for moving the Front Panel and for bringing it to the front of the workspace.

grab handles (or handles)
The small squares displayed at the corners and midpoints of a selected graphic element.

group
A collection of users who are referred to by a common name. Also, permission setting that determines a group's access to files.

Group Appointment
In Calendar, an appointment for a group of people, scheduled using the Group Appointment Editor.

header
In Mailer, the basic information about an electronic mail message as it appears in the mailer container. A message header displays the name of the sender, subject, the date and time it was received, and message size.

Help
A button or menu item used to access information about objects, choices, tasks, and error messages.

help family
A set of help volumes that provide online information about related applications.
**Help Index**
An alphabetic listing of help topics.

**help key**
A designated key, usually the F1 key, used to request online help information about what the cursor is currently on.
Some keyboards have a dedicated Help key that may take the place of F1.

**Help Manager**
A special help volume that lists all the online help registered on your system.

**Help Viewer**
The software application that displays online help.

**help volume**
A complete body of help information about a subject.

**help window**
A secondary window that displays help information.

**hierarchical file system**
A way to organize data on computer systems using a hierarchy of containers, often called folders (directories) and files. In this scheme, folders may contain other folders and files. The successive containment of folders within folders creates the levels of organization, which is the hierarchy.

**highlight**
**(v)** To make something stand out on the screen by selecting or choosing it. Also (n) the visual indicator that something is selected.

**history**
A list of the most recently accessed commands, files, folders, or help topics.

**home directory**
A directory where you keep personal files and additional directories. In graphical user interface applications, may be called the home folder.

**HomeDirectory**
Symbolizes your home directory. For example: If your home directory is /users/anna, then /HomeDirectory/bitmaps/smile.bmp represents /users/anna/bitmaps/smile.bmp.
**home folder**

A folder where you keep personal files and additional directories. By default, File Manager and Terminal Emulator windows are set to the home folder when you first open them. When discussing command-line activities, may be called the home directory.

**home session**

A choice at logout to designate a particular session, other than the one you are currently in, as the one you will automatically return to at the next login.

**host**

A computer system.

**hyperlink**

In Help text, text or a graphic you click to display another Help topic.

**icon**

A graphical representation of an object consisting of an image, an image background, and a label. An icon can be directly manipulated.

**Icon Editor**

The software application used to create new icons and to modify existing icons.

**Inbox**

The main or default Mailer container. The Inbox receives all incoming mail. Messages can be moved out of the Inbox and put in various containers.

**index**

In a help volume, an alphabetical list of words or phrases that can be searched to find help on a subject. The Help System displays the index when you choose the Index button in a help button dialog.

**insertion point**

The point at which data typed on the keyboard, or pasted from the clipboard or a file, appears on the screen. In text, a synonym for cursor.

**Install Icon**

An item on a subpanel used to install icons into the Front Panel using drag and drop.
ITE

Internal Terminal Emulator. ITE allows use of a bitmapped display as a terminal (through command-line mode from the login screen).

items

Elements in a list or menu.

label

The text appearing next to an icon or control that names the element.

link

Synonym for symbolic link.

list

A control that contains elements from which you select. Also called selection list.

Lock button

A Front Panel control used to lock the screen.

log in

To supply a user name and password to gain access to a system or desktop session.

login

The process of gaining access to a system.

log out

To terminate or end access to a system or desktop session.

logout

The termination of a desktop session.

Mailer

An application that enables you to send, receive, and compose electronic mail messages.

mailer container

The electronic mail box and filing system that contains all mail messages. Once a message is put in a container, you can display, modify, delete, print, include, forward, and reply to it.
<table>
<thead>
<tr>
<th><strong>Mailer control</strong></th>
<th>The Front Panel control used to start the Mailer software application. Dropping a file on the control loads the file into the Mailer Compose window.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Main Panel</strong></td>
<td>The portion of the Front Panel excluding the subpanels.</td>
</tr>
<tr>
<td><strong>mapping</strong></td>
<td>A method of using one action to run another action. Also, a pairing of entities in one set with those in another set.</td>
</tr>
<tr>
<td><strong>Maximize</strong></td>
<td>A choice that enlarges a window to its largest possible size.</td>
</tr>
<tr>
<td><strong>maximize button</strong></td>
<td>A button on a window’s title bar that you choose to display the window in its largest size.</td>
</tr>
<tr>
<td><strong>menu</strong></td>
<td>A list of items from which you select to perform a particular application task. Also see submenu.</td>
</tr>
<tr>
<td><strong>menu bar</strong></td>
<td>The part of the application window between the title bar and the work area where menu names are listed.</td>
</tr>
<tr>
<td><strong>menu item</strong></td>
<td>An element in a menu that represents a choice (for example, Copy on the Edit menu).</td>
</tr>
<tr>
<td><strong>Minimize</strong></td>
<td>To turn a window into an icon. The push button that minimizes a window is located near the upper right corner of the window frame.</td>
</tr>
<tr>
<td><strong>minimize button</strong></td>
<td>A button on a window’s title bar that you choose to display the window as an icon.</td>
</tr>
<tr>
<td><strong>mnemonic</strong></td>
<td>A single, underlined character in a command. The mnemonic indicates that you can choose the command by typing that letter. Mnemonics are used most commonly in menu commands; however, other buttons may also have mnemonics.</td>
</tr>
</tbody>
</table>
**modifier key**

A key that when pressed and held along with another key or mouse button changes the meaning of the second key or mouse click. Control, Alt, and Shift are examples.

**mouse**

A device for moving the pointer and making selections.

**mouse button**

A mechanism on a mouse that you press to make selections.

**mouse button 1**

On a mouse, the leftmost button when configured for right-handed use; the rightmost button when configured for left-handed use. Mouse button 1 is primarily used for selection, and is the default button for the “click” instruction.

**mouse button 2**

On a three-button mouse, the middle button. On a two-button mouse, the right button if configured for right-handed use or the left button if configured for left-handed use. Mouse button 2 has two modes: Transfer and Adjust.

**mouse button 3**

On a mouse, the rightmost button when configured for right-handed use; the leftmost button when configured for left-handed use. Mouse button 3 activates pop-up menus.

**Move**

A window menu choice used to put a window in a different location on the screen.

**navigation keys**

The keyboard keys used to move the current location of the cursor. These include the arrow keys (with or without the Control key); the Tab key (with or without the Control or Shift keys); the Begin and End keys (with or without the Control key); and the Page Up and Page Down keys.

**newline character**

An unseen character that marks the end of a line of text in a document. It tells a printer or screen to break a line and start a new one.
**object**

Any logical piece of data that has associated behavior. For example, in File Manager, files, folders, actions, and applications are all considered objects. Each type of object has specific associated actions. Typically, each object is represented as an icon.

**object type**

A desktop mechanism used to associate particular data files with the appropriate applications and actions. Object typing defines the criteria for typing the file (such as name or contents), the appearance (the icon used in File Manager), and the behavior of the object (for example, what happens when you double-click it).

**OK**

A choice that accepts the information in a window and closes it. If the window contains changed information, those changes are applied before the window is closed.

**On Item help**

When you choose On Item from the Help menu, the cursor changes to a question mark and you can obtain information about a particular command, operation, dialog box, or control by clicking that object.

**On Item Help control**

A Front Panel control used to access item help information on the Front Panel.

**overwrite**

To replace.

**page**

To advance text displayed in a window by one full screen at a time, usually using a scroll bar.

**palette**

A range of graphically displayed choices, such as colors or collections of tools, that you can select in an application.

**parent directory**

A directory that contains subdirectories and files. In graphical user interface applications, this may be called the parent folder.
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>parent folder</td>
<td>A folder that contains subfolders and files. When discussing command-line activities, this may be called the parent directory.</td>
</tr>
<tr>
<td>password</td>
<td>A sequence of characters that users type to prove their identity to the system.</td>
</tr>
<tr>
<td>path</td>
<td>A text string that specifies the hierarchical location of a folder (directory).</td>
</tr>
<tr>
<td>pause</td>
<td>To temporarily suspend a process without ending it.</td>
</tr>
<tr>
<td>permission</td>
<td>A setting that determines how users or groups of users may access a file or folder (directory).</td>
</tr>
<tr>
<td>pixmap</td>
<td>An image stored in a raster format. Usually refers to an image that may have more than two colors. Contrast with bitmap.</td>
</tr>
<tr>
<td>point</td>
<td>To move the mouse until the pointer rests on a particular screen element or area.</td>
</tr>
<tr>
<td>pointer</td>
<td>A cursor that shows the area that receives input from a pointing device. The pointer can take the form of an arrow, an I-beam, a cross, or other graphic. Also see cursor.</td>
</tr>
<tr>
<td>pop-up menu</td>
<td>A menu that, when requested, is displayed next to the object with which it is associated. Pop-up menus are usually displayed by clicking mouse button 3 or pressing Shift+F10.</td>
</tr>
<tr>
<td>Print Manager</td>
<td>A software application that shows all the printers on your system.</td>
</tr>
<tr>
<td>print server</td>
<td>A host computer to which one or more printers are connected, or the UNIX process that manages those printers.</td>
</tr>
</tbody>
</table>
Printer control
The Front Panel control used to start the Printer software application. Dropping a file on the control displays a dialog box you can use to print the file to the default printer.

Printer Jobs
A software application that provides information about jobs on a single printer.

Program
A sequence of instructions that a computer can interpret and execute.

Properties
A menu item used to set characteristics of an item, such as its date or name, or display identifying characteristics of an item, such as typefaces.

Pull-down menu
A menu of related choices that extends from a cascading choice when you click mouse button 1 on a menu bar item or the Window menu button.

Push button
A control that immediately starts an action by an application, usually executing a command (such as Apply), displaying a window, or displaying a menu.

Queue
An ordered list of jobs waiting to be performed.

Radio button
An exclusive control whose setting is indicated by the presence or absence of a graphical indicator, usually part of a radio group. A radio button has two states, on and off.

Read
Permission to look at the data in a file or permission to list the files and folders (directories) in a folder (directory).

Reset
A button or menu item used to return an item to the condition it was in when it was last opened or to the condition it was in before the most recent changes were applied to it, whichever is more recent.

Resize border
A control used to change the size of a window or a pane in a window.
resource

A mechanism of the X Window System™ for specifying an attribute (appearance or behavior) of a window or application. Resources are usually named after the elements they control.

restart

To stop a process and start it again.

Restore

A menu item used to return a window to the size and position it occupied before you minimized or maximized it.

root, root user

See superuser.

root directory

In a hierarchical file system, the directory that contains all other directories and files. Represented by a / (slash) in UNIX systems.

run

To start an application or action.

class

A box on a separator or split bar that enables you to increase or decrease the size of a window pane using the mouse. You can navigate to the class using the keyboard.

class lock

A function that locks the workstation screen, barring further input until the valid user password is entered.

Screen Saver

A choice that, after a specified time period, switches off the workstation display or varies the images that are displayed, thereby prolonging the life of the screen.

scroll

To move the cursor through data one increment at a time. While scrolling, data shifts within the window to indicate the current position of the cursor.

scroll bar

A control located at the right or bottom of a window that enables you to display window content not currently visible.
scroll box

The part of a scroll bar that shows the position of the visible information relative to the total amount of information available in a window. You click a scroll box to see information that is not currently visible.

select

To add highlighting or some other visual cue to an item or element so that it can be operated or enabled. Selection does not imply the initiation of an action but rather a change of state, such as highlighting an item in a list, or toggling a check box on.

server

A system that supplies services to a client.

session

The elapsed time between user login and logout. Also, a particular configuration of workspaces that includes Style Manager settings, open applications, and the size and position of objects.

Session Manager

A software application that controls saving sessions, restoring sessions, screen locking and unlocking, and the use of screen savers. When a session is saved, the state of the desktop environment (location of icons, size and location of open windows, open/closed status of applications, current color palette, and so on) is preserved so that it can be restored at the next login.

session server

A system that provides networked sessions. Session files reside on the session server and are used whenever you log in to a system on the network.

shortcut

General term for a mouse gesture that simplifies filling out a dialog box. For example: As a shortcut, double-click an item in the Filename list box to select it and choose OK in one action.

shortcut keys

A keyboard key sequence used to activate a menu item, usually through a special accelerator key. For example: Press Alt+F to choose Print from the File menu.
**slider**

A control that uses a track and arm to set a value from among the available values. The position of the arm (or a separate indicator) gives the currently set value.

**software application**

A computer program that provides you with tools to do work. Style Manager, Text Editor, and File Manager are examples of software applications.

**status area**

A part of a window where information is displayed that shows the state of an object or the state of a particular view of an object.

**Style Manager**

The software application used to customize some of the visual elements and system device behaviors of the workspace environment, including colors and fonts, and keyboard, mouse, window, and session start-up behaviors.

**subdirectory**

A directory contained within another directory (sometimes called the parent directory). In graphical user interface applications, this may be called a subfolder.

**subfolder**

A folder contained within another folder (sometimes called the parent folder). When discussing command-line activities, this may be called a subdirectory.

**submenu**

A menu displayed by choosing an item from a menu.

**subpanel**

An extension of the Front Panel that slides up providing access to additional elements. Subpanels usually contain groups of related elements.

**suffix**

A part of a file name, added at the end, separated from other suffixes or the base file name by some punctuation, such as a period (.)
superuser

A login identity that enables special permissions for modifying system files that most users do not have permission to modify. Superuser is also called “the root user” or “root” because the user ID for superuser is root. On most computer systems, only a few users have permission to become superuser.

symbolic link

A type of link that is capable of pointing to a file or directory that resides on another physical storage device or partition.

template

In Mailer, an ASCII file you can create for conveniently including frequently typed information, such as your name and electronic mail address, in your mail messages.

Terminal

In the Front Panel, an item in the Personal Applications subpanel used to open a terminal window.

terminal emulator

A window that emulates a particular type of terminal for running nonwindow programs. Terminal emulator windows are most commonly used for typing commands to interact with the computer’s operating system.

text cursor

A cursor that shows the insertion point for textual input. This cursor usually takes the form of an I-beam. Contrast with location cursor and pointer.

Text Editor

The software application used to create and edit documents.

text field

A rectangular area in a window where information is typed. Text fields with keyboard focus have a blinking text insertion cursor.

title bar

The topmost area of a window containing the window title, window menu button, and the maximize and minimize buttons. See also window title.

toggle

To change the state of a two-state control, such as a radio button or check box, using either the mouse or keyboard.
topic tree

In a general help dialog box, an expandable and contractible list of topics that can be selected to display help information.

Trash Can

A container for deleted files or folders.

tree view

A view of a folder or files that includes all lower-level folders in the search path.

user name

An identifier for making a user known to the system. Sometimes called a login name. For example, a user whose name is John Doe might have the user name jdoe. The login screen prompts for the user name.

window

A rectangular area on the display. Software applications typically have one main window from which secondary windows, called dialog boxes, can be opened.

window frame

The visible part of a window that surrounds a software application. A window frame can contain up to five controls: title bar, resize borders, minimize button, maximize button, and the Window menu button.

window icon

A minimized window.

Window Manager

The software application that provides users with the capability to manipulate windows on the workspace; for example, opening, resizing, moving, and closing windows.

Window menu

The menu displayed by choosing the Window menu button. The menu provides choices that manipulate the location or size of the window, such as Move, Size, Minimize, and Maximize.

Window menu button

The control at the upper left corner of a window, next to the title bar. Choosing it displays the Window menu.
<table>
<thead>
<tr>
<th><strong>work area</strong></th>
<th>The part of a window where controls and text appear.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>workspace</strong></td>
<td>The current screen display, the icons and windows it contains, and the unoccupied screen area where icons can be placed.</td>
</tr>
<tr>
<td><strong>workspace backdrop</strong></td>
<td>See backdrop.</td>
</tr>
<tr>
<td><strong>workspace background</strong></td>
<td>The portion of the display not covered by windows or icons.</td>
</tr>
<tr>
<td><strong>workspace icon</strong></td>
<td>An icon that has been copied from File Manager to the workspace.</td>
</tr>
<tr>
<td><strong>Workspace Manager</strong></td>
<td>The software application that controls the size, placement, and operation of windows within multiple workspaces.</td>
</tr>
<tr>
<td><strong>Workspace menu</strong></td>
<td>The menu displayed by pointing at an unoccupied area of the workspace and clicking button 3 on the mouse.</td>
</tr>
<tr>
<td><strong>workspace object</strong></td>
<td>An object that resides in a workspace, rather than inside a viewer in a window. Workspace objects include windows, icons (minimized windows), and objects that have been dragged from File Manager and Application Manager and dropped on a workspace.</td>
</tr>
<tr>
<td><strong>workspace switch</strong></td>
<td>A control that enables you to select one workspace from among several workspaces.</td>
</tr>
<tr>
<td><strong>workspace switch area</strong></td>
<td>The rectangular area in the center of the Front Panel that contains the workspace switches, the Lock control, the Exit button, and the busy light.</td>
</tr>
<tr>
<td><strong>Wrap To Fit</strong></td>
<td>In Text Editor, this setting controls whether lines are automatically wrapped to fit the window width as you enter text. If set, lines wrap at the edge of the window. If not set, you must press Return to end the line.</td>
</tr>
</tbody>
</table>
Write

Permission to modify the contents of a file or folder.
Symbols
.. (parent directory), 117

A
absolute path, 88
access
denying to your calendar, 251
granting to your calendar, 248 to 251
to calendar, changing, 248
to other calendars, 241
action icon, 123
and file names, 128
help on, 126
actions
creating, 130
double-clicking, 95
executing, 100
executing the default, 101
Actions menu, 95
adding
applications, 130
applications to Front Panel, 126
applications to personal application group, 128
attachments to mail messages, 173
calendars to Browse list, 240
controls with Install Icon, 78
group appointment, 241
palette, 142
subpanels, 78
To Do item, 235
workspaces, 80
addresses, 159
aliases, 160
application groups, 123 to 124
built-in, 124
definition of, 123
application help, 42
application icon, 123
help on, 126
on workspace backdrop, 127
Application Manager, 121
application groups, 123
built at login, 124
folders in, 122
Front Panel control, 8, 122
labels and file names, 128
location in file system, 129
opening, 8, 122
running applications from, 124
starting Icon Editor from, 281
updating, 127
window, 122
Application Manager control, 73
applications
adding, 130
adding to Front Panel, 126
adding to Personal Applications subpanel, 133
registering, 132
reloading, 127
running from Application Manager, 124
running from File Manager, 132
running from Front Panel, 133
running from Personal Applications subpanel, 134
running from terminal emulator, 135
starting in Terminal window, 261
using Text Editor with, 224
Appointment Editor
changing defaults, 246
Group, 241
options, 232
standalone, 254
using, 231
appointment list
displaying, 234
printing, 238
appointments
adding to mail message, 175
basic, 231
changing, 233
creating, 231
creating using standalone Appointment Editor, 254
deleting, 233
deleting using dtcm_delete, 256
dragging from File Manager, 244
dragging from Mailer, 244
dragging to File Manager, 245
dragging to Mailer, 245
finding, 234
finding using dtcm_lookup, 255
format for mail message, 243
frequency of, 232
inserting, 231
inserting using dtcm_insert, 255
inserting using standalone Appointment Editor, 254
looking up, 255
mailing, 243, 248
options, 232
reminders, 232
scheduling, 231
scheduling using standalone Appointment Editor, 254
attachments
adding to mail message, 173
adding with drag and drop, 174
deleting, 174
printing, 173
reading, 172
saving, 174
viewing, 172
automatic mail messages, 166

B
Backdrop dialog box, 144
backdrop, See workspace backdrop
Backspace key, 24
base name font list, 308
basic appointment, 231
basic file management skills, 90
Beep Calendar reminder, 232
Beep dialog box, 145
beep, changing settings for, 145
bell options in Terminal, 270 to 271
BottomShadow, 287
Browse list, 240
browsing calendars, 239
Browsing Help on Your System, 57
Busy light, 73
buttons
check box, 20
OK, 19
radio, 20
types of, 19
C
Calendar
   Front Panel control, 225
   menus, 226
   saving data in a file, 239
   starting, 225
   starting from command line, 256
   Tool bar, 226
   tool bar, 227
Calendar control, 72
Calendar views
   changing, 228, 229, 230, 231
   changing default, 248
   Day, 228
   default, 226
   displaying, 228
   Month, 230
   printing, 238
   Week, 229
   Year, 231
calendars
   access to other, 241
   browsing, 239
   comparing, 241
   deleting from the Browse list, 240
   names of, 240
canceling
   dragging, 91
   print jobs, 194
capturing region of display, 291, 292
changing
   Appointment Editor defaults, 246
   appointments, 233
   beep settings, 145
   calendar access and
   permissions, 248
   Calendar printer settings, 252
   Calendar time zone, 253
   Calendar views, 228, 229, 230, 231
   colors, 141
   date format in Calendar, 253
   default Calendar view, 248
   File Manager default
   preferences, 116
Front Panel lock settings, 147
how your next session starts, 150, 151
initial calendar displayed, 247
number of colors, 143
permissions for your calendar, 250
printer icon, 199
printer label, 200
privacy defaults in Calendar, 246
properties of file, 105
properties of folder, 105
reminders in Calendar, 246
time boundaries on Day and Week
views, 247
To Do item, 236
check boxes, 19, 20
choosing
   Front Panel controls with the
   keyboard, 301
   help, 32
   help topic hyperlinks with the
   keyboard, 303
   menu items, 30
   push buttons, 19
   subpanel controls with the
   keyboard, 302
   Window menu items, 29
   Workspace menu items, 29
Clean Up (command in View
menu), 115, 116
clicking, 2
to make window active, 149
Clock control, 72
closing
   application windows, 12, 296
   subpanels, 66
color
   changing, 141
   for icons, 287 to 288
   grabbing from workspace, 142
   in help windows, 60
   limiting usage of, 143
   in Terminal window, 269
Color dialog box, 141, 142
Command Line Login mode
- Definition of, 37
- Exiting, 38
- Logging in to, 38

Commands
- Entering in Terminal window, 262
- Issuing for printing, 189

Compare Calendars grid, using, 241
Comparing calendars, 241
Contents, finding file using, 110
Control characters in Terminal, 277
Control key, 3
Controls
- Adding with Install Icon, 78
- Customizing in the workspace switch, 81 to 83
- Deleting, 69
- Moving to Main Panel, 77
- Replacing in Main Panel, 79

Copying
- Files, 97
- Folders, 97
- Objects, 97
- Palette, 142
- A region of an icon, 288
- Text, 215
- Text in Terminal window, 262

Create Action, 130
Creating, 130
- Actions, 130
- Aliases, 160
- Appointment using standalone Appointment Editor, 254
- Appointments, 231
- Custom palette, 142
- Data types, 130
- Document, 204
- File with language-specific characters, 306
- Files, 96
- Folders, 96
- Mail templates, 177
- Mailboxes, 159, 168
- Objects, 96
- Personal application group, 127
- To Do items, 235
- Current folder, 88
- Current session, 31
- Definition of, 38, 150
- Resuming at, 150

Cursor movement keys, 209
Cursor options in Terminal, 267 to 268
Custom Time, in Calendar, 253
Customizing
- Calendar printer settings, 239, 252
- Colors, 141
- File Manager views, 111 to 112
- Keyboard behavior, 145
- Mouse behavior, 145
- Palette, 141
- Screen saver, 146, 148
- Cutting a region of an icon, 288

D
- Data types, 130
- Date format, 253

Day view
- Calendar, 228
- Changing time boundaries, 247
- Three-month mini-calendar, 228
- Default actions, 101
- Default printer
  - Changing, 184
  - Control, 75
  - Definition of, 183
  - Determining, 184
- Default terminal emulator, 258
  - Changing, 278
- Defaults
  - Calendar view, 226
  - Changing access and permissions, 248
  - Changing Appointment Editor, 246
  - Changing Calendar reminder, 246
  - Changing Calendar view, 248
  - Changing privacy, 246
  - Date format in Calendar, 253
initial calendar displayed, 247
time boundaries on Day and Week views, 247
Delete char key, 24
Delete key, 24
deleting
appointments, 233
appointments using
dtmcmd_delete, 256
calendars from Browse list, 240
controls from subpanels, 69
files, 103
folders, 103
mail attachments, 174
mail messages, 158
palette, 143
subpanels, 78
text, 214
text in a field, 24
To Do items, 236
workspaces, 80
denying access to your calendar, 251
deselecting text, 16
desktop
current session, 31
exiting, 31
help, 32
logging out, 31
overview, 4
windows, 4
workspaces, 4, 16
Desktop Introduction control, 76
desktop session, 36
directories, See folders
display
capturing region of, 291, 292
locking, 32
refreshing, 28
unlocking, 32
displaying
appointment list, 234
Calendar views, 228
concealed windows, 15
Front Panel pop-up menus, 66
help, 32
man pages, 58
message line in Print Manager, 198
pop-up menus, 26, 30, 299
print job properties, 194
print jobs, 192
Print Manager problem flag, 198
printer properties, 199
pull-down menus, 25, 30, 299
subpanels, 65
To Do list, 236
Window menu, 26
Workspace menu, 28
workspaces, 16, 300
document
creating, 204
ingoing to specific line in, 210
including file in, 217
including file through drag and drop, 219
justifying text in, 222
margins, 222
new lines in, 208
opening existing, 206 to 207
opening existing from File Manager, 207
printing, 222
restoring, 201
saving, 204
searching, 220
word wrap, 208
dot files, 117
double-clicking, 2
action performed, 95
drag and drop, in Text Editor, 219
dragging, 2
appointment from Calendar to File Manager, 245
appointment from Calendar to Mailer, 245
appointment from File Manager to Calendar, 244
appointment from Mailer to Calendar, 244
canceling, 91
drawing icon image, 283
undo, 285
drawing tools for Icon Editor, 283 to 285
dropping
  file in Text Editor, 219
  files, 91
  folders, 91
  icon file, 281
  objects, 91
  text, 219
dynamic colors for icons, 287
due date, setting for To Do item, 235
File Manager
  changing icon display area size in, 119
determining headers for, 111
disabling icon browsing in, 119
Front Panel control, 7, 86
icon browsing in, 118
main window, 86
opening, 7
opening existing text document from, 207
printing using, 186
running applications from, 132
saving current preferences as default, 116
starting, 86
starting Icon Editor from, 281
File Manager views
  aligning icons in, 116
  arranging icons in, 112
  changing, 111
  changing sort order of, 115
  customizing, 111 to 112
  folder, 114
  saving, 116
  tree, 112 to 114
file names
  and action icons, 128
  in Application Manager, 128
File system
  concepts, 87
  hierarchical, 87
  moving through, 99
files
Index

changing properties of, 105
  copying, 97
  creating, 96
  dragging, 91
  dropping, 91
  dropping in Text Editor document, 219
  finding by contents, 110
  finding by name, 109
  getting help on, 94
  hidden, 117
  hiding, 117
  including in document through drag and drop, 219
  including in mail messages, 165
  including in Text Editor document, 217
  with language-specific characters, 306
  locating, 108
  moving, 96
  opening, 95
  putting on workspace backdrop, 107
  removing from workspace, 108
  renaming, 94
  restoring from Trash Can, 102
  selecting multiple, 91
  selecting single, 90
  sorting, 116
  types for printing, 184 to 185
filing mail messages, 169
finding
  appointment using dtcm_lookup, 255
  appointments, 234
  files, 108
  mail messages, 157
  objects, 108
  objects using wildcards, 109
  print jobs, 193
Flash Calendar reminder, 232
flipping part of an icon, 289
folder view in File Manager, 114
folders
changing, 99
changing properties of, 105
changing to, 99
  copying, 97
  creating, 96
  definition of, 87
  deleting, 103
  dragging, 91
  dropping, 91
  getting help on, 94
  hidden, 117
  hiding, 117
  moving, 96
  opening, 95
  putting on workspace backdrop, 107
  removing from workspace, 108
  renaming, 94
  restoring from Trash Can, 102
  selecting multiple, 91
  selecting single, 90
  sorting, 116
Font dialog box, 144
font set specification, 308
font specification, 307
groups
  internationalizing, 307 to 309
  selecting new size for, 144
  specifying from the command line, 308 to 309
  specifying within a resource file, 309
formatting
  document in Text Editor, 221
  mail message text, 163
forwarding messages, 157
frame controls, 9
frequency of appointments, 232
Front Panel, 63 to 83
  adding applications to, 126, 133
  Application Manager control, 122
  Calendar control, 225
  changing the printer in, 196
  contents, 72
customizing, 77
drop zones, 64
Exit control, 31, 36
File Manager control, 86
help, 70
Help control, 76
Icon Editor control, 281
Lock control, 32
lock settings, 147
minimizing, 71
moving, 70
On Item help, 70
pop-up menus, 66
printing through, 185 to 186
removing customizations made
through the GUI, 79
running applications from, 133
Style Manager control, 73
Text Editor control, 202
displaying, 32
displaying for file, 94
displaying for folder, 94
displaying topics, 46
Front Panel, 70
hierarchy of topics, 49
hyperlinks, 303
index, 51
keyboard navigation, 302
moving between topics, 48
on objects, 94
On Item help, 43
pop-up menu, 49
printing help topics, 58
using Help key, 42
window colors, 60
windows, 45
help commands
Backtrack, 48
History, 48
Home Topic, 48
Index, 53
New Window, 57
Print, 59
Top Level, 55
Help key, 32
Help Manager
Front Panel control, 44
opening, 55
Help Manager control, 73, 76
Help menu, 33
help topic, 49
help volume, 49
help windows
color in, 60
duplicating, 57
topic display area, 45
topic tree, 45
types of, 45
hidden files, 117
hiding
files, 117
folders, 117
Icon Editor grid, 292
grabbing
region of display, 291, 292
grabbing color from workspace, 142
granting access to your calendar, 248 to
grid
Calendar Week view, 229
Compare Calendars, 241
in Icon Editor, 292
Group Appointment Editor,
starting, 241
group appointments
inserting, 241
mailing reminders, 242
scheduling, 241
help
on action icon, 126
on application icon, 126
browsing, 54
customizing, 77
browsing, 54
customizing, 77
drop zones, 64
Exit control, 31, 36
File Manager control, 86
help, 70
Help control, 76
Icon Editor control, 281
Lock control, 32
lock settings, 147
minimizing, 71
moving, 70
On Item help, 70
pop-up menus, 66
printing through, 185 to 186
removing customizations made
through the GUI, 79
running applications from, 133
Style Manager control, 73
Text Editor control, 202
displaying, 32
displaying for file, 94
displaying for folder, 94
displaying topics, 46
Front Panel, 70
hierarchy of topics, 49
hyperlinks, 303
index, 51
keyboard navigation, 302
moving between topics, 48
on objects, 94
On Item help, 43
pop-up menu, 49
printing help topics, 58
using Help key, 42
window colors, 60
windows, 45
help commands
Backtrack, 48
History, 48
Home Topic, 48
Index, 53
New Window, 57
Print, 59
Top Level, 55
Help key, 32
Help Manager
Front Panel control, 44
opening, 55
Help Manager control, 73, 76
Help menu, 33
help topic, 49
help volume, 49
help windows
color in, 60
duplicating, 57
topic display area, 45
topic tree, 45
types of, 45
hidden files, 117
hiding
files, 117
folders, 117
Icon Editor grid, 292
}

CDE User's Guide
objects, 117
waiting print jobs, 193
hierarchical file system, 87
highlight, keyboard, 294
home folder, navigating to, 100
home session
definition of, 38, 150
returning to, 150
setting, 38, 151
starting automatically at login, 39
home topic, in help volume, 49
hotspot in an icon, 291
hyperlink, used in help, 46

I
icon browsing, 119
Icon Editor
control, 281
drawing tools, 283 to 285
hiding grid in, 292
opening icon for editing, 281
saving icon, 286
saving icon with new name, 287
starting, 281
starting a new icon, 282
starting from Application Manager, 281
starting from File Manager, 281
starting from Terminal, 281
Icon Editor control, 74
icons
aligning in File Manager view, 116
arranging in File Manager view, 112
behavior of in Front Panel, 78
browsing in File Manager, 118
changing display area size in File Manager, 119
changing for printer, 199
changing magnification of, 292
clearing loaded, 283
color usage for, 287 to 288
copying a region of, 288
cutting a region of, 288
displaying in icon box, 150
displaying on workspace, 150
drawing image, 283
flipping part of, 289
hotspot, 291
moving a region of, 289
naming, 285 to 286
opening existing, 282
output format, 286
resizing, 290
resizing a region of, 290
rotating part of, 289
saving, 286
saving with new name, 287
selecting an area of, 288
selecting multiple, 91
selecting single, 90
size conventions for, 286
included text, marker for, 163
including multiple messages in a mail message, 165
indicator controls, 64
initial calendar displayed, changing, 247
input method for locales, 310
inserting appointment, 231
appointment using dtcm_insert, 255
appointment using standalone Appointment Editor, 254
group appointment, 241
To Do item, 235
Install Icon
behavior of icons installed with, 78
control, 64, 74, 75
internationalization and fonts, 307

J
justification, setting in Text Editor, 222
K

keyboard
  basic skills, 3
  choosing menu items with, 30
cursor movement keys in Text Editor, 209
customizing behavior, 145
displaying menus with, 299
focus, 294, 295
highlight, 294
navigation, 3, 293
navigation and Window Behavior setting, 3
options in Terminal, 273 to 274
shortcuts, 3, 293	
tab groups, 294
Keyboard dialog box, 145
dkeymaps, changing, 311

L

labels
  changing for printer, 200
  in Application Manager, 128
LANG environment variable, 306
language, setting for desktop session, 36
language-specific
  characters in file, 306
data, 306
login, 306
sessions, 305
terminal emulator, 307
Text Editor, 306
link, creating symbolic, 98
list
  of appointments, 234
  of To Do items, 236
lists
  scrollable, 19
  selecting items in, 22
local time, setting in Calendar, 253
Lock control, 32, 72
locking the display, 32
logging in, 36
to language-specific session, 306
logging out, 31, 36
login screen, 35
login, language-specific, 306
logout confirmation, 151
logout, determining session resumption at, 150
looking up appointments, 255

M

magnification of icons, 292
Mail Calendar reminder, 232
mail messages, See messages
mailboxes
  adding to menus, 170
closing, 169
creating, 168
filing messages in, 169
filing using drag and drop, 170
opening, 169
removing, 170
Mailer control, 72
mailing
  Calendar appointment, 243, 248
  reminders of group appointment, 242
Main Panel, 63
  changing controls in, 77
  contents, 72
  moving subpanel control to, 69
  replacing Personal Applications control in, 134
man pages, displaying, 57, 58
managing files, 90
margins, document, 222
marking To Do item completed
  using To Do Editor, 238
  using To Do list, 237
maximize button, 10
menu bar
  removing from Terminal window, 265
restoring to Terminal window, 265
menus
   Calendar, 226
   mnemonics, 25, 294
   shortcut keys, 25, 294
   using, 25
   Window, 26
   Workspace, 28
messages
   Calendar appointment format
      for, 243
   changing text, 167
   checking spelling, 167
   displaying numbers of, 176
   filing, 169
   finding text in, 167
   frequency of checking for new, 177
   including text files, 165
minimize button, 10
minimizing
   Front Panel, 71
   windows, 12
mnemonics, menu, 25, 294
Modify dialog box, 141
Month view, 230
mouse
   choosing a menu item, 30
   click, 2
   customizing behavior, 145
   double-click, 2
   dragging, 2
   using, 2
mouse button 1, 2
mouse button 2, 16
mouse button 3, 26
Mouse dialog box, 145
moving
   controls to Main Panel, 77
   files, 96
   folders, 96
   Front Panel, 70
   icons, 13
   keyboard focus, 295
   objects, 96
a region of an icon, 289
subpanels, 70
windows, 13, 298
My Time, setting Calendar time zone, 253
N
name, finding file by, 109
names
   for icon files, 285 to 286
   of calendars, 240
navigating
   to home folder, 100
   moving text insertion cursor, 209
   to specific line in document, 210
   with keyboard, 293
Next key, 21
O
objects
   aligning in File Manager view, 116
   changing ownership of, 105
   changing permissions of, 105
   changing properties of, 105
   copying, 97
   creating, 96
   dragging, 91
   dropping, 91
   executing action of, 100
   finding by name, 109
   folder, 87
   getting help on, 94
   hiding, 117
   manipulating, 96
   moving, 96
   opening, 95
   pop-up menu for, 107
   putting on workspace backdrop, 107
   removing from workspace, 108
   renaming, 94
   restoring from Trash Can, 102
   selecting multiple, 91
selecting single, 90
sort order in File Manager, 115
sorting, 116
workspace, 8
Occupy Workspace dialog box, 17
OK button, 19
On Item help, 43, 94
On Item Help control, 76
online help, 41
displaying, 32
keyboard navigation, 302
opening
application windows, 11, 296
effective document, 206 to 207
files, 95
folders, 95
icon, 281
mailboxes, 169
objects, 95
Style Manager, 137
subpanels, 65
Terminal window in current
directory, 100
overstrike mode, in Text Editor, 214
ownership, changing in File
Manager, 105
permissions
changing, 105
changing for your calendar, 248,
250
setting for your calendar, 249
personal application group
adding applications to, 128
creating, 127
Personal Applications control, 72
Personal Applications subpanel, 133
adding applications to, 133
customizing, 134
replacing the Front Panel control
of, 134
running applications from, 134
pointing to make window active, 149
Popup Calendar reminder, 232
pop-up menus
displaying, 26, 30, 93
for objects, 107
Front Panel, 66
for subpanels, 69
preferences, saving File Manager
current, 116
Prev key, 21
print commands, issuing, 189
Print dialog box, 187 to 189
print jobs
canceling, 194
definition of, 192
determining type in Print Manager
display, 197
display of in Print Manager, 197
displaying, 192
displaying properties of, 194
finding, 193
hiding, 193
properties, 194
Print Manager
determining type of print jobs
displayed, 197
display of print jobs in, 197
displaying print jobs in, 197
displaying message line in, 198
printer display in, 197
Page Down key, 21
Page Up key, 21
palette
adding, 142
creating, 142
deleting, 143
modifying, 141
restoring, 143
selecting, 141
parent folder, navigating to, 100
pasting
text, 16
text in Terminal window, 262
path, 88
pending To Do item, 237
Index

printing using, 187
problem flag, 198
starting, 190 to 191
window, 189
Print Manager control, 75
print options, setting, 188
printer
  changing the default, 184
  changing the Front Panel, 196
definition of default, 183
determining the default, 184
Printer control, 73, 75
Printer Jobs, 191
starting, 192
printers
  changing icon of, 199
  changing label of, 200
display of in Print Manager, 197
displaying properties of, 199
printing
  allowable file types, 184 to 185
  appointment list, 238
  Calendar views, 238
  changing Calendar printer settings, 252
document, 222
  using File Manager, 186
  through the Front Panel, 185 to 186
help topics, 58
issuing print commands, 189
mail attachments, 173
mail messages, 171
using Print Manager, 187
setting options for, 188
To Do list, 238
privacy, changing Calendar defaults, 246
properties
  changing file, 105
  changing folder, 105
  changing object, 105
  of print jobs, 194
pull-down menus, displaying, 25, 30
push buttons, 19

Q
question mark pointer, 33

R
radio buttons, 20
read permission, changing, 105
reading mail messages, 155
refreshing the display, 28
registering applications, 132
relative path, 89
reloading applications, 127
reminders
  appointment, 232
  changing defaults, 246
  of group appointment, mailing, 242
removing
  files or folders from workspace, 108
  Front Panel customizations made through the pop-up menus, 79
  Front Panel customizations made with the Install Icon control, 79
  mailboxes, 170
  menu bar from Terminal window, 265
  scroll bar from Terminal window, 266
  workspaces, 80
remsh command, 136
renaming
  files, 94
  folders, 94
  objects, 94
  workspaces, 18, 69, 300
replacing controls in Main Panel, 79
replying to mail messages, 156
resizing
  icons, 290
  a region of an icon, 290
  windows, 14, 298
restoring
deleted mail messages, 159
items in Trash Can, 102
menu bar to Terminal window, 265
palette, 143
scroll bar to Terminal window, 266
Text Editor file, 224
window icon, 13
windows from an icon, 13, 297

Return key, 3
rlogin command, 136
rotating part of an icon, 289

S
saving
Calendar data in a file, 239
document to new file, 204
document to original file, 205
icons, 286
icons with new name, 287
mail attachments, 174
mail message as text, 157
scheduling
appointments, 231
appointments using standalone
Appointment Editor, 254
group appointments, 241
To Do items, 235
screen blanker, settings for, 146
screen control options in Terminal, 275
to 276
Screen dialog box, 146 to 149
screen lock
duration before starting, 149
enabling, 148
screen saver, customizing, 146, 148
scroll bar
removing from Terminal
window, 266
restoring to Terminal window, 266
scrolling
setting in Terminal window, 269
window contents, 21
scrolling window contents, 298
search and replace, in Text Editor, 220
secondary selection, in Text Editor, 210
selecting
an area of an icon, 288
backdrop, 144
check boxes, 20
files, 90
folders, 90
font size, 144
icons, 90
list items, 22, 299
multiple files, 91
multiple folders, 91
multiple icons, 91
multiple objects, 91
objects, 90
palette, 141
radio buttons, 20
text, 15, 210
a window, 10
sending mail messages, 166
session
changing startup, 150
current, 38, 150
determining for each login, 39
home, 38, 150
language-specific, 305
shortcut keys, 25, 294
in Text Editor, 213
sizes of icons, 286
sliders, 19, 21
sort order
changing File Manager, 115
of objects, 115
sorting
files and folders, 116
mail messages, 156
special characters
in Terminal, 277
in Text Editor, 209
spelling, correcting in Text Editor, 216
standalone Appointment Editor, 254
starting
Application Manager, 122
applications in Terminal window, 261
Calendar, 225
Calendar from command line, 256
Command Line Login Mode, 38
File Manager, 86
home session automatically at login, 39
Icon Editor, 281
new icon, 282
Print Manager, 190 to 191
Printer Jobs, 192
Style Manager, 137
Terminal, 258 to 261
terminal emulator with specific language, 307
Text Editor with specific language, 306
startup
changing session, 150
Startup dialog box, 150 to 151
status line
in Text Editor window, 203
Style Manager
opening, 137
starting, 6, 137
Window Behavior setting, 3
Style Manager control, 73
subdirectories
changing to, 99
definition of, 87
subfolders
changing to, 99
definition of, 87
subpanels, 64
adding, 78
deleting, 78
displaying, 65
moving, 70
opening and closing, 65
symbolic link, creating, 98

T

tab groups, 294
Tab key, 295
templates, creating for mail messages, 177
Terminal
bell options, 270 to 271
color control in, 269
control characters in, 277
cursor options, 267 to 268
entering commands in window, 262
Global Options dialog box, 266
keyboard options, 273 to 274
removing menu bar from window, 265
removing scroll bar from window, 266
resizing window, 263
restoring menu bar to window, 265
restoring scroll bar to window, 266
running on another system, 263 to 264
screen control options, 275 to 276
scroll behavior in, 269
setting language through, 306
starting, 258 to 261
starting applications in window, 261
starting Icon Editor from, 281
stopping, 261
Terminal Options dialog box, 272
Terminal control, 74
terminal emulator
See also Terminal
changing the default, 278
default, 258
definition of, 257
language-specific, 307
running applications from, 135
Terminal window
opening in current directory from File Manager, 100
text
alignment, 222
automatic wrapping, 208
copying, 215
copying and pasting among windows, 15
copying in Terminal window, 262
cutting and pasting, 216
deleting, 24, 214
deselecting, 16
dragging, 219
dropping, 219
editing, 201
ing in Text Editor, 220
justifying, 222
pasting, 16
pasting in Terminal window, 262
selecting, 15, 24, 210
selecting characters, 24
selecting lines, 24
selecting words, 24
Text Editor
closing, 202
cursor keys, 209
drag and drop in, 219
dragging keys, 212
entering text, 208
formatting document in, 221, 222
Front Panel control, 202
menu shortcut keys, 213
opening document, 204
printing document, 222
saving document, 204
saving document to new file, 204
saving document to original file, 205
special characters and, 209
starting, 202
starting with specific language, 306
status line, 203
UNIX (Emacs) key bindings, 213
used in other applications, 224
using Undo in, 215
window, 203

word wrap, 208
Wrap To Fit option, 208
Text Editor control, 72, 74
text fields, 19
three-month mini-calendar
Calendar Day view, 228
time zone, in Calendar, 253
title bar, 10
To Do items
changing, 236
deleting, 236
inserting, 235
marking completed, 236, 237
pending, 237
scheduling, 235
setting due date, 235
To Do list
displaying, 236
printing, 238
Tool bar, Calendar, 226
tool bar, Calendar, 227
topic display area, 45
topic tree, 45
TopShadow, 287
Trash Can
emptying, 103
opening, 102
restoring objects from, 102
using, 102
Trash Can control, 73
tree view, in File Manager, 112 to 114

U
Undo, in Text Editor, 215
UNIX key bindings, 213
unlocking the display, 32

V
vacation mail, 166
viewing
See also displaying
mail attachments, 172
mail messages, 155
views
  Calendar, 228
  controlling File Manager, 111

W
Week grid, Calendar Week view, 229
Week view
  Calendar, 229
  changing time boundaries, 247
  Week grid, 229
wildcards
  for finding files, 109
  to search help index, 51
Window menu
  displaying, 26
  items, 26
  keyboard usage, 300
Window menu button, 10, 12, 26
windows
  bringing forward, 15
  closing, 12
  copying and pasting text, 15
  determining how to display
    active, 149
  dragging, 14
  focus policy for, 149
  frame controls, 9
  icon display policy for, 150
  icons, 4
  icons, moving, 13
  icons, restoring, 13
  moving, 13
  opening, 11
  placing in other workspaces, 17, 301
  policy for activating, 149
  removing, 12
  resize border, 10
  resizing, 14, 298
  restoring from an icon, 13, 297
  scroll bar, 21
  scrolling, 21, 298
  selecting with keyboard, 297
  title bar, 10
  turning into an icon, 12, 297
  word wrap, 208
workspace backdrop
  putting file or folder on, 107
  selecting, 144
Workspace menu, 28
workspace objects, 8
workspace switch, 64, 65
  customizing controls in, 81 to 83
  help for, 69
  switch area of, 68
workspaces
  adding, 80
  bringing windows forward in, 15
  changing colors of, 141
  deleting, 80
  displaying, 16
  keyboard navigation, 301
  placing windows in, 17
  removing files or folders from, 108
  removing objects from, 108
  renaming, 18, 69, 300
Wrap to Fit, turning on and off, 208
write permission, changing, 105

X
XLFD, 307
XmNinputMethod resource, 310
XmNpreeditType resource, 310
XMODIFIERS environment
  variable, 310
xmodmap command, 311

Y
Year view, 231